Google - Pixel 4a - sunfish - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

I suggest highlighting the part of the instructions saying " Enable USB debugging on your device. You can find the instructions here" because i missed it
You should also link to google’s page to install the USB driver

“Installing /e/ from recovery” Should be completely rewritten since it is really different from the GUI

Hello friends, let me first start out by saying this is not a step by step installation guide but rather a roadmap to some of the interesting things I found installing 0.18 R onto a used and freshly factory reset Google Pixel 4a (“sunfish”) with Android 11 already installed.

First of all, in my case the bootloader would not unlock from the device- the option was greyed out completely in Developer Options. And so, I had to use the command line as outlined here.

Success looks like this:
Bootloader Unlock Successful2

At some point I lost the USB debugging “authorization” between the PC and device as shown below:
PC Unauthorized
If you see it, there’s no cause for alarm- just “reauthorize” the computer connecting to the device.

A general tip for those new to the Android Platform Tools (ADB, etc.) is to put the /e/ recovery and /e/OS image from here in the same directory as the platform tools so that the processes don’t fail since they’re “right next to each other”…

I got the same error as @lefou did in this thread shown below:

– Wiping data…
Formatting /Data…
Formatting /metadata…
Wiping Titan M
E:can’t send spi message: Try again
E:can’t send spi message: Try again
E:can’t send spi message: Try again
E:can’t send spi message: Try again
E:can’t send spi message: Try again
E:can’t send spi message: Try again
E:can’t send spi message: Try again
E:can’t send spi message: Try again
E:can’t send spi message: Try again
Data wipe complete

Since the wipe said it was “complete” I just went forward. Sometimes fortune favors the foolish!

Sideloading the OS for the first time is always for me the time I hold my breath. This time was no different. I followed these instructions:

It quickly got to 47% and then stopped. I waited 4 long minutes for this message:
I didn't get this message

But I didn’t get it.

Instead, I got this:

Oh no.

Well, in for a penny, in for a pound. At this point, there was no other option that I could think of but to reboot the device and see where I was at.

Surprise! It booted into /e/OS. I’m not exactly sure why!

Hope this post helps anyone else who’s grappling with installing /e/ on a Google Pixel 4a- I will be following up in the thread some thoughts as I use the device over the next few days. There’s already one issue I’ve come across that’s kinda funny and one that’s a bit of annoyance, but this can wait.

Good luck with your install- follow the instructions and remember what I’ve posted here and you should do fine!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

i can confirm that

E:can’t send spi message: Try again
Data wipe complete


(47%) adb : failed to read command : No error
(47%) adb : failed to read command : Success

are known as successful messages

1 Like

Good to know for the next time. Thanks, @piero. :beers:


I bought the Google Pixel 4a to install sunfish on it.

Now I read on the documentation page this:

Warning: Downgrading Smartphones already on Android Q or LineageOS 17.x to Pie or other OS can cause instability or at worst brick some devices

The pixel came with Android 11. I really want to install the OS but now Im a little bit skeptical.

You have any ideas?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

That warning is out of place for sunfish.

If you are running Android 11 now, you are good to install eOS-r. However, if you have updated to android 12 on your device you will have to flash the google stock rom for android 11 before installing e.

More info here if you need it (and elsewhere in the google devices category :wink:)

1 Like

I just want to echo @chrisrg here. If your device is on Android 11, the /e/OS “R” beta MUST be flashed to avoid problems. If your device is on Android 10, you have the OPTION of flashing /e/OS “Q” or updating the device to Android 11 first, and then flashing /e/OS “R”.

Good luck and let us know how things go!

1 Like

Ugrade to 1.15 T (Android 13!!) just went smoothly.
No hickup. 10 min and done!
Great job!

Did you flash it, as in clean install? If you sideloaded it to eOS already on it, from which version did you move to T?

@Manoj Would it be possible to add documentation how to upgrade from R to T or if it needs to be from R to S and then to T would also be fine. I would like to upgrade my stable R to T dev. I was under the impression I would have all vendor updates for T in the image but I don’tlknow how to proceed. I am aware it is a manual thing but I would prefere not to backup and clean install. If no other option is available, than to go stock to make the device ready, so be it.

I installed (sideloaded) S already some time ago and had some OTA-updates. The latest was e-1.14-s-20230819321663-dev-sunfish when T came out.
I followed the steps in the documentation and everything went smoothly.

I just installed to a 4a that had Android 13 stock ROM on it.

Following the instructions as linked above in combination with [HOWTO] an Unified Install Guide Project for /e/ worked very well for me - I completely followed the instructions along and also did the dtbo- and recovery- steps before actually flashing eOS…

Pretty straightforward and fast execution once I had understood that I had to copy the downloadad files into the same folder as adb…or:

… respectively :slight_smile:

And that would be my only suggestion: to clarify that “where to download the files for availability in adb and fastboot”-thing in the guide as it was just unclear for me as an adb-and-fastboot-newby (or maybe I have just overread it?)

Else: pretty cool! :+1: Thanks a lot for the guidance!!!

Edit: for the official pixel 4a-guide (and presumably others as well) it would be helpful

  • to inform the user about the recurring "bootloader is unlocked … " -warning that occurs at every boot once eOS is installed on the device
  • to give clarification on whether and why relocking or not relocking the bootloader is advised …