Google - Pixel 5 - redfin - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

Hello --all,

I follow this guide line by line : Install /e/OS on a Google Pixel 5 - “redfin”
My phone is a pixel 5, with latest android 11 stock from google freshly installed for the occasion.
Developper mode is activated, usb debogging to, and OEM unlocked.
Everything works nice in the tutorial until reboot after flashing recovery img:

$ fastboot flash vendor_boot recovery-e-1.6-s-20221201239247-dev-redfin.img
Sending 'vendor_boot_a' (98304 KB)                 OKAY [  3.680s]
Writing 'vendor_boot_a'                            OKAY [  0.382s]
Finished. Total time: 4.323s

and then when I try to reboot in “recovery mode”, I have always the same error: “error boot prepare”

I have try many reboots, I re-installed android stock several times et re-do the all process, several times
I try with different recovery images… every time the same issue.

For precision, before android stock 11, phone was running grapheneos.

I presume I do some mistake at some point, but I don’t see where and I didn’t find the same case/error in the forum.

Thank you in advance for every suggestion.


It looks to me as if the stock ROM is available in Android 11, 12 and 13

… but …

If you want to install S you should prepare with Android 12 (=S) … or if you prepare with Android 11 (=R) you should download and flash /e/OS R.

It seems both are available

E have messed up the installation instructions yet again confusing users and leading to failed installations.

Please tell what eOS build you want to install. 11 0r 12 android equivalents?

They require different steps for flashing recovery

thank you, for now, I tried at least 3 times with R image and 3 times with S image with the same result. I never tried from android 12. I’ll try asap.

If you are flashing stock 12 with the flashall script in fastboot it would be a good idea to flash both slots to be on the safe side. So flash the active and do it all again by changing to the other slot.

With android 12 on both slots you should be ok following e install guide.

Thank you. And yes I prefer to install S build.

If you are flashing stock 12 with the flashall script in fastboot it would be a good idea to flash both slots to be on the safe side. So flash the active and do it all again by changing to the other slot.

I didn’t even know there is two slots ^^, I set that with an option in the fastboot command?

If you watch the output of the flashing process you will see which slot is being flashed. There is a bit of resizing of the other slot at one point but it’s mostly all done to the active slot.

On your second run, yes , change the slot in fastboot. So if you flashed slot_a (for example):

fastboot --set-active=b 

Then reboot bootloader

fastboot reboot bootloader

It may not strictly be necessary to do this but it worked well for me when I had redfin.

1 Like

Try the /e/ installation by deleting the GrapheneOS custom Android Verified Boot key beforehand.

fastboot erase avb_custom_key

Thank you,
I have done this to, according to the graphene tutorial to Install official android 11 Pixel rom, just before trying install /e/

I installed android 12 for pixel on both sides (slot a, slot b), 12.1.0 (SQ3A.220705.003.A1, Jul 2022) Factory Images for Nexus and Pixel Devices  |  Google Play services  |  Google Developers => no issue, Everytime I allow usb debugging…

So I flash recovery on slot a

fastboot flash vendor_boot recovery-e-1.6-s-20221201239247-dev-redfin.img
Sending 'vendor_boot_a' (98304 KB)                 OKAY [  3.391s]
Writing 'vendor_boot_a'                            OKAY [  0.310s]
Finished. Total time: 3.922s

choose recovery mode : “error boot prepare”

So I also flash the slot b with recovery to,

Same error, whatever the slot I am …


Well, you got the device prepared ok. There’s a few things to try. You shouldn’t need to keep changing slots now.

After flash recovery try unplugging device, power off, boot recovery.

If that doesn’t work try the 1.5.1-s recovery

After flash recovery try unplugging device, power off, boot recovery.

Done, same result :confused:

If that doesn’t work try the 1.5.1-s recovery

flashing done, I unplug, power off; power button + vol down, vol down to select “recovery mode”, same error.

I will retry the all process to see if I missed something.
Is there a way to have more logs from the phone about the error?

I don’t know, sorry.

I recently helped a friend get his redfin onto eos. Flashed the same google build as you onto both slots. This was 25 November, so installing eos 1.5.1-s.
At that time I deliberately chose to follow lineage instructions and use their vendor_boot.img as the recovery. It had an older date than the target eos and everything worked.

You could try the lineage vendor_boot.img linked from their install guide. Pick the oldest dated one. Unfortunately the timings of their new year release mean that we cannot get one with an older date than the eos 1.6 so it may possibly lead to an issue when sideloading. But it would be worth a try to see if it would boot the recovery. That would at least give more of a clue whether the problem is your device or installation software.

If you can boot lineage recovery let me know and I’ll try to get copies of the older vendor_boot from my friend

It works with lineage vendor_boot.img
I can reboot in recovery mode, version 19.1 from there Index of /pub/lineageos/full/redfin/20221207
That’s the oldest available on the website.
Can I try to install the eos 1.6 s build from the lineage recovery?

Yes you can.
Only problem may occur is date issues. If you get ootion to answer a prompt by recovery to “install anyway?”, go ahead.

If it fails to install at the end, let me know and I’ll try to get the older versions.

Good luck.

Also: dont worry if you get a long spi message. Let it finish, then move on.

Ok I try:

Wiping data...
Formatting /data...
Formatting metadata ...
Wiping Titan M...
E:can't send spi message: Try again
E:can't send spi message: Try again
Data wipe complete
E:Signature verification failed

I select : Install Anyway

E:current SPL: 2022-11-05 Target SPL: 2022-10-05
This is considered a downgrade
E:Denying OTA because it's SPL downgrade

after few minutes, I escape from recovery, I presume install failed.

@chrisrg : thank you, I try to find an older vendor_boot.img if your friend still got his own I take it
And now I am curious to undrstand why the recovery images from eos do an “error boot prepare”

Damn! Ah well, bit of progress.
I can try tomorrow morning to get the files. He 's not home today.

No idea why e recovery not working.

My attempts to install /e/OS ‘S’ v1.6 on the Google Pixel 4a 5G (bramble) and Pixel 5 (redfin) have failed. Both times I could not boot into /e/ recovery mode after flashing vendor_boot recovery-e-1.6-s-*. Each time the devices booted into fastboot mode. In the upper right corner the devices showed “Start”.

Two other installations with other CustomROMs based on Android 12 were performed flawlessly and without any problems.

On the Pixel 5 (redfin) with a custom ROM fork of LineageOS code, I was even able to relock the bootloader again in another installation process, since an avb_custom_key' is available.

The source of the error must be in the /e/OS file vendor_boot recovery-e-1.6-s-*


Yes, it certainly looks like it. We got pgp’s P5 flashed with an older (late October 22) LineageOS vendor_boot.img which I was able to find for him. The files linked from LOS install guides would boot recovery ok but not complete the install process due to date mismatches.

I wonder if it would make a difference to extract the vendor_boot directly from the eOS rom with payload dumper but I don’t have the P5 anymore so cannot test. If you fancied testing on one of your pixels I would happily extract the images for you if it helped.