Google - Pixel 5a - barbet - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

1 Like

Where do I report a bug in installation process?

You report it right here. Share the error and if possible the step number in the guide. Other users can also pitch in and share their suggestions. Once we have a consensus of what should be removed, I can have that corrected from the documentation.

I was unable to install /e/os on Google Pixel 5a. I’m following the instructions here: https://doc.e.foundation/devices/barbet/install . In the section " Temporarily Booting a custom recovery using" I complete through step 5 using the vendor_boot.img linked in step 1 of that section. Once I flash the vendor_boot in step 5, I attempt to reboot into recovery mode without success. I’ve tried many different images and still no luck. The Google pixel img I’m starting from is Android 12 (barbet-sq3a.220705.003.a1) and I have it loaded into both slots. Any help would be greatly appreciated and hopefully the doc can be updated. Thank you.

Hello

I just bought a pixel 5A refurbished with Android 13.

In the installation guide, it’s written " Before following these instructions please ensure that the device is on the latest Android 11 firmware.".

Will the installation work with Android 13 ?

Thank you

It is important to read carefully, but there is an error of detail about Android 11.

This is the critical warning

It is important that you know that downgrading Smartphones on OS versions greater than the /e/OS OS version you plan to install, can cause instability or at worst brick some devices. We recommend that you check your current OS version, before attempting the installation.

The download location https://images.ecloud.global/dev/barbet/

does offer /e/OS available in Android 11 R and 12 S

Please check the following link to see the naming convention used by /e/ Android version

The Android R versions are now dated. So you will want to first downgrade your Pixel to Android 12 and then install e-1.12.3-s-20230616300623-dev-barbet.zip.

Downgrade of Android OS on Pixel is made easier than some other brands. Check out

or mentioned here more privacy friendly

Thank you for your reply

So, if I understand correctly, either I wait for version T of /e/Os which corresponds to Android 13 or I downgrade it to Android 12 knowing that this remains a risk even if it is probably less important on a Pixel.

It is a learning experience, every new install !

Risk implies something else … I guess you were not expecting this difficulty. Perhaps it still requires enough reading and reflection to feel more confident in the steps involved.

1 Like

Or you install the Android 13 build of LineageOS for microG available for download here and use it until /e/OS T is available.

Worth checking the LineageOS Installation instructions also, There is a greater chance that they are correct :wink:

Thank you for your answers

I downgraded my phone to Android 12.
It has restarted correctly.

I’m now using the procedure to install /e/Os but I’m stuck at step 6 “Manually reboot into recovery mode”.
The phone remains in fastboot mode

If you have the solution, thank you in advance.

You are already confident with

Boot Modes

Recovery

With the device powered off - hold Volume Down + Power and choose Recovery Mode.

Download or fastboot mode

With the device powered off - hold Volume Down + Power

I feel it would be unusual for the device to remain in fastboot mode, do the hardware key presses have zero effect ?

So first you have powered off from Fastboot mode in order to engage Recovery as per above ?

May devices will resist the first intrusion of non android software – but you do not seem to be reporting that ?

I powered off the phone with the hardware keys while I was in fastboot mode.
After that, I used the key combination Volume down + power.
it returned to the fastboot mode screen, I chose “recovery mode” but nothing happens

Please see if you can try what we do with a Samsung phone.

Of course first do the fastboot flash recovery job again then … @CedricD you saw this late edit ?

From fastboot, kill the power, but don’t allow the existing system any moment to recover.

It is difficult to time, but the instant fastboot dies to a black screen hit the key combo for Recovery.

The result is the same except for one detail.
If I let the phone restart itself, the message at the bottom of the screen is “Enter reason: error boot prepare”.
If I press the key combination as soon as it switches off, the message is “Enter reason: combo key”.
But I’m still in fastboot mode :frowning:

I saw it and I did it but it didn’t change anything

I came back to Android 12 for now.

As it says on the smartphone’s info page: “Command Line: For advanced users, installing /e/OS with Android platform tools.”
While I’m comfortable with IT tools, I’m not a computer scientist either.
If the “Easy installer” method is offered on this device, I’ll give it a try.

This is beyond my direct experience
– android flash tool did not include format data, I guess, as it might not be required in the Google ecosystem ? Am I correct ?

And … a separate idea … Please can you tell us the Android Security Patch Level of your current running system. Check in Settings > About phone (or so).

I can’t tell you, the phone again offered to install Android 13 and I validated, having failed to install /e/Os