"Google sign in failed!", Could not generate OAuth Token

Got /e/ (what do you call it in speech? Slashie-slash is kind of fun? :slight_smile: ) installed on my Fairphone 4 as the stock image for the Fairphone is sort of crumby — not terrible but stale enough to want to try something else.

Anyhow, I’m not terribly allergic to google so I want to sign in to the App Lounge using my google account - accessing previously bought apps and such.

  • I run App Lounge
  • I choose to login using Google
  • Go through the motions confirming the login/device using another device

Then I get the following:

Google sign in failed!
Due to a network error, App Lounge was not able to get Google sign-in data.

Authentification failed : Could not generate OAuth Token

Anything obvious about this that would fix the issue? Otherwise I’ll out up an issue on gitlab later on tonight.

I also don’t want to tear it down, but personally I don’t understand why it’s not just called eOS without those strange characters. I also find it difficult to get used to the name Murena. It’s a historical stripbook series and a fish that doesn’t really look nice. Why that name was chosen is a mystery to me and I don’t like it. But that is of course my opinion.

But…Why do you wanna install a deGoogled android version and thinking that you can still use your Google account? I don´t understand that.

If you choose to have a deGoogled phone, than it sounds a little bit crazy to me for using a Google account. But your not the only one. I would ask this question also to some other users.

If you try a project with a deGoogled version of Android…Why the hell you still want to use a Google Pixel phone?

If i want to stop with Google, i don´t want nothing from Google. :joy:

For me it is the same as having installed Linux on your PC and still use a Microsoft keyboard.

Do you use slashieslash? If you do, why? – it offers integrations to Google services, which according to your take should be a big no no as the mear logotype of Microsoft on a cheap rubber dome keyboard plugged into your Linux box is enough to be a conflict?

Pixel devices are among the absolute top teir of Android phone hardware, of course people should use them and degoogle them. The same way the Asahi Linux team are working on enabling Linux for the M1, M2 chips from Apple. It’s the ultimate in software judo. Take something big corp and judo-flip it into something open and powerful, by the people for the people. It’s also ethical because it prevents ewaste and enables great devices for the common folk.

I look at it as a gradient. You can be more or less involved with Google. From black to white with shades of grey in the middle.

I don’t have the luxury of being able to stand out side the Play Store completely which is why I wanted to check out slashieslash. It offers to minimize my connections to Google yet giving me some access to the parts I need as well as promoting and contributing to a lovely suite of open souce apps. Win win win :wink:

Have a great day :wink:


slashieslash does judo-flip :rofl:

Thank you @linkert you made my day with the judo thing and by made me thinking about


1 Like


Tried a secondary Google account of mine and it worked just fine! Not that it provides any practical use to me other than showing it’s something to do with my OG account from the olden days that is acting up.

So what are the differences?

Well, the secondary account is rather new and untouched so to speak while my OG account is what I call a “semi-gsuite” account.
Back when I was a gmail user I wanted to use a custom domain for my gmail account, so I payed for said service which was called “gsuite” but is now “Google Workspace” (I think). Once I stopped paying the account kept working for most services except Docs, Sheets and Gmail — the office type services. YouTube, Play Store and such where fine.

I tried turning off 2-factor auth for seeing if this made a difference since my “New” account worked and it does not use 2-factor auth. Sadly same issue with the OG account even with 2-factor auth turned off.

Anyone out there with a google account that have previously been part of Gsuite, used a custom domain but is no longer a payed for Gsuite account that can confirm this madness?

This topic was automatically closed after 90 days. New replies are no longer allowed.