GS290 Bluetooth error (No Pairing)

I bought a gs290 on which I ran easy install with Linux (manjaro) perfectly smoothly.
Everything works (even banking app !!! webank, Italian bank)
But although the BT is able to pair with a BT speaker correctly, the connection with the car’s system cannot be completed.
I have a 2019 toyota corolla.
The system sees the gs290 but is not paired correctly and is not registered!
With stock roms, on the other hand.
Android auto also doesn’t work although I followed the guide on xda to get AA working with microg

Have you had similar experiences?
Did I have to enable something?


Hi @Lucky_luke here is an Android troubleshooting guide, I wonder if that can help?

Bluetooth often crops up as problematic, you might search our Gitlab issues:, many fewer issues are actually recorded against GS290[]=GS290&search=Bluetooth

Getting Started on /e/OS

You can also try to change names (both car & phone) to something simple (less than 8 chars, no symbols or space).
It helped me in the past with a Lexus.

1 Like

nothing’s not working

an update :

There seems to be a problem with permissions.
The pairing appears to be done, but not completed correctly.
The CONTACTS connection is made
PHONE connection is NOT made
AUDIO PLAYER connection is NOT made.

then the car display indicates “unsupported phone” and “unsupported audio player” and the pairing is not carried out giving “error”.

On the gs290 in the BT section, there is the “toyota touch” connection but with only the “contact synchronization” active.

Obviously it’s unusable.

I noticed that if I do:

  • “app and notificaton”
  • show all apps
  • top right active “show system”
    I look for a bluetooth app, and I press “permissions”,
    I get that I have permissions for:

contacts (and indeed those seem to log them)
call log

there is no telephone
there is no audio player

Permission problem?

So, It may also be your Toy not enumerating all capabilities, or not understood by your phone :frowning:

Same here, and (at least) phone is working with my car.

i just performed a revert to stock on the gs290.

With stock rom the BT pairing is done correctly in 3 seconds (phone, audio player, contacts)

This indicates that there are no hardware incompatibilities between the gs290 and my toyota.

Evidently it is the /e/ rom who has problems.
at least in the BT module … driver problems or settings?

If there are no updates I am forced to remain stock.

due to the issue you raised here with BT on GS290 I was checking the function on my side.
One year back BT was not working properly for each device. But finally the developers made it.

So I checked the capability (GS290, vers. 0.19, stable) to establish a connection with my logitech headset (H 800) and also with the a car (ford focus).


  • Everything was working.
  • No echo during the call
  • caller list etc.
  • Initial problem with pairing.
    Solution: I reset paring on the headset and the headset was recognized by the phone.
  • was able to listen to music
  • was able to change volumen +/-
  • was able to move forward/backward on the playlist.

(Pls. not I did not fidle around with any permission settings at all).

Ok, it is not a solution for your issue, but it indicates that there is not a general problem.

Have a nice day.


ok … but I don’t understand why with stock roms everything is ok and with the e.19 it synchronizes ONLY the contacts and not the phone and audio player …

Is your ford focus recent?
I have a corolla 2019 with update to android auto of 2021 (april)

I don’t know … maybe it’s the BT version …

this seems to be a general problem with /e/ OS and newer Toyotas. I have the same Problem with my Toyota RAV4 from 2021.

But pairing on my Skoda Kodiaq from 2017 works fine and even pairing on Toyota Auris from 2010 is no problem.

So there must be an issue with newer Toyota models.
The Toyota RAV4 supports these Profiles: HFP, PAN, SPP, OPP, PBAP, A2DP, AVRCP, MAP

Would be great if this could be solved.

I have the same problem to pair my GS290 with may car (mazda). I have two phones, one /e phone, the GS290, which cannot pair with the car, and another phone (google phone) with pairs without difficulties. I observe the same differences as Lucky Luke as far as permissions are concerned : no phone permissions for bluetooth for the GS290 (/e phone) but this permission is present on the google phone. Its seems then logic that it is the lack of phone permission which makes the pairing impossible.
screen of the google phone when paired :

screen of the GS290 when trying to pair without succes :