GS290 is in bootloop after updating /e/ OS

Since some time I’m using a Gigaset GS290, first with Android 10. But to regain my privacy I found /e/ OS and installed it one month ago.
All was running fine, with all the Apps I need. And yesterday came the info that a system update is possible (0.13_…) and I installed it.
After some time the phone was rebooting but I must notice that this is running constantly (about 30 seconds to a minute it shows “Gigaset” in red and “Powered by android”) but it never stops rebooting !!!
Pressing ON/OFF or other buttons (also a long time) nothing can stop rebooting!
What can I do? Can someone help me to use the phone again?

1 Like


I did a fresh install of /e/OS 0.13-q on my GS290 to upgrade OTA to 0.15-q and I didn’t face any issue.

I suggest you to reinstall everything (without wiping):


Go into fastboot mode (press Power + Volume plus until you enter into something. In case you enter into the recovery mode, go to “Advanced” > “Reboot to bootloader”).

fastboot flash --disable-verity --disable-verification boot boot.img
fastboot flash recovery recovery-e-0.14-q-2021012698290-dev-GS290.img
fastboot flash system system.img
fastboot reboot
1 Like

It’s not possible to go into fastbootmode. After pressing <Power + Volume plus> “Gigaset” in red and “Powered by android” is shown but this is running constantly and repeating all 30 seconds to a minute.
Any other help how to stop this bootloop?

Indeed if I keep pressing these two buttons, it just reboots everytime.

So sometimes I released these buttons, sometimes I pressed on them and and quickly went into the recovery mode. Now you can go to Advanced > Reboot to bootloader.

Just try to play with these two buttons and you will end up somewhere.

if I press <Power + Volume minus> | <POWER + VOL(-) >at the same time and as soon as it shows “Gigaset” in red and “Powered by android” I release both buttons, after a few seconds (which feel longer) I get into TWRP or eRevovery. From there I can switch to bootloader mode (fastboot mode).

The FASTBOOT mode is then displayed in tiny letters at the bottom left.

Thanks, Anonyme and Suzie Q, I did so many time in all variations, but my GS290 never changes in a recovery, TWRP or Fastboot mode. Allways “Gigaset” in red and “Powered by android” only is displayed.
I do not understand why it doesn’t find an other status. May be softbricked now but how can it be freed?

Do any of these resets do anything for you?

No, nothing of these infos are changing anything with the GS290.
When I connect it with my PC over USB and open the device manager I find in “other devices”: “MT65xx Preloader” about 10 sec during the display is black.
When the display shows red “Gigaset” about 20 sec no other device or mobile is shown in the device manager.

Thanks for trying. Experienced advice says keep pressing buttons in an organised or random way!

While you continue to experiment to get that to work, you could file a ticket at Gigaset.

MT65xx has also been displayed in my Windows Device Manager, as have numerous other designations. It always helped me if I temporarily updated the driver software, for example:

Right click on the Android Device “MT65xx” > Update driver software > Search for driver software on the computer [manually] > Select from the list of device drivers on the computer > [x] Show compatible hardware > Android Composite ADB Interface [select] > Next > The driver software was updated successfully > Close. Now the Windows Device Manager shows under ‘Android Device’ | Android Composite ADB Interface instead of ‘MT65xx’.

If nothing works anymore, I would now let the device run in bootloop and wait until the battery discharges and the GS290 switches itself off. Then just charge it briefly and try if the fastboot mode works.

Hi @HaMi,what is your status quo? Were you able to stop the bootloop? Did you find a solution and your GS 290 works again with /e/ OS ‘Q’?

Hi SuzieQ, thanks for your interest on my problem!
The driver update didn’t work, because the GS290 allways changes ON/OFF.
After waiting for completely discharging of the battery I connect it to the charger, but it immediately returns to the described bootloop.
Now I will file a ticket at Gigaset. Hope they can give me a helpful hint.

Hi @HaMi,
I had the same symptoms today as you described with my GS290. It only ever displayed “Gigaset” in red and “Powered by android”. I fiddled around with it until nothing worked. Now the screen is black. Nothing works anymore. It can’t even be charged anymore. It’s dead. That was a short acquaintance.

1 Like

Hi ,

Did you tried to install a old version of twrp.
One time, i had difficulties with a phone.
And i resolved the problem by installing a precedent version of twrp.

1 Like

Hi, I tried anything but my GS290 never changes in a recovery, TWRP or Fastboot mode. Allways “Gigaset” in red and “Powered by android” is displayed only.
Also tried to get help from Gigaset service portal, but they answered that I should clarify it with my dealer.
Hed will not give me guarantee when I changed the software by myself.
So it seems that I have softbricked my GS290 with /e/ OS ?
Or is there an other hope for get running my phone with /e/ ? Help from /e/ foundation/service possible?

1 Like

I have been reading about SP Flash Tool as I have a MTK based MediaTek device. @SuzieQ did you already check out whether this might be an option for GS290?

1 Like

Hope to get some help from third party? No, I haven’t. I’m not asking either because the answers are predetermined. Changing the Orignal operating system has risks that the user is responsible for. I have written off this hardware.

It’s a tiresome topic that Gigaset does not provide an official stock Android 10 for the ut SP Flash Tool and the user has to make use of a capped ROM.

Try to press only Volumen up while reboot starts. Release when Gigaset Logo appears. Then you should geht the selection of recovery, fastboot and normal mode. Facing the same issue while tried the first flash…

1 Like

I’m looking for a complete ROM official Stock Android 9 and/or Android 10 firmware for Gigaset GS290.

So far I’ve not found an alternative to this download URL. Do you know an link that makes me happily?

1 Like


dont want to paste the direct link due to compliance reason. Search in web for Rúben Carneiro villa phone repair. You can find all you need…