GSI Boot Loop no matter the GSI

So I’ve had /e/ installed on my Pixel2XL (taimen) before. I previously used the “e-pie-20190827-UNOFFICIAL-treble_arm64_beN.img” file back in 2019 when it was new. Didn’t have any problems installing it.

Since then, I have tried other ROMs and have went ahead to Android10. Now I am unable to get back onto /e/ using the official sideload release (which has been reported to be bad regardless) or using the GSI package. From what I can gather, some people have had issues once they have reached Android10 because it changes the bootloader.

About my attempts: I have downgraded back to Android 8, flashed two different vgmetas I found (one was zero’d out), installed the GSI using TWRP (3.3.0) and fastboot. Have tried erasing and not erasing cache, dalvik, formatting, ect. No matter the install, the end result is the same: the recovery is replaced with LineageOS’s recovery (what /e/ uses) and the phone resets after a short time on the google splash screen. To be more specific, the phone crashes about 6 seconds into the boot and reboots. The log recovered shows very very little and shows this crash 6 seconds in.

What is happening? I have tried other GSIs too with no success at all. I can still flash the OEM roms and custom roms. Just not GSIs.

PS: I have tried the “20190827” GSI that worked back in 2019 for me, and it wont work either. I think something is borked with my phone thus preventing the boot.

I was able to install bliss using the GSI by injecting Bliss’s GSI (as the system.img) into the official stock 9.0 android. What an odd technique seen here: https://forum.xda-developers.com/project-treble/trebleenabled-device-development/rom-blissroms-9-0-official-4-4-2019-t3918303

Unfortunately this did not work for /e/. The end result of /e/ is a screen that says: “No command” (not a part of any OS)

Yesterday after testing Magisk on GSI I’m running into an issue like yours. All GSI I have flashed a running into bootloop. I have solved the issue in the way with first flashing ‘normal’ treble enabled rom (lineage 16 for my device). Than I was able to go further with eOS GSI and also with AOSP-Q GSI’s.
And a wipe or better format of data is absolute needed before flashing a GSI

wiping data is my go-to when installing ROMs. My normal process is:

  1. install Stock android of version x (8,9,10)
  2. wipe cache, data, dalvik
  3. install custom rom

This hasn’t gotten me further. Could you post your exact setup so I can mirror it? I did the process you recommended with Bliss with no success.

This won’t work.
You can try this way [HOWTO] install eOS GSI on a Treble device - new GSI added June 14th

Coukd be that the vbmeta.img could solve your issue

[HOWTO] install eOS GSI on a Treble device - new GSI added June 14th was the first source that I tried for the GSI process. I have followed the guide step by step and have already flashed vbmeta to the vbmeta partition. I probably should have mentioned that this was the original source material that I used. I initially didn’t mention it because it’s the boilerplate method of flashing roms.

(flashing vbmeta disables verify boot. it’s already disabled in all my cases but I flash it again for good measure)

This won’t work.

Why would replicating the process that you did not work?

So just to be clear: I am not inexperienced at flashing roms with android. Due to none of the GSIs/official ROMs from e.foundation working, I have resorted to a multitude of different experimentations. I have put more than 8 hours into trying to get this ROM installed. Here are some of the things I have tried:

  1. I started every flash on a clean advanced wipe.
  2. I always flash the official OEM android version (8,9 or 10 depending on the matched rom version) (after running out of options, I have also tried NOT flashing the stock android. but I dont see how that would be any different. but I have)
  3. I always format the data before the next step
  4. flashed every ROM (non-gsi) I could find on this site for pixel2/Taimen.
  5. flashed every GSI I could find on this site.
  6. after every failed attempt, I flashed my vbmeta (which is a blank file btw).
  7. after every failed attempt of the previous, I formatted my data and cleared cache/dalvik

During moments when I run out of options, I try crazy solutions like throwing in more formats, I reflash the roms again and try other rom sources to verify my technique.

Almost every single rom on xda-forums is flashable using my technique. My technique is the recommended technique for clean-installing roms. vbmeta is mentioned in almost every post for the taimen device, Im no stranger to vbmeta. It’s not the issue.

PS: e-pie-20190827-UNOFFICIAL-treble_arm64_beN.img did once work for me. I even backed up this file because it worked for me back in 2019. Some variable has changed causing it to no longer work on my phone. Does Android 10 mess with the boot loader? Does it restructure something?

I just realized that’s your guide :stuck_out_tongue:

I’m sorry, but I think you have shoot something with your Android 10 tries. That’s why I have written you shoukd try once more at beginning.

The only thing a can recommend is, starting at beginning with stock rom.

And by the wsy, it makes no sense flashing any GSI. The GSI MUST fit for your device. You have to know is your device a arm, arm64, a a-only or a/b device to find the right GSI for you. All other GSI will fail and could break your device. It’s like tring to mount a ferrari engine into a VWGolf.

Sorry, but the result if this wild flashing you will have now.

I rally.think.the best solution is starting at stock rom

There is miscommunication here. Ill try to be blunt:

I flash a stock rom every time.

I only flash arm64/ab GSIs.

Ok, your above list tells different.

And your are flashing the normal stock rom from google ? And it boots ? If yes, pls stay there and run treble check and post the result and wait.I will have a look tommorow.

It does not. My above list specifically says:

  1. I always flash the official OEM android version (8,9 or 10 depending on the matched rom version)

OEM means Original equipment manufacturer by the way. Meaning the official android release from Google.


Yes I am able to run the “normal stock rom from google”. It boots. Running Treble check shows me that the Pixel 2 XL has a a/b scheme and is arm64.

What GSI works for you?

I’m using the gsi from my howto. My device is a a-only device

Here is a guide for a/b pixel3xl. It seems you have to flash the gsi on both slots

By the way, in telegram group is a gsi specialist available. He was just helping a guy with audio issues on pixel 2xl. So if this xda guide won’t help, you could try in telegram group

Just seen your post on redit. I never have seen a answer/solution on redit posts. Wish you all the best.

I have found this. Headline sounds interesting. I haven’t watched it, because I hate video tutorials

Interesting. Ill give it a shot (flahing both a/b as in that guide.)

On a side note: Its too bad the Pixel 2 isn’t getting any more /e/ updates :(. I guess it’s too old now?