[GSI] Q-GSI --- new version download location. See post 73

No, I don’t think so

@Sean i have also got sm-t585 (lte version) of tab a 10.1 2016, but can’t manage to run any of gsi. i have followed the steps in the xda post https://forum.xda-developers.com/t/project-treble-sm-t580-sm-t585-20190401.3917465/ , flashed twrp, treble.zip, then an img of android 10 gsi, but after install, it won’t run. how did you manage to run android 10 gsi on the tablet? what’s wrong with this? i repeated so many times the steps, but all end in bootloop. could u help me? thx in advance.

@asgara sorry I never attempted a gsi on my T580 tablet I ended up installing XtendedRom and also tried lineage 17 rom for android 10 versions.

@asgara, when installing a GSI ROM, a supporting element is the part VENDOR.

Did you also fill the newly created partition /VENDOR with the necessary data before re-booting into GSI system?

Thank you for building, @anon26953564

Android security patch level: 5. Janury 2021
/e/ version 0.14-q-20210206-UNOFFICIAL-


The new versions of today are in upload, will take a few minutes.


They have the security patch from 05.02.2021

@anon26953564, thanks for the ROM-building. Your new versions form March, 25 2021 still going very well on my treblesized Galaxy A3 2017 ‘a3y17lte’.


Security Patch Level 5.3.2021

1 Like

New Images from today online, but Security Patch from March, not from April.

Happy flashing :joy:



With official q-GSI builds, will you build again or work on ‘R’ GSI ?

Anyway, thanks again for your work, my little Samsung a3y17lte runs /e/ smoothly as daily :wink:


Thank you for your builds. Your last 20210511-bvS build works fine on my A320FL.
I’ve also tried official GSI /e/ build 20210426-bvN and it doesn’t boot (/e/ bootloop). I know there are different ways to build but i don’t know what could be the differences causing this issue.
I hope your Q builds will continue to exist (at least time to time) because i don’t think there will be official builds working fine on the A320x as yours do.

Has anyone tried official GSI build and has it working on A320x ?

I will continue to publish my builds for now, they are still based on Android 10. Unfortunately, I really have no idea how to create them, or where to change what to change the Android version, for example, to 11 or 12. That /e/ now offers the GSI officially, I also heard today.

Did you just install the official GSI as an update? Maybe you should reinstall it cleanly.
As written, I will continue to create “my” builds for now. I myself also use them.


Thanks a lot. I will try both official and yours, with clean install…

Glad that you will continue to make your builds for now.

Concerning official GSI build, I’ve installed it cleanly (format data, wipe everything except external, and wipe caches after flashed).
I have to confess that I modify builds before flashing them (remove some apps, and part of firmwares and librairies related to bluetooth, wifi and gps) but my mods work fine with your builds and some LineageOS based roms (unofficial LOS17.1 and crDroid 6.x for example). I don’t know why it doesn’t work with official /e/ GSI.
I’ll be waiting feedbacks from trefix and others to see if it’s related to my mods or if a3y17lte needs something missing in the official build to boot/work properly.

EDIT : Without any mods Official GSI image boots and seems to work (not fully tested).
So my mods are the cause of bootloop although they work on this unofficial /e/ build, LOS 17.1 and crDroid 6.x. I don’t know why, but that’s a problem I have to fix myself. Waiting for more tests from other users and for the moment I will use this Unofficial build which is perfect for me.

I m using 0.18 q (unofficial) on my Mido now.
Now I want to install /e/ Os (official) for regular use. Can you guide me how to uninstall 0.18 q unofficial and install 0.17 n Official Version of /e/ ?
Thanks in advance

download is missing from the original location, and the other link requires an username and password, how do we access these gsis?


Once you know which system image you need, download it

Is this only available on treble enable devices?
My a3y17lte is not Treble enabled.
I have tried this method but cannot get it to work.
booting to bootloader doesn’t work on my device for some reason ( always goes straight to normal boot or gives error)
tried installing ZIP with OrangeFox and TWRP, Both give error for invalid zip format.

not 100% sure, but i think @trefix or @OneThumb may help you preparing your device for treble