Help installing /e/ on Galaxy J7

I buy a Samsung J7 model SM-J700F as described in /e/ documentation.

After a lot of researches, I found that I can have device information with adb from the file /system/build.prop. Instead of having j7eltexxe as codename I got this

I found device information based on lineageOS project. The main issue is the SoC is not Exynos as it is recommended but a Qualcomm MSM8929 Snapdragon 415. By the way, device documentation on /e/ website describe the SoC as a Qualcomm MSM8939 Snapdragon 615 (28 nm)

Do you think I have a chance to install /e/ on this device ?

If the answer to the question above is yes, I have another issue with the OEM unlock option in developer mode. It seems that Samsung locks this option with KnoxGuard during 7 days before we can get it available. I don’t find any solution to bypass this.

Does this “security” lock is also in Lollipop ? With my readings, I am not sure about it. It seems it’s only in android 6.x and 7.x


Hi, welcome to our community :slight_smile:

According to the information you provided, your device isn’t compatible with /e/. Do not try to flash it if it’s not exactly the same codename etc.

But the SM-J700F is supposed to be compatible so this is weird. I’m not an expert on how Samsung name their device…

Thank you for pointing that out, I will dig in and report it.

The good news first: Your SM-J700F is supported by /e/ OS dev (oreo) codename “j7eltexx”.

Samsung Galaxy J7 Edition SM-J700F models supported by /e/ OS are: SM-J700F/DS- H/DS - M - M/DS are equipped with a SoC Samsung Exynos 7580.

The codename “j7eltexx” is used in conjunction with LineageOS primarily with UNOFFICIAL LOS builds.

The linked j7eltexx page in the /e/ documentation only shows the error message “404 - Page not Found”.

The /e/ codeword “j7eltexx” is derived from “j7elte”. But there is also a current TWRP recovery version twrp-3.3.1-0-j7elte available from TeamWin - TWRP.


Samsung’s Galaxy J7 is available in three editions: 2015, 2016 and 2017. The variety of models leads to irritations.The indication under in the /e/ documentation under »Device Specifications: SoC Qualcomm MSM8939 Snapdragon 615 (28 nm)« is wrong.

Samsung’s Galaxy J7 SM-J700F specifications on → SAMmobile and → GSMarena:

@liochan, here you find all the latest Samsung firmwares for the Galaxy J7 SM-J700F.

If your new SM-J700F is running a firmware StockROM 9.0, you may need to downgrade it to in order for /e/ for j7eltexx dev (oreo) to work properly.

Thank you :slight_smile:

It seems so… I was not really aware of everything when I choose this phone. I learn :smiley:

Yep that’s something I don’t understand. I thought the model was enough to get the right phone.

According to a lot of source the SoC is Exynos 7580

I thought it too, when I bought my phone to somebody, I just asked for the device model “SM-J500FN”.
Could the information provided by adb be wrong ? Or vice versa. It doesn’t seem logical.

What I would do (I don’t know if it will be useful though) : When you remove your battery, there should be a tag with IMEI and probably the device model (SM-J700F).
With this model name, I would then download the right firmware on sammobile (free account, approximately 1h to download). Select your country, not your operator/ISP, it’s not cecessary you will have bloatware from this operator. By the way, keep it somewhere it’s always useful to have the original firmware in case of trouble.
Then I would flash it with Odin. After that, check your codename with adb again.

@archie thank you very much for your time and message.

I bougth the phone on aliexpress and even the specification is talking about a Qualcomm SoC. Maybe it’s a copy and not a real refurbished one as announced.

This the /system/build.prop

# begin build properties
# autogenerated by Aug 27 13:21:19 KST 2015
# ro.product.cpu.abi and ro.product.cpu.abi2 are obsolete,
# use ro.product.cpu.abilist instead.
# is obsolete; use ro.product.device
# Do not try to parse description, fingerprint, or thumbprint 5.1 LMY47O J700FXXU1AOH5 release-keys
# Samsung Specific Properties

The chipname MSM8929 and the codname j7ltechn are corresponding with the description on lineageOS

I think the best things I have to do, it’s reselling the phone because I can sell it at the same price. I will take time to search the good one and buy it on my country even it’s not the same.

@Anonyme: thank you for your answer !

I dug a little more thanks to your information.

@archie : with your link to gsmarena I find that models with Exynos haven’t NFC, but models with Qualcomm has NFC. Bad news, my phone has NFC :smiley:

@Anonyme : based on IMEI number the model is SM-J7008.

I think I am done and I can resell it without any regrets :innocent:


the chipname MSM8929 belongs to Qualcomm Snapdragon 415. There’s no doubt about it;

The official WinTeam TWRP does not know the codename j7ltechn, but following four editions:

Samsung Galaxy J7 (2015 Qualcomm Sprint) (j7ltespr)
Samsung Galaxy J7 (2016 Exynos) (j7xelte)
Samsung Galaxy J7 (2017 Qualcomm Sprint) (j7popltespr)
Samsung Galaxy J7 Exynos SM-J700 (j7elte)

The right TWRP is important for /e/ OTA updates. I don’t know if there are any differences between /e/ j7eltexx (aka j7elte) and j7ltezm as well as j7ltechn (=

Be careful, because shopping at aliexpress or Amazon “Market Place” brings especially high risks.

#6 “I think I am done …” Yes, that seems to be a good solution…

This explains everything. The SM-J7008 is specific to China. So the codename you found, “j7ltechn” (chn for China), makes sense now.

@archie : thank for editing, I was getting confusing about TWRP :smiley:

I know the risk and this time I loose ! According to /system/build.prop I see this


It’s not an octa-core but a quad-core. Two models are good candidate SM-550F and SM-J5008, but the last as also a codename j5ltechn.
I don’t know if it’s possible to fake information.

But the situation is waking up my “hacking mojo” ! Good case to do some forensics :rofl:

I assume that all digital data is manipulable.

07.04.2017 | heise online

On online marketplaces such as eBay or AliExpress, USB sticks with large capacities are available for little money. These are often counterfeits, says the North Rhine-Westphalian consumer association Verbraucherzentrale Nordrhein-Westfalen.

or 27.03.2019 | Fake USB sticks and SD cards

© Translated with (free version)

1 Like

Really good readings, but I didn’t pay 10x less just 20-30% less. The other point was I found it only available on aliexpress as refurbished in french market.

I installed apps from f-droid (cpu info and android explorer). So I was wrong about the cpu, it is an octa-core Qualcomm MSM8929 Snapdragon 415. I also find that my phone is rooted.

Also my bad @Anonyme, but I am learning about devices. As you state, it makes sense now.

So j7ltechn and j7ltespr are same devices according to and And this page achieve to clarify this point

Common Tree for Samsung Galaxy J7 (j7ltespr/j7ltechn)

So my plan is

  1. Install Official TWRP App. Because my phone is rooted. It will help to bypass 2 issues. I am linux user, I can’t use Odin. I can’t use Heimdall because of OEM unlock options issue.
  2. Backup existing recovery and boot with TWRP App
  3. Install TWRP Samsung Galaxy J7 (2015 Qualcomm Sprint) ( j7ltespr )
  4. As adviced by @Anonyme install the right firmware from sammobile. Fun fact, with Android Explorer, bootloader is J7008ZMU1AOH5, which is corresponding to a PDA number in firmware list. Perhaps I can try to install firmware of SM-J700F model ?
  5. Install unofficial lineageOS 15 for j7ltespr
  6. Learn how to create a /e/ Rom based on lineageOS Rom to provide an ROM for j7ltespr/j7ltechn. Possible ? Quite long ? :smiley:
    Edit : doesn’t look impossible or quite long (for me) I just read the documentation page, so the build looks possible by using j7ltechn model and create a new unofficial ROM.

Thank you very much for your help !

My plan is perfect, it has failed quickly :rocket:

I have been successful to install TWRP App.

I did a backup of the stock recovery. I also have done an error, I backed up the bootloader, but I didn’t take care that it has overwritten the backup of the recovery as the filename was the same. Now I have no recovery :upside_down_face:

I installed TWRP for j7ltespr. When I rebooted to recovery (device button), my screen was displaying vertical colored lines, nothing clearly visible. After that the screen was black. So the recovery is not working.

I rebooted and I installed stock recovery backup. I tried to reboot in recovery mode, but the device only rebooted to android. It was at this time that I was understanding my mistake with the backup of the bootloader.

I did another mistake. I retried to install TWRP j7ltespr. I used abd reboot recovery command in linux. Now I am stuck in boot recovery loop. My other option is to reboot in download mode (device button). If I start the device with the power button, the device is trying to boot in recovery anyway.

I am downloading from sammobile the stock rom for SM-J7008. I will find a windows device to install odin and I will reboot to download mode. I will give a try with Heimdall first.
But I am still not sure if it will help me to install the stock recovery. Anyone knows about this ?

After the next step is to compile TWRP for my devices. I don’t know if it is possible yet :smiley:

For your information, once you will restore your phone with Odin and the file from sammobile, everything will be erased. Custom recovery too. And the stock recovery will be installed.

@liochan, does this from SamMobile downloaded StockROM consist of a 1-part or 4-part firmware?

If your system or memory is damaged, it may only be possible to fix it by flashing a 4-part firmware with pit file.

All the firmwares I’ve downloaded from sammobile was one file.

Well, on the website of sammobile they talk about “You should get 5 files”.


Whatever: A download speed of 15 kB/Sec is an imposition even for non-premium members. Therefore I use other faster and free sources.

@Anonyme and @archie thank you a lot for your support.

The file downloaded from sammobile is a .zip archive containing a .tar.md5 - this extension is non-sense - which is another archive containing 12 files including recovery.img

With heimdall and download mode I installed the stock recovery. I could reboot to android and the stock recovery is working again :star_struck:

It didn’t reset my phone with the stock rom, but it is not something really important as the device has no data neither a sim card connected.

So now I will start to read all documentation to compile TWRP for this device :innocent:

Please keep us updated on how the compiling TWRP goes :slight_smile: I think this would be a first for this forum. We usually get users who compile ROM’s for the smartphones.

For now it’s giving me headaches :smiley:
For newbies this kind of tasks aren’t easy. Documentation is lacking, I mean for starting level, you have to already know how things are working, but community support is good. I think it will take a lot of time, but I am still motivated to do that.

1 Like