Help installing /e/ on Galaxy S9

I just managed to install the software yea!

This is very pleasing :ok_hand:


It would be interesting and certainly useful for other potential users if they could say here how you avoided the initial difficulties - for example, what did you do differently than before? All for one and One for all.:v:

1 Like

What i did was unzip the install file using archive utility. the file had a zip.cpgz thingy and i could install that. I tried a second time but it didnt work. If you are struggling to install e on a mac give that a go.

Hello there,
I originally came on this topic for the same reason as @cosmin, i was (am) getting the E:footer is wrong when trying to “Patch de device”.
I followed along the thread and decided to try installing TWRP first as @Anonyme recommended.
Following the instructions in the next step I am getting the same error as @Frank, Only official released binaries are allowed to be flashed(RECOVERY) when trying to heimdall flash --RECOVERY twrp-3.3.1-0-starlte.img --no-reboot on the “Downloading screen”…
I am on a Linux system, I succesfully enabled OEM and my phone model is SM-G960F (which should be supported).
How do I get through this? heimdall print-pit does work but simply reboots the device, I don’t see the point of it.
As @archie suggested we could (should) make a sum-up of these errors and maybe update the installation guide accordingly, I personally haven’t been able to find the part I am missing in this thread while at least 2 persons went through that, can anyone share his story?

@ROM, I tried the tool heimdall under Windows® and uninstalled it very quickly. With Samsung’s ODIN3 I have collected best experiences.

Also under ODIN3 the immediate restart is known after flashing TWRP Recovery with file twrp-3.3.1-0-starlte.img.tar - and is deactivated there in the options.

The decisive point to success, however, is the complete manual switching off of the device:

This forcing to switch off the device causes TWRP Recovery to remain installed during my flash operations and not to be overwritten by StockROM Android Recovery again.

To switch off the S6 Edge I had done the following:

  1. press VOL (-) + POWER + HOME simultaneously - and wait patiently …
  2. but exactly at the moment when Samsung device goes out, i.e. the display turns black, …
  3. change from VOL (-) to VOL (+) and press all three buttons simultaneously {= VOL (+) + POWER + HOME} …
  4. the Samsung LOGO shows up
  5. wait a few seconds … until TWRP is displayed.

Thank you for your advice @archie, however I had completely forgot to mention it but I use arch BTW :smile: and I haven’t used a Windows machine in years (I don’t even own one anymore).
If there is still a way to go on Linux I would like to follow it, as it would seem morally wrong otherwise… After all if we are using a mobile OS for privacy reasons we should be able to install it from another privacy oriented system rather than through Windows…
Will edit my post for others coming later

It offers ADB and Fastboot. It is available for Windows, Mac & Linux.

Data protection under the Windows® operating system is very easy to handle. The reliable MS Windows® 7 and Samsung ODIN3 can be used offline, without internet connection.

My PC (work and test computer) consists of a dual boot system: Windows + Ubuntu. This gives me the possibility to try different installation possibilities of customROMs.

I have no moral concerns when using these operating systems and tools. What counts for me is the successful installation of customROMs.

@ROM
I did it on Mint a week ago (edit: using Heimdall, to be clear). I hit the ‘only official binaries’ wall, too, and my understanding was that I triggered the 7-day lock by allowing the stock ROM to boot (a whole thread around it here, there was also a very informative recap post on how it exactly works, can’t find it now), eg the OEM unlock was gone from dev options, but to my surprise I was able to flash TWRP when I tried two days later. Maybe the cool-off was shorter in my region or something, I don’t have the answer as to why.

The terminology “Only official released binaries” I haven’t met it not yet in connection with flashing customROMs.

Samsung’s ODIN3 and Samsung smartphones harmonize very well with each other. Even the subsequent upgrading of /e/ OS with a new bootloader/baseband firmware or the bottles of a 4-part StockROM firmware works very well.

Whatever that may be: Every user can choose his tool to switch to /e/ OS. And every /e/ user is welcome in the /e/ club.

Sorry, what offers ADB and Fastboot, again?

You can’t seriously believe that I’m discussing with you a lá @harvey186 /e/ support continue …

Your question “What does “/e/ support” stand for on this forum?” is enough for me.

I seriously believe that the quality of posts on this forum varies greatly from kids running wild to useful and informed advice.

Now, if you were claiming that it’s Odin that offers ADB and Fastboot, which I believe you did but I wanted to make sure, you were wrong on both accounts.

I just checked on the official Samsung Odin website and it clearly states

  • This tool only works with Windows Computers
  • Use Heimdall for Linux/MAC OS

Following your suggestions @reb77 I tried to reenable OEM, it helped but it’s not the end of my problems.
I followed this guide to enable the OEM without waiting a full week. When it appeared, the OEM switch was on, which isn’t too surprising cause I had enabled it previously, anyway I don’t know if it changed much but when trying again to flash with Heimdall I don’t meet the official binaries wall but the process is stuck.
I tried restarting the phone on download mode (Power + Bixby + Volume Down) then plug-in cable and flash with Heimdall. Terminal output looks normal, the loading bar appears on the phone screen, the command ends… and nothing happens… the phone is stuck on Downloading... Do not turn off target, it has been 2 hours and 3 attempts, what does that mean ? How long is the normal waiting time ? (Heimdall command takes 20 seconds)
Here is Heimdall’s output for reference.

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
PIT file download successful.

Uploading RECOVERY
100%
RECOVERY upload successful

Ending session...
Releasing device interface...

@ROM
You have flashed TWRP successfully, you now need to manually boot into it.
(Finish reading before you press any button).
You restart the phone from the Download mode by pressing and holding Power+VolDn for 7s. You boot into TWRP by pressing and holding Power+VolUp+Bixby. So, to smoothly go from Download to TWRP (and not to allow to boot into system), you press and hold Power+VolUp+VolDn+Bixby, and when the screen turns off (as the result of Power+VolDn), you release VolDn (thus holding the correct combination for booting into the recovery/TWRP). You should first see the Galaxy logo, as you always do, and then the TWRP screen, from where you can do a backup (which normally is recommended but I didn’t so I won’t sing a song that’s not mine), and either Install your custom ROM from an SD card or sideload it with the help of ADB tools. If you have problems with finding any instructions, ask here.

Edit: with these button combos, it’s a good practice to press Power as the last one.

1 Like

Thank you so much @reb77 !!!
That 4 button combo was a life-saver, I would never had made it through without you!
I succesfully booted into TWRP as you explained then I sideloaded verity, the vendor and /e/ and it works :partying_face: !
I didn’t do a backup either cause the phone was brand new and I didn’t have anything to backup.

Seriously now, this part should be clearly mentioned in the /e/ install guide for the S9, after a quick look at the gitlab documentation repo, it seems that the install page is genererated through templates for every device… I would happily volunteer to rewrite part of the tutorial but I am unsure about opening an issue there, the whole process looks very messy…

Follow-up, first impressions after 10 minutes use: It sucks :frowning_face:
Glitchy apps, very ugly cross-breed look between Ubuntu and iPhone (I hate both ^^), f*ing advertisement in the app store and weird buggy search engine…
Also seems impossible to access the app menu (swipe up on Stock), or I am retarded or it’s really iPhone-like
Guess I will give it a week try and revert to Stock if I can’t adapt it to my needs (was still very interesting to flash a custom ROM).

Thanks everyone for the support!

1 Like

It is correct that Samsung’s Odin (firmware flashing software) is designed for Windows system. Heimdall is the open-source variant of Samsung Odin. But after a test of Heimdall unter Windows I stayed with Odin.

On the heimdall website it is “clearly stated” …

What platforms does Heimdall run on?
Officially - Linux, OS X and Windows (XP, Vista, 7 etc.)

If you don’t want to use the installation method offered by /e/ documentation or Samsung’s Odin to install TWRP Recovery, you can use the so-called dd Install Method:

dd Install Method (Requires Root):
Download the latest image file (.img) from the download link above. Place it in the root of your /sdcard folder and rename it to twrp.img. Run the following commands via adb shell or a terminal emulator app:
su
dd if=/sdcard/twrp.img of=/dev/block/platform/11120000.ufs/by-name/RECOVERY
TWRP for Samsung Galaxy S9 (Exynos)

As so often: The user has the choice…

@ROM
Glad you’ve made it. I only knew what needed clarification because I’m freshly after struggling with the process myself, so I know where folks are likely to get stuck and frustrated.
As for your initial impressions… The greatest job the /e/ team did is full degooglification. This is their ONLY advantage over LineageOS, and everyone else for that matter. All the bells and whistles (/e/ email accounts, service integration, the ridiculous iOS rip-off look) are unnecessary distractions, perhaps an attempt to attract less aware crowds, I don’t know.
For this full degooglification, though, I’m happy to pay the price of having to live with certain technical issues and logistic workarounds here and there.
The /e/ app store – I wouldn’t even bother, just use F-Droid and Aurora. To get rid of the iOS look and feel, get another launcher, my choice was Lawnchair and I couldn’t be happier. If you decide to go away from /e/, I suggest giving LineageOS a try, although S9 isn’t officially supported anymore and you will have to settle for unofficial releases (worked fine for me for the few days I used it).
Good luck! :slightly_smiling_face:

1 Like

Hi, a year ago I got an old Nexus 5 and was able to install /e/ on it as a trial, then I bought a second hand Xiaomi Mi 6 and it was a disaster, I couldn’t manage to install /e/ (stuck in loop), got very frustrated and end up selling the phone. After a break, a feel courageous enough for a secon trial and thought buying a second hand Samsung Galaxy s9. My question is: what android version as to be in the phone in order to install /e/ without loops or strange things? And the next one: were you able to install it following the instructions? (I’ve read some threads and something wasn’t really clear @cosmin You ended up not installing that “patch” and installing the ARI9 from the SD card, and afterwards flashing the /e/ image via sideload?

With which StockROM Android version is your S9 SM-G960F/DS/N | G960FXX… currently running?