Help installing /e/ on Galaxy S9

Hi @graz. I’ve mainly followed the instructions on the wiki. Except for the order of executing the ‘patch the device section’. That’s what brought me to this forum in the first place since I didn’t completely understand that based on previously flash experiences :slight_smile:
I’ve also had to sideload the vendors. There was only one strange thing and that was after sideloading the /e/ zip and wanted to restart the phone (latest step in the instruction) I got a warning that there was no OS installed. Restarted anyway and apparently there was an OS since /e/ started up. All in all in was quite a smooth experience.
The previous Android version was 9. Stock and up to date (to 2019-11).

1 Like

Thanks @0x7C0
Sorry, wha do you mean with sideloading vendors?

It’s the part from the instruction that doesn’t seem to be needed on every device so I first tried it without. But then indeed the installation did fail so I had to execute that as well. (Although I’m not really sure what it does exactly)

On some devices, installation can fail if vendors are not up-to-date. In this case, please:

    Download those vendors
    Install them
        On the device, go into Advanced > ADB Sideload, then swipe to begin sideload
        From the computer, please run adb sideload <vendors file>

Lovely, thank you very much @0x7C0 for sharing your experience! Its very helpful!

@graz, please also see this issue. Already forgot about that :smile:

1 Like

Ok, so I’m stucked in step 1… Cant install Heimdall in Mac. Is there any way to skip this and somehow use Odin or some other tool that doesnt require command lines? In Nexus 5 i was able to install adb and fastboot and then trough TWRP flash /e/ image, but this time I didnt even reach that phase

To install TWRP Recovery on the Samsung S9 SM-G960F you need Heimdall or Odin3 (Wind°ws). ADB commands work. Fastboot doesn’t work

Thanks, @archje. I checked the “HOWTO Install /e/ on a Samsung smartphone with Windows easily” tutorial from @Anonyme.

Did anyone tried this method with the S9 instead of the installation wiki?

This how-to is basically applicable to all Samsung devices. But it is well known that the devil is in the details.

Some Samsung devices require additional steps. Especially the Galaxy S9 (starlte), possibly in two points:

Patch de device 1. download the patch from here

On some devices, installation can fail if vendors are not up-to-date. In this case, please:

Download those vendors

As soon as TWRP has been flashed successfully, the /e/ OS ROM is installed in no time.

1 Like

Thank you very much for your help @archje ! I’ll give it a go and tell you the results!

I keep my fingers crossed that the OS change will work without incident. The S9 SM-G930F is still a great /e/ phone.

Thanks! In my case the phone is the following (second hand):
Model: Galaxy S9-G960F.
Firmware version (can’t find it), but the kernel version says 20.09.2019
Security patch: 1.09.2020 (in case it’s relevant, I don’t know).
Android 9.
Base band version: G960FXXU6CSGD

I’ll keep you updated with the progress.

Security Patch Level Sept. 2019 indicates the firmware version PDA: G960FXXS6CSH5.

1 Like

Hi! Ok, I have another problem. I was following @Anonyme instruction and in step 3, OEM unlock, I activated it (it appeared in developer options). According to the instructions, “activate it and don’t worry about the warning”. I activated it and the phone did a factory reset. It didn’t say anything similiar in the tutorial, but I assumed that after the factory reset the OEM would be activated. But then, after setting everything up, in the developer options there was no OEM unlock button at all, neither activated nor deactivated. I followed the advice of @0x7C0 to make the OEM unlock button appear, but I didnt appear. Any help? By factory reseting it (without internet) did I updated something that prevents OEM unlock? It seems that I’m going backwards in this quest…

EDIT: ok, it appears that after rebooting the date was again set to the actual date, so changing it some days before to day made the trick and now OEM Unlock is showing and bootloader is unlocked.

1 Like

Almost a year ago I tried to install /e/ in a Xiaomi MI 6 without succes and I got so frustrated I abandoned the quest. After taking strength again, reading a lot in the forum, with the previous experience and (specially) thanks to ALL OF YOU, in this second attempt I managed to install /e/ succesfully in my “brand new” second hand S9!!!

All the little details that @archje mentioned appeared, but I was able to solve them thanks to the answers posted in this thread, as well as others in the forum!

I will briefly describe my process in case it’s useful for anyone like me who is kind of newbie:

  1. As I dont know about command lines and stuff, I didn’t follow the official install wiki and followed @Anonyme s guide for Samsung phones, which is very carefully and clearly explained.

  2. OEM unlock button didn’t appear: I followed this recommendation from another thread, that also @0x7C0 mentioned that could be problematic. It didnt’t solve it at first, but after connecting to the internet and changing again the date, the OEM unloeck toggle reappeared.

  3. In step 6.6 of the guide, i followed the WARNING, but didn’t succed. Then I followed the alternative suggested, and it worked, but I’m not sure if TWRP is permanently installed.

  4. The vendor problem also appeared:

On some devices, installation can fail if vendors are not up-to-date. In this case, please:
Download those vendors .

I copy and pasted the vendors zip in the internal storage, but found that in the guide it says to copy them next to the TWRP folder, and I didn’t find that folder in the internal storage. Therefore, again, not sure if TWRP is permanently installed (I guess that could led to some update problems in the future?) I’ll wait till the next update is released to see if I can update via OTA or not (that would be the ideal for me).

Being able to find all this info has been critical for me to prepare everything before the flashing. That was the main reason I choose the S9, because with the Xiaomi MI 6 there wasn’t as much info and help in the forum to search.

I still have to transfer contacts, data and stuff and check if everything (bluetoth, tethering…) works ok, but, again, that couldn’t had happened without your help and support. I’m happy to be closer to degoogling! Thank you all!


Yes, TWRP is elementary important for the automatic OTA installation.

Please simply check if TWRP Recovery is permanently present on your S9 SM-960F:

  1. Switch off the device completely (until all LEDs are dark).

  2. Now boot into Samsung’s Recovery mode with pressing following buttons simultaneously:
    VOL(+) and HOME and POWER.

  3. Wait until the TWRP start screen appears; now release the buttons.

  4. TWRP will show now its menu:
    Install, Backup, Mount, Advanced
    Wipe Restore, Setting Reboot.

  5. Touch “Settings” (I only change: “Use 24-hour clock” and Select Time Zone - “Set Time Zone”).

  6. Return to the TWRP menu and tap “Reboot” > “Recovery”.

When your S9 boots into TWRP again you can be sure that it is installed correctly and permanently.

@graz, please let me know what your experience is.

Hi @archje it seems like TRWP is installed. In step 5. when you sey “Select Time Zone”, UTC+6 was selected. Should I change it to my time zone?

1 Like

I’ll do that, yeah. But it’s not essential.

So, you haven’t given up and fought your way through. :clap: :clap: :clap:
This is great and I’m very happy for you, @graz. Welcome to the /e/ club.


Hi @archie, after I made those changes, then I go to “reboot” and “power off” and the phone goes off, but then when switching on it goes into twrp instead of the normal phone.

Yeah, I know the feeling. I don’t like it, but I’ve seen it before.

Type “Reboot” > “System”. /e/ OS starts new. Now switch off normally (POWER button). The next start will then be into /e/ OS ROM.