[HOW-TO] Flash /e/-OS on Fairphone 3 using Debian based GNU/Linux

https://doc.e.foundation/devices/FP3/install doesn’t list fastboot flash product product.img anymore.

1 Like

In the /e/documentation (https://doc.e.foundation/devices/FP3/install) the last step is the lock of the bootloader.
Is it mandatory or may I leave the bootloader open? In a later case of unlocking, all data will be erased - I would like to avoid erasing…

It isn’t mandatory to lock it, but be aware that it is advised to lock it for reasons.
Make sure to set up a screen lock if you leave the bootloader unlocked.

To leave it open just in case you don’t need to unlock it later for reasons you don’t know yet … I don’t know … I would rather run the risk of having to set up the phone again.
(But then again I choose to not have banking Apps on my phone, oh, the bliss :slight_smile: .)


Not sure, where to ask this. Maybe this is a good place.

Now that /e/ finally allows for Corona Warn App to work, I would like to revert back. However, I am currently running LOS 16.0 and I am not sure if the official install instructions will work under those circumstances, especially since I would be upgrading to from pie to Q. Has anyone tried it? Does anyone know if complications are to be expected?

Thanks in advance!

Hello everyone!

I hope this is the right place to post my question, as it concerns different threads.

Wanting to degoogle my mobile life and having read about the e-foundation I bought a used Fairphone 3 (Android 10 installed) last week. And now I am trying to install eOS. However, I am completely new to the field…

In a first step I tried to follow the instructions on Install /e/ on a Fairphone FP3/3+ - “FP3”. In order to do so, I downloaded the necessary files and installed “Minimal ADB and Fastboot” on my PC (Windows 10). However, I got stuck with the command: “fastboot flash recovery twrp-3.4.0-0-FP3.img”. I got: “FAILED (remote: partition table doesn’t exist)”.

I then started reading across different forums. In different places, I found the recommandation not to install TWRP on the FP3 as this would make OTA updates impossible in the future. (E.g. here.)

When I came along this thread here, I realized that in this instruction no TWRP is flashed to the FP3. I am therefore wondering whether I might adapt this instruction for me (although I am not using Linux but a Windows 10), and install eOS in this way?

Any recommendations on that? Could it be a feasible way at all? And if so, are there certain commands which would have to be adapted?

Thanks a lot in advance!

After replying I saw you essentially asked the same thing in a separate topic so I moved my answer there to avoid duplicates. I think it’s best to continue there.

A huge THANK YOU for this how-to, it is EXCELLENT. The only hick was the ‘product.img’ which is still in the howto but not in the downloaded zip any more. But I found AnotherElk’s post further down in this tag. Maybe you could put a notice on top of your howto telling noobs like me just to get on without being frightened of missing something.


I can t edit it anymore for now, that would be for @Manoj to enable :slight_smile:

Hi @Chimpthepimp I have made it a wiki…Pl go ahead and make the edits.


It was very important issue to preface all commands with sudo to get it to work, but finally it works great!

1 Like

Thanks for your Guide! :+1:
I’ have one question though. I’ve followed all your steps and managed to use /e/ successfully on my FP3.
Is it Okay now to disable in the developer option the “OEM unlock”? Or must it be enabled?


I just bought a new FP3 and would like to use it from the beginning on with /e/ -OS (currently Android). This tutorial has worked great so far, but now I can’t get any further. When I enter the commands to install /e/ -OS in the terminal an error message appears (see screenshot in attachment).

I don’t have Linux or GNU, but a MacBook Pro (macOS Mojave 10.14.6), but until now everything worked as described.

Maybe someone has an idea how to solve the problem.

Thanks for the help.
Bildschirmfoto 2021-07-05 um 14.19.58

Hi @PeteS welcome.

The fastboot command comes (with adb) from Android platform-tools. I am not a Mac user, but the mac method is described here.

Note it does not install the tools to the system, it just “provides” them.

Did that all go as expected for you? :slight_smile:

PS no Mac instructions here but just for reference.


1 Like

If you made sure that you have the fastboot command in the folder you operate in, just add ./ before the command to tell the system to look in the current folder for it, resulting in ./fastboot flash system system.img.
(I don’t have a Mac, this is just a general Unix/Linux remark, as macOS is a kind of Unix.)


Thanks for the promt reply, now it works! :smiley:


Sorry for the late answer. You can disable the developer options.

This guide worked well for me, even thought there is some typing (first everything for _a, then for _b… but I didn’t see this post.

Thanks! But i’m still confused, because i’m not talking about developer options, but the option “OEM unlock”. Am i allowed to disable this as well?

Hi @solanum as I think you have a Fairphone 3, does this answer address your real question?

No, it doesn’t, but thanks for citing.
The “OEM unlock” switch is there to allow or not allow the unlocking process, it doesn’t lock or unlock anything itself.

You can disable it, if it makes you feel better.
But I guess in case the OS can’t be booted anymore for some reason and unlocking the bootloader again might be part of a possible solution, you could be in trouble if OEM unlocking wasn’t enabled to allow the unlocking process.
I have no practical experience with this scenario or a link to where this happened, it’s only my theory for now.