How to pass "rebooting in bootloader mode" in Easy Installer

Hi all,

I recently bought the Gigaset GS290 because I saw /e/ as a great privacy alternative for my iPhone. Although I have zero experience in both installing ROMs as well as using Linux, I thought it would be fun to learn so and do it all myself. After one week of getting stuck in the process I really need you guys to get this done. Otherwise I’m afraid that I have to give up :sweat: I have gone through all the posts on this topic but can’t find an answer about Linux.

After installing the latest platform-tools as well as turning on developer options, USB debugging and OEM unlocking on my phone, I did open Easy Installer and clicked my way though the steps. Everything went well until my phone turned into fastboot mode. It seems like after turning into fastboot mode there is no connection between linux and my phone anymore.

I’ve restarted my phone and repeated the process a couple of times but without any different outcomes. Am I doing something wrong?

All help is very welcome!

Hi @underdog welcome to the forum.

For help with Easy Installer, you will have read the troubleshooting guide please can you upload a log.

In the meantime I will point you to this Windows thread where myself (with no Gigaset) and a new-to-gigaset user learns about the bootloader on your device. Please be sure to read to the end and the final (hidden) photo! :slightly_smiling_face:

I chose this just from the trace you chose to show us.
adb devices will answer when you are in Recovery mode,
fastboot devices will answer when you are in Fastboot mode.

Bon chance :smile:

Looking at the screenshot my assumption is that your phone is still in normal system or recovery mode (adb devices shows a detected phone, fastboot devices doesn’t).

Did your phone show a screen similar to this?

And did you select the fastboot mode there?

Edit: and as aidb said, could you provide the logfile, please?

Hi @aibd thanks for the quick reply! I did read the topic but think my problem is different. The phone is turning itself into fastboot mode from the Easy Installer software. After that, the installation software gets stuck and it seems like my computer isn’t recognizing the device in fastboot mode anymore.

1 Like

The forum doesn’t allow me to copy paste my logs because new users can’t paste >2 url’s :frowning:

I pasted my logs in this file:

Looks like the “Share” functionality of this online-toolz collection just shares the URL to the editor, not to the text you typed there.

@aibd it seems like I’m not allowed to post links in here. I’ve tried to paste my logs inside a reply but I’m having the error ‘new users can not post more than 2 links within a reply’. Also tried to paste the logs inside a external URL but then my comment gets reported as spam. Do you have any suggestions about how to share this with you?

I am not certain, but if I mention a moderator, @Manoj, and you mention him in your reply, perhaps your links will come through. Be sure to use, known to work here. :slight_smile:

@aibd @Ingo_FP_Angel second try, can you guys see my link?

1 Like

Thanks @underdog, seen and converted:

Did you experience any difficulty with the OEM unlock stage? or is 169 lines different to what you thought you pasted?

@aibd The Easy installer asked me to turn on OEM unlock, so I did and clicked allow on my device. I did also turn on USB debugging and file transfer within usb settings. The last line of my log code is correct and corresponds with what I’m seeing in the Easy installer software log window.

Thank you, @underdog, for documenting this well. I will step back for now as far as East Installer is concerned, but will be sure to check the thread this evening! :slight_smile:

Thanks @aibd, we keep in touch!

The log is consistent with the easy installer waiting forever to see the phone in fastboot mode.
But I don’t really know what might be causing this (except of course the trivial explanation that it isn’t in fastboot mode :wink: ).

Your computer OS is Ubuntu, right? Which version?

Can you try the following while the phone is in fastboot mode

sudo /snap/easy-installer/18/easy-installer-linux-x64/bin/adb/fastboot devices

Also, when the phone is in fastboot mode, is there a line in the output of lsusb that corresponds to the phone?

Yes, I’m using Ubuntu 20.04.2 LTS 64-bit running on a macbook pro (intel) macOS Big Sur version 11 using Virtualbox.

I’ve tested the lsusb command with and without fastboot mode activated on the phone, these are the results:

Normal mode:
Bus 001 Device 004: ID 0e8d:201d MediaTek Inc. GS290
Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Fastboot mode:
Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The command “sudo /snap/easy-installer/18/easy-installer-linux-x64/bin/adb/fastboot devices” returned nothing :frowning_face:

Might as well be a Mac OS or VirtualBox problem (or the combination of both) as the phone isn’t even seen on USB level inside the VM. :frowning:

On a physical linux machine I have those entries for an FP2


Bus 001 Device 008: ID 05c6:6769 Qualcomm, Inc. 

fastboot mode

Bus 001 Device 010: ID 18d1:d00d Google Inc.

I thought so at first but it seems that this problem only occurs when the phone is in fastboot. With a normal phone connection (using adb devices without fastboot mode) I have no problems. I have also tried Parallels desktop in addition to Virtualbox and get the same results. Are you sure my problem is in the virtual machine?

In my experience sure might not get an answer in a forum! But @Ingo_FP_Angel what do you make of the 3 warnings
Input stream must not be null
in the top 20 lines?

I said it’s either Mac OS, Virtual Box or a combination of both. :wink:
But then, it could also be a Gigaset thing, I don’t know.

My best idea right now would be to install adb and fastboot on Mac OS and see if fastboot devices returns anything without the additional layer of a VM. If the host already has the problem, I doubt there’s anything you could do from inside the VM.

You took me on the right path @Ingo_FP_Angel, thanks!

I did figure out that I must add/attach the USB (phone) device twice to the Virualbox settings. In normal mode and in fastboot mode. Now my device was detected in fastboot mode and went through the next stage of Easy Installer.

I clicked yes to unlock the bootloader and then it started the ‘USB transfering’ process. After the installation bar was at 100% my phone kept saying ‘USB transfering…’. This took on for more than one hour. I decided to restart the device holding volume up and power which turned me into the setup stage of the stock android. No /e/ on the device.

I’ve pasted my log in here:

Do you have any thoughts based on the new log? Thanks for your help!

UPDATE: video of device can be found here