How to sync pictures from FP3 to ecloud?

I have made some photos on my FP3. I created an ecloud-account and added it in the FP-settings. “Pictures and videos” is checked in the account settings.
Now I would expect my photos to be synced to the ecloud, where I can see them via desktop pc. But no images are shown there, even after hours.

Am I doing completely wrong?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

There is a similar question here Pictures synchronization issue in eDrive with some very well informed links and a useful workaround suggested Pictures synchronization issue in eDrive - #38 by tcecyk

Thank you very much :slight_smile:
The workaround is this:

workaround is reboot with power cord plugged or using nextcloud-official

I did the first (reboot with power cord plugged), nothing changed.

The second one

using nextcloud-official

I don’t know, what that means.

plugging the cord (during runtime) was at some point a workaround. Not sure if the boot event is necessary even. Didn’t test again for a long time.

using nextcloud-official: this replaces the builtin file sync. Search for “nextcloud” in Apps, the first hit with “unknown” as author subline is the proper one. Ecloud is a nextcloud instance. You need to enter your ecloud credentials there too. Disable the builtin file sync category within the “accounts” android settings menu and let the nextcloud client do it.

I did so.
Now I see some folders in NextCloud app (Devices, Documents, Images, …, Photos, Pictures, …), they are all empty (0B) and keep empty over the time.
There are a few photos (in gallery app) on my phone made by the build in camera. I would expect to see them here in the NextCloud app and then after a while on PC in the cloud.

Ah, just the one note appeared on phone (in NextCloud app) now, which was in the cloud before. But no images anywhere.

Do I have to share them manually somewhere?

I think, I do not understand a single bit about clouds :wink:


Now I noticed the small exclamation mark<!> nearby the NectCloud app symbol. I opened again and was asked to add the OpenCamera folder to the synced folder. I did so and now I see the files in the cloud :slight_smile:
But not in the photos folder but in a new one called InstantUpload/OpenCamera. That’s not nice, so I will search to change that.

Thanks to all up to this point :slight_smile:

glad it works for you but yes it needs some configuration. I think the built-in file sync will work again with 0.21 if you want to switch back.