[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

I have the S6 Lite (SM-P610).

TWRP for that unit is no longer updated and therefore results in a boot loop - so no use for Odin. I tried to build Heimdall myself, but was unsuccessful. I really do not understand what I am doing wrong.

Thanks! I will try the package and see if I can make it work :slight_smile:

No luck…

" Windows: Extract the Heimdall suite zip and take note of the new directory containing heimdall.exe. You can verify Heimdall is functioning by opening a Command Prompt or PowerShell in that directory and running heimdall version."

It does not manage to find Heimdall, even though i Ran PowerShell from the directory it is in :thinking:

I do not have a Windows machine to demonstrate this, but you are likely to need to:

cd /path/to/Heimdall
./ heimdall.exe

The ./ tells your PC to operate in this folder.

Follow @Marine she had give you the solution, TWRP is unfoundable OK but recovery-e


1 Like

I am currently stuck at this same point, but on a Galaxy S10e Exynos. It looks like there’s hope though, thanks @StigtriX for the SamMobile link to get out of the Download Mode bootloop.

And pre-emptive thanks to @piero & @Marine for what looks like the next guides I’ll need. (Although I did manage to use Odin to downgrade from Android v12 to v11)

Please let me know if there are any other pitfalls I’ve overlooked.

Really good tutorial! I created a German translation: [HOWTO] /e/OS auf einem Samsung-Smartphone einfach installieren

1 Like

I’m stuck and very frustrated. I’ve tried three phones so far and I’ve reach a road block on all three…

I was able to get eOS on a S4 mini, but no US carrier would provide service…something about it being a China phone. So I bought two (2) more Verizon-branded editions of the S4 mini, and I can’t even get eOS installed. One won’t even update the built-in OS. The other is Android 4.4.2, but I get stuck at the same spot on both…OEM unlock doesn’t appear in the menu (yes I enabled developer options), fastboot and heimdall don’t seem to recognize it when plugged in, (but adb will), Odin failed to install twrp…

What’s going on? Is Verizon F’ing me? What do I gotta do to get this to work?

Hi @concretebox welcome to the /e/ forum.

Verizon is a bootlocker. If the phone is branded Verizon this is highly likely. Samsung phones with locked bootloader display Prenormal on the Odin mode (Download mode) screen.

Search results for 'Usa phone' - /e/ community

Well…I got it Rooted…twrp won’t install via odin though…say Fail.

welp i just f’ed it all up…used adb shell to dd serranoltexx into the /dev/block/platform/msm_sdcc.1/by-name/recovery…when I restarted the phone displayed a message “unauthorized software installed, power off your phone and contact your verizon store.”

Is this what “bricking” is? Does this mean it will never work and I’m F’ed again?

So is it Prenormal or is it not?

That is not bricking; the device is still talking to you!

@aibd - Thanks…I’m new to this so the terms are confusing me…

I don’t see the word Prenormal anywhere…I’m looking on the phone and it says:
BOOTLOADER AP SWAEV: 4 (really hard to read this one)

Lower down is says “Downloading… Do not turn off target!!”

On the PC Odin says:
<ID:0/015> Added!!

and nothing else.

So the bootloader is not locked. Two lines of “Custom” indicate it is not Samsug Official.

I guess it is now what Verizon is up to. I am in UK and have no experience.

You might try searching for the bootloader term you are struggling to read.


Maybe Verizon require a special situation to allow the Custom ROM to become authorised. Just a guess, but that expression I have not seen before, sorry.

Sometimes we see a disabler for a situation like this.

humm…after a few more restarts now it won’t display anything other than the “bring this to verizon store” message.

So…not bricked but just as useless?

Thanks for this tutorial!
I tried this on a Samsung Galaxy S5 neo (SM-G903F) and all steps seemed to run through without errors. But after the final reboot, I won’t see an “e” logo. Instead, there’s the original “Samsung Galaxy S5 neo - Powered by Android”. The phone will not boot, but stay there forever.

I used:

  • Odin3-v3.13.3
  • twrp-3.6.1_9-0-s5neolte.img.tar
  • e-1.1-q-20220630200240-dev-s5neolte.zip (had tried e-0.23-q-20220402175186-dev-s5neolte.zip before with identical result)

Thanks in advance!

Great article.

I apologize if somebody has already posted this info above (I couldn’t read the whole thread - too may posts :slight_smile: ):

If you’re working with a Samsung S10/S10e/S10+, at step 5, you’ll also need to add the vbmeta.tar file to the CP field (see this article: /How to/ install /e/ R on a samsung galaxy s10e already running android 12 - Using /e/OS / Setup - /e/ community)

1 Like

I failed to install /e/ on my S10e yesterday evening with this error.

I haven’t test your trick yet but I’m quite sure this will fix the problem. Many thanks for that!

@Anonyme May I suggest you amend your original post to add what @centaurus just mentionned for S10/S10e/S10+ devices? BTW many thanks for your very precious post!

I got the same error when trying to load without the vbmeta. Once I added the vmbeta file, the error went away.

Thank you very much for the help, this tutorial made it possible to install e/os/ after the easy installer failed on my Galaxy S9+ . However if someone runs into the same issue as me, I was not able to intsall the stable version with multiple different versions of TWPR. However what worked for me was to install the dev version on with an old version of TWRP (instead of the current twrp-3.7.0_9-0-star2lte.img.tar version fro my device , I used this version twrp-3.3.1-1-star2lte.img)