[HOWTO] Installing Banking Apps

relocking only works for a few devices !
you probably must edit build.prop first…


Does it work for MIDO, Redmi Note 4 !

I dont want to use Magix but i just want to relock boot loader after installing E os.


1 Like

Sorry for replying late. The url is this:
See bottom of page.

1 Like

Yeah that makes sense. You are referring to the documentation for the Fairphone 4, which is one of the few devices which allows re-locking the bootloader. To my knowledge the OnePlus 5t does not allow re-locking the bootloader. I brought this up a few times in other topics and it looks like the blocking factor for locking bootloaders lies with the device manufacturer. AFAIK attempting to lock the bootloader of a device that does not allow you to do so can “softbrick” your device, so @Zeno make sure to look into it properly before attempting to relock the bootloader and only follow the instructions for your specific device.

1 Like

Okay, sorry if I almost got people to softbrick their device, that was not my intention at all! I am surprised to hear that most devices don’t let you re-lock the bootloader, as this is a serious sexurity vulnerability. Glad I have a Fairphone!

1 Like

Well it took bit longer, but now when /e/ OS V1 is released, stable builds do have some improvements for banking apps also. Since I don’t have stable Murena device, I decided to test same method used at stable builds. Basicly I installed ih8sn to my device. To install ih8sn basicly follow this guide at xda.

I try to split this to 2 version at here ( NOTE DO THIS AT YOUR OWN RISK!):

  1. General method which should basicly work for almost every device. If possible I suggest to try option 2.

  2. Quick install method if you have Redmi Note 8 (ginkgo)/ 8T (willow), which are using same unified build for ginkgo. If you have some other device, you might be able to find presetted conf file for you divece, or zip file flashable fro twrp like for Redmi Note 8/8T. See quick method at the bottom of message.

Method 1 - General installation (note this is using install / push script at ih8sn package, so works at linux, not in windows. I also assume you have working adb etc. at your computer):

Step 1 - Download latest ih8sn package for your device architecture and extract

Step 2 - At folder you extracted zip file, you see ih8sn.conf where you have to get right values in the file corresponding to your device, unless you have that device which is preconfigured. Even if you have that device, remove #at front of lines and make lines start with those texts. So basicly from




File by default includes following information presetted:


Now bit tricky part. To be able to get correct values for these, you need to either find ready made conf file for your device, or have device running stock rom at your hands. If you have same model phone running stock, or temporatily flash stock to get those values, then enable developer options from phone and make sure you have enabled usb degug. Connect your phone to your computer and check computer recognizes phone with command adb devices

I assume everything is ok so far, so you can start to get those informations…

type adb shell and press enter

to get build fingerprint run getprop ro.build.fingerprint

to get description run getprop ro.build.description

to get build security pach date run getprop ro.build.version.security_patch

to get build version release run getprop ro.build.version.release

to get manufacturer name run getprop ro.product.system.manufacturer

to get product name run getprop ro.product.system.name

Now you should have all information needed for ih8sn.conf file (just paste each output to corresponding line at conf file after =). If some commands don’t give result, you can get all information with command getprop which will give a long list of details.

Ok, assuming you now have conf file setted up, it’s time to enable developer mode + usb debug as root from your device running /e/ OS. Then at computer open terminal to the folder where those files are located (at linux adb will work when setted up correctly, no matter what folder you are into.). Test connection to phone again with command adb devices

Now if you run script push.sh with command sh push.sh you will probably get information that /system is read only. To mount it with write permissions, type adb remount and after done, run sh push.sh again. If managed, you should get output similar like:

60-ih8sn.sh: 1 file pushed, 0 skipped. 7.9 MB/s (734 bytes in 0.000s)
ih8sn: 1 file pushed, 0 skipped. 231.4 MB/s (9869696 bytes in 0.041s)
ih8sn.rc: 1 file pushed, 0 skipped. 1.3 MB/s (292 bytes in 0.000s)
ih8sn.conf: 1 file pushed, 0 skipped. 4.4 MB/s (364 bytes in 0.000s)

If successful, you can disableusb debug & developer options and restart your phone. Now banking apps should work. Also since 60-ih8sn.sh has comments:

# /system/addon.d/60-ih8sn.sh.sh
# During a LineageOS upgrade, this script backs up ih8sn,
# /system is formatted and reinstalled, then the files are restored.

it should restore ih8sn after system upgrade.

Method 2 - Quick install

If you have Redmi Note8/8T (ginkgo) you can do this easy way. There are ready made zip files for ginkgo and willow. Might be that ginkgo version works for both models, but I tested willow version on mine since I have willow (Redmi Note 8T) and so I could also get conf files manually to willow running stock.

Step 1 - Download ih8sn.zip for ginkgo, from this telegram group at this message - or for willow from same group at this message.

Step 2 - at least willow version zip file is meant for flash directly from twrp, so you can just save the file ie on memorycard, power off your device and start to twrp recovery with power + volume up. From twrp select install and locate your zip file and swipe to flash and after done, reboot system… that’s all.

If you don’t have Redmi Note 8/8T and neither have option to use same device as yours, exact same model but running stock rom, you could possibly find preconfigured ih8sn.cn file or maybe even flashable zip. In case of preconfigured ih8sn.conf file, just replace ih8sn.conf at method 1 with that preconfigured conf file and run script to install.

What ever method you choose to try with, you do it with your own risk, especially when downloading something ready configured ar installable etc.

So I just put this here as basic guideline if someone else also want’s to try this. With that said, I’m not saying there aren’t any mistakes at my post, I got banking apss working with ih8sn at device running dev-build, so I assume you could do the same. Just better check all information given twice on your own too, your own risk here…


I can confirm that the method #1 worked flawlessly for me :slight_smile: on my OnePlus6 with the Danish app MitID. This one specifically was complaining that the device is rooted.

I put the information needed for ih8sn to this post - to save some time for the others:


Method #2 worked for me on Xiaomi Mi A1 (tissot) using /e/ v1.0 and Credit Agricole app.
Thank you for that tip that avoid me a huge disappointment :slight_smile:

1 Like

Has anyone some experience to share about running the Sparkasse Push-TAN and N26 apps within /e/OS 1.5 r ?

I’ve a Moto X2 2014 with very low mic volume and would like to fix that using root access. Or can I even unroot after applying the mod and everything stays as it is?


Magisk Delta still works for me. For Belgiums Payconique by bancontact and itsme (ID) and other app’s from work like succesfactors or ESS are working because of the hide function.

I typed the following prompt in ChatGPT and I was able to retrieve the info for #Method1

fill in the following details for Nexus 7 2013 with latest rom update:


Based on my knowledge cutoff date (September 2021), the latest official ROM update for Nexus 7 (2013) was released in November 2016 and it is running on Android 6.0.1 Marshmallow. Therefore, the following details correspond to this version of the operating system:

BUILD_FINGERPRINT= google/razor/MRA58K/3371000:user/release-keys
BUILD_DESCRIPTION= razor-user 6.0.1 MRA58K 3371000 release-keys
BUILD_TAGS= release-keys
1 Like

#Method1 worked for two devices:
Nexus 7 2013 and POCOPHONE F1.
If you have the same devices and it doesn’t work ensure you have uninstalled Magisk or other similar apps. When I had Magisk, then two banking app could not launch, it was detecting the device as unsafe. There is still one app that doesn’t work which is checking if the app was downloaded from the Play Store… how damn stupid!

Magisk Delta doesnt work anymore :pensive:

Hello, just scrolled to this post.
Not a Finn but living in Finland :slight_smile:
I just installed /e/os v1.8.
And I have the same issue as you with OP Pankki, I can’t install it as it sees my device has been rooted.
I consider using Magisk to overcome this problem but let’s see…

I use both apps and they work flawlessly. I used to be on 1.5 R on my OnePlus 7pro. Now running 1.8 S on my OnePlus 9.

Having that said, I’m (always) rooted and therefore any app I know works. When I forget to put those on the Denylist in Magisk they immediately start complaining.

I don’t understand why people just don’t want Magisk? I mean, just TRY AdAware and a commercial free device. It’s heaven :slight_smile:

Magisk delta with safetynet module: and the most used pay app in Belgium ‘payconiq by bancontact’ is running.:sunglasses:

You need:

1 Like

Hi Edouard!
I don’t have that problem any more. One of the updates cleared it for me. On the other hand, the touch screen of my phone (Samsung S9+) has started acting up, so I need a new phone. Thus, if I purchase it from Murena, I might face the same problem all over again. Damn! I have so pleased with my phone after the OP -problem solved itself.
Yours, esa

Hi Everybody :slight_smile:
I tried both the magisk way and the build.prop way : none of them worked.

  • Revolut bank : detects the root and refuses to launch;
  • N26 : refuses to synchronise (in order to authorise 2FA in web transactions);
  • Hello Bank : refuses to activate the digital key (in order to authorise 2FA in web transactions).

Has somebody any other solution ?
Thank for all the work done, it’s impressive :pray: :pray: :pray: :+1:
(POCO F2 pro /e/OS 1.9-s-20230312268558-dev-lmi)

I have it working with magisk using Magiskhide Props Config, Shamiko and Universal Safetynet Fix. Remember to add OP-pankki to denylist.