[HOWTO] use Seedvault early to understand Android backup

Is there a build for Samsung s9+ with seedvault available?
I only have local transport and it simply refuses to backup apps with the flag set to false :frowning:
Would be quite helpful to have a way to override it - would help me to move to newer phone…

Android 12 will start to ignore allowBackup for device2device backup. Not sure how cumbersome a backport is. I think the star2lte must’ve multiple builds available with hidden Seedvault in it?

I am using the official build and, unfortunately, that one seem to not include the SeedVault.
And I cannot seem to find a way how to update from stable to dev without loosing exactly the data I’d like to backup :slight_smile:

You have to wait for a e-0.18 to see the premises of seedvault on your device.
But e-0.18 need some fixes for now, it is not ready to be released as stable yet

Have you tried the steps outlined in the first post in this thread for configuring and starting SeedVault from adb? As far as I know, SeedVault has been present in all /e/ ROMs since around e0.14, but it is hidden in the normal setting UI.

1 Like

SeedVault is not enabled in the UI of e-0.18. It can still only be invoked via adb as outlined in the first post in this thread.

According to this post, e0-18 is becoming available

1 Like

My misunderstood, as i have seen some seedvault screens during the first boot setup process, asking for restoring a backedup system, and choosing from internal storage or from nextcloud, due to that is a serranolte Unofficial Test Build e-0.18-r from /e/ official sources
I don’t have any screenshots of that, but,


2021.08.27 seems ok, but 2021.08.13 was buggy
and some talk about version “0.18.2”

1 Like

I just installed official 0.18 for S9+ and I don’t seem to have SeedVault. The list of bmgr only shows local transport.
Am I doing something wrong, perhaps?

it is because you use dev or stable build…

following seedvault development I see the backup format is getting a new revision for Android 12: k/v files will move into a sqlite db. This will result in less ops per entry on SAF ops and sync. Good for nextcloud sync speed, but will maybe be less efficient on traffic volume (whole sqlite db has to be transfered). But if it’s only a few megabytes in sensible backup time intervals, it’s a better tradeoff.

1 Like

SQLite databases generally compress very well.
If HTTP compression is used, it should not be a problem :slight_smile:

I’m using e/OS 0.19 and after enabling the backup manager with adb, listing the transports lead to the following result:

$ adb shell bmgr list transports

Is seedvault removed in version 0.19 or why isn’t it shown here?

I’ve checked if a restart leads to any difference, but it doesn’t.

Q or R? I still see the seedvault transport in 0.19 Q

1 Like

The stable version for the Galaxy S9: Android 8 (Oreo).

it was merged in Pie at the earliest: Seedvault backup as Backup/Restore transport (!48) · Merge requests · e / os / android_vendor_lineage · GitLab


Will it be possible to upgrade Android Oreo on an S9 to a newer version if it is stable without loosing any data? AFAIK the newer version is Q, so there is one version missing in between. Does that affect the upgrade?

please search the forum for the S9 starlte upgrade topics.

If you can wait another few weeks, early december: the weekly dev updates mention a planned OTA update for starlte Oreo stable users.

for persons not into cli and adb, you can run Seedvault via creating shortcuts to the available Activities (settings + restore) with Activity Launcher | F-Droid - Free and Open Source Android App Repository

I think you can do all the default transport register through using the settings dialog once.

(the caveat that Seedvault needs Android 12 level backup api or a backport to be fully useful still applies)


I just tried to activate seedvault on my FP2 /e/ os R 0.21, but I couldn’t activate it: bmgr: not found. Does this means, seedvault is not included in the actual 0.21 version?

It is enabled in R ROMs, at least for some devices. Not sure whether it is supposed to be there for FP2.