I need a recommendation for what phone to buy

Hello Everyone,

I need some help picking an e-compatible smart phone. I tried this on my own once before and regretted my choice (Galaxy S9+… complete piece of shi— um, garbage. It’s a piece of garbage.)

So now, since my Galaxy appears to be unusable, I need to get something new, and I don’t know what I’m doing. Of the many phones that are compatible with /e/, can someone please suggest a phone that is:

  • no more than a year or two out of date
  • generally less than $800
  • has a fingerprint reader
  • is compatible with the /e/ Easy Installer

Those are the only criteria that I can think of right now, that I absolutely NEED. That doesn’t mean that I want the most basic phone out there though; these are just the things I can think of at the moment. There are three things that I DON’T want though;

  • I don’t want anything by Samsung (they’re 10 times more likely to be hacked than any other android phone)
  • I hate to say this, but nothing Chinese. I keep reading/hearing about how China is spying on the west through TicToc and Chinese made phones and tv’s etc. etc. etc… so I can’t help thinking it would be best to just avoid those.
  • preferably no Google phones. I mean, if you de-Google a phone MADE by Google, can you be sure it’s been truly and completely de-Googlified?

Thank you to everyone who has any suggestions.

I think the best choice for you is probably the Fairphone 4. It fits to all of your criteria.
I have one too and do not regret it


Also don’t forget where you live, which wasn’t mentioned. For instance if you are in the U.S. then your choices may be limited.
Hmm, seems like the Fairphone 4 covers most of the U.S. carrier bands so that’s pretty cool. Much better than its predecessors.


Sorry to hear that. My S9+ is just running fine. Not a single complain I could think of.
I did the manual install with the app from /e/. From stock android to /e/ oreo version and then the upgrade via OTA at the beginning of last year.
Did you ask for suggestions in forum how to fix it?

Depends on the use, but … I was really happy with my S9+, until /e/-OS 1.4 and this - may be microG-related - bug that BLOCKS me : I can no more use my daily driver app Naturalist, which has no possible replacement :cry:

I confirm, my wife and me both have FP4 running /e/. Just great! Very stable.
As bootloader is locked, all our apps are working correctly. IoT, banking apps, GPS transportation tracks, printing, Bluetooth apps, etc… Everything is fine! :wink:

1 Like

I see. This is something that didn’t happen to me.
Regardinge the fairphone 4 I can confirm that I know a happy user too.

If you live in the US, from what I understand no Samsung device will work with e/os because VoLTE cannot be enabled.

What about US mark like motorola, or disigned for the US marcket as the teracube 2e

Given your budget I would recommend Fairphone 3/3+/4.

You can also give GrapheneOS a try. It runs exclusively on Pixel phones, made by Google, because at the hardware level they are very secure. Pixel phones also receive updates for 5 years, I think? So even a used or refurbished phone for cheaper might be enough for you to judge if you are happy with it.

This can be explained by the huge market share Samsung has on the smartphone market. Also, most ‘hacks’ are actually social engineering i.e., not a problem with the technology, but with the human.

Hello, and thank you to everyone who’s made suggestions.

Tyxo asked If I’ve asked for help from the forum… Typically I haven’t because I just don’t know how to describe the problems. I’m going to try explaining the most recent sequence of troubles now, and we’ll see how it goes:

First, I’ll say that I was getting a lot of “X has shut down” messages for various apps; I’m sorry but I don’t remember which apps. I had a hand-me-down android phone once before, and that one was also always telling me that apps had shut down (usually they were apps that I hadn’t even known were running in the background), so when it happened with this phone as well, I thought it was just something that happened with androids.

Then one day I tried to connect to a company’s wifi network, and for some reason couldn’t - even though the older iPhone I was also carrying had no problem connecting. A week later I was back in the same place and again tried to connect, and this time it worked… but when I got home, the phone would no longer connect to MY wifi networks! When I tried I got a message saying something along the lines of “this network has been temporarily forbidden” for one, and “This network has been permanently forbidden” for the other. (I don’t remember exactly how they were worded, but the main point is that it was clearly the phone refusing to connect, not the networks refusing to accept the connections. I should probably also say that my PC, old iPhone, printer, etc. were able to connect just fine.) I was never able to resolve this problem.

About a week later another problem cropped up. You know the 3 shapes at the bottom of a Samsung phone’s screen? From left to right there’s a triangle, a circle, and a square, right? Suddenly the square, which normally called up all currently running apps, wasn’t having any effect at all. This meant there was no way to close any apps. A few days after that, the triangle (the “back” button) also stopped responding. At this point I was going to use the easy installer to start over with a fresh installation of /e/, but I discovered that the installer refuses to acknowledge that the phone’s been connected.

So, anyone want to take a stab at what might be happening?

Thanks to Marcdw for pointing out that I didn’t say where I am. I’m in Canada, and I know that when I got my S9+, I had to look for either Canadian or Global versions; the US version would not have worked. Does anyone know if that’s a typical thing for smartphones, or if it’s only Samsungs that are fussy like that?

Oh! I just remembered: when I first installed /e/, I immediately got a message saying my e account (e-cloud?) was full, even though I’d never used it. Anyone know what that’s about?

Thank you all SO much for reading this lengthy post, and for whatever suggestions might come from it.


Honestly, I am not aware of any of the described problems. In particular the cloud worked flawlessly. Is a factory reset possible.
Next level would be cleaning everything via twrp. Everything mean

  • data
  • cache
  • dalvik (dalvik cache)

Thus all your data would be lost. Make a backup, if you do that.

Methinks there are tutorial some place in the forum, the documentation. If not look at what they suggest at XDA.


Isn’t this kind of counter productive? Trying to avoid Google by using a Google phone and a Google operating system… I’m not quite following the logic there. What am I missing?

GrapheneOS is not a Google project.

It’s an operating system designed from the ground up with privacy and security in mind, and implements no Google services whatsoever. Therefore is technically not a so-called “degoogled” operating system, because there’s nothing to remove in the first place. This is in contrast to something like /e/ which starts from a “googled” base and strips down the bits it doesn’t like.

In terms of hardware security, Pixel phones are remarkably secure. Part of the design threat model considers potential rogue employees within Google itself.

Here’s a couple of videos talking about it (both with timestamps). The second one is an interview with one of the core developers of GrapheneOS and talks about why Pixels are used exclusively.

Thank you, I really appreciate this!!