Install /e/ on a Samsung Galaxy S5 Active - “klteactivexx” (beta)

Indeed, I am trying the same configuration as before the reboot without any luck so far. Sure I would not be bothered at all to do a sequence after every boot to get it connected to the carrier - I am used to trouble shooting being a Linux apostle for two decades.

I’ll update on my findings, fingers crossed for fast resolve.

BTW when is the next update scheduled?

Last but not leased thank you so much for holding hands and being so supportive @taurus.


1 Like

One thing I see is different looking at the Network app is the smsc value - suspecting that to be an possible blocker.


Update: Not 100% sure how I managed to get it connected again (receive and make calls) (learning curve is high) but could be as trivial as me not saving after changing operator name under APN yesterday.

What is missing now is that I can’t send SMS only receive. This I am sure has to do with smsc value that is not the same for some reason. Unfortunately I do not have a copy of the value when it worked. Maybe the operator has it…I’ll find it somehow.

The mobile number still does not show.

I can live with all this just to have /e/ running on my now refurbished device.


As far I can remember, I used a while ago on a klteactivexx-device the latest TWRP version for klte. That should support also your klteactivexx. Maybe it’s worth trying.

1 Like

Mine was blank. I tapped Refresh and some carrier-generated numbers populated, but it didn’t have any negative effect on my connectivity.

I suspect soonish: Announcing the start of /e/ R beta testing

Nothing but Linux in my house! (And /e/ and some somewhat de-trackerized other Androids)

P.S. Sometimes, carriers have alternate APN settings that can be tried. You might talk to yours, if you haven’t already since the new issue came up.

@itsclarence thank you. Do you have the link for the latest TWRP version for klte? I thougth I had it but that gave me an error 7 as you see up in the history…

@Taurus - I am on the carrier to actually check the health on the sim - it does not display phone-number on both of my devices…that is a blocker for sending SMS.

1 Like

not sure you need the last TWRP,
no need of advanced knox or a/b support like in 3.4.x-x, or 3.5.x-x
better search xda or guit-hub for an unofficial unified 3.1.x-x, or 3.2.x-x, or 3.3.x-x for this device shipped with android 6

i remember that the firsts 3.4 wasn’t work to intall /e/pie or nougat on s4 android 4.4 and s7 android 7

yes there are tones of those codes
some are samsung vendor related, some are gogol related
some others works

Yes, but the service code I mentioned worked on the Sony before I installed /e/, and now no longer does. I was wondering if /e/ wipes out some of those functions when flashed.

The Service Menu is part of the Sony Stock ROM, and installing any custom ROM will overwrite the stock ROM so the Sony Service Menu will be gone.

As mentioned above, /e/ ROMs do include a similar but more limited menu which can be invoked by dialing *#*#4636#*#*

1 Like

Thanks! That is kind of what I thought, but I didn’t know /e/ replaced some of them. Nice!

@taurus So I tested with another sim-card from the same carrier. This card displays phone-number and I was able to send SMS - But after fiddling with the network app - hitting refresh update etc just to see the values there…after that the same behavior occurred - failed to send SMS on that card also…do you know the impact on what that app does?

The Refresh button shouldn’t change anything. Try this:

  1. Restart. If that doesn’t correct it, then…
  2. Power down, then remove SIM card. Power on, then…
  3. Shut down, then reinsert SIM. Power on. If that doesn’t help, then…
  4. Repeat step 3, but insert a different SIM card. Power on and let the network set itself to the new SIM. Then repeat step 3, but insert your normal SIM card and power on.

I think that will probably fix it.

P.S. If your network sends a text asking you to download the internet settings, accept it before powering down.

Thank you @Taurus for the possible fix, this was to be my last resort if the new sim card I got yesterday did not make any difference.

But here are the GOOD news, all in place now; sms, calling, sim pin etc is working perfectly after I got the new sim card provisioned on the /e.

1 Like

On another topic - the new update failed but I guess that is because I did not find twrp-x.twrp-x.x.x-x-klteactivexx.img anyware but (found) and are using lineage-18.1-20201225-UNOFFICIAL-recovery-klteactivexx.img instead. But this I can live with for sure, I’ll just do a manual adb upgrade. BTW do you have a link to the latest build?

Thank you again for fantastic support!


1 Like

Fantastic, @Hibba, glad you got the comms issues worked out.

I recommend searching for your device here in the forum, and then if you need more guidance, start a new thread focusing on that in particular.


Sure will do, thank you. Let’s mark this case/topic as resolved.


1 Like