[SOLVED] Error 7 when flashing /e/ ROM on Samsung Galaxy J5 2015

Hi everybody !

I’m getting this error (look at the screen). Actually I think I know why :
at the line “E3004: This package is for device: j5nlte, j5nltexx : this device is .”, my device code name (j5nlte) should appear (but it doesn’t), so I suppose the code name of my device have been erase during the wiping and because there is no match betweem my device code name (which doesn’t exist anymore) and the compatible devices list code name of the ROM, an arror occur.

What do you think about my theory and how to solve that issue please ?

I’ve actually found some tips like this one (go to “METHOD 1”) which seems logical but I would like expert advices before modifying the ROM (it could creates some troubles with OTA uptading or launch an atomic bomb I don’t know)

Problem solved ! Thanks to that tutorial.

But I haven’t delete all the “assert” section, I have juste add the third line in order to approuve the installation in a smartphone called " " (because in the error message it was written “this device is .” (meaning the name of my phone is an empty thing, I don’t know why).

1 Like

Hi there, I have a Samsung SIII, i9300 the international version, I have managed up to the point where I have installed TWRP and wipe what is here described. The problem is that when I try to install the /e/ zip it I get the error 7. From the link I tried to edit the script in the zip file and tried to install again but I always get new errors. Any suggestions are welcome.

if you don’t mind loosing apps/data wipe cache, system and data and try again.

Hi there,

Same issue, and tryed 2 solution on the script but nothing work.

My file :
assert(getprop(“ro.product.device”) == “starltexx” || getprop(“ro.build.product”) == “starltexx” ||
getprop(“ro.product.device”) == “starlteks” || getprop(“ro.build.product”) == “starlteks” ||
getprop(“ro.product.device”) == “starlte” || getprop(“ro.build.product”) == “starlte” || abort(“E3004: This package is for device: starltexx,starlteks,starlte; this device is " + getprop(“ro.product.device”) + “.”););
ifelse(is_mounted(”/vendor"), unmount("/vendor"));
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/VENDOR”, “/vendor”);
ifelse(file_getprop("/vendor/build.prop",“ro.vendor.build.date.utc”) != “1536890700”,
ui_print(" “);
ui_print(" ERROR: “);
ui_print(” Vendor image on the device “);
ui_print(” is NOT compatible “);
ui_print(” Expected version: 27_ARI9 “);
ui_print(” You can download from is.gd/omexok “);
ui_print("============NO CHANGE HAS BEEN MADE==========");
abort(" “););
ui_print(“Target: samsung/lineage_starlte/starlte:8.1.0/OPM7.181205.001/a863ee5b61:userdebug/dev-keys”);
ifelse(is_mounted("/system"), unmount("/system"));
package_extract_dir(“install”, “/tmp/install”);
set_metadata_recursive("/tmp/install", “uid”, 0, “gid”, 0, “dmode”, 0755, “fmode”, 0644);
set_metadata_recursive("/tmp/install/bin", “uid”, 0, “gid”, 0, “dmode”, 0755, “fmode”, 0755);
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”, “/system”, “”);
run_program("/tmp/install/bin/backuptool.sh", “backup”);
show_progress(0.750000, 0);
ui_print(“Patching system image unconditionally…”);
block_image_update("/dev/block/platform/11120000.ufs/by-name/SYSTEM", package_extract_file(“system.transfer.list”), “system.new.dat.br”, “system.patch.dat”) ||
abort(“E1001: Failed to update system image.”);
run_program("/sbin/e2fsck", “-fy”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”);
run_program("/sbin/resize2fs", “/dev/block/platform/11120000.ufs/by-name/SYSTEM”);
run_program("/sbin/e2fsck", “-fy”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”);
show_progress(0.020000, 10);
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”, “/system”, “”);
run_program("/tmp/install/bin/backuptool.sh", “restore”);
show_progress(0.050000, 5);
package_extract_file(“boot.img”, “/dev/block/platform/11120000.ufs/by-name/BOOT”);
show_progress(0.200000, 10);
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”, “/system”);
run_program("/sbin/sed", “-i”, “/exfat/d”, “/system/etc/selinux/plat_sepolicy.cil”);
run_program("/sbin/sed", “-i”, “/sdfat/d”, “/system/etc/selinux/plat_sepolicy.cil”);

help, any other suggest ?

Finally my problem is solved, i change the version of TWRP i was using(3.4) to, the latest version seems to have some bugs ( : KO).
It’s working well, ++

1 Like

I tried to change the TWRP version as you wrote but I’m still getting ERROR: 7

What can I do?

Are you sure your on TWRP 3.3.1-1.
If so, try to download the rom again. Maybe it’s corrupted

Some roms will give a error 7 when you Wipe and install immediately , first do a reboot back into recovery then install Rom …fo me solves this problem on many Roms

Just as a remark, in case somebody encouters a simular issue: I had mulitple issues on S9+ with error 7, going from android 10 to e/os/ Q.
For me switchig to an older version of TWRP (from twrp-3.7.0_9-0-star2lte.img.tar to twrp-3.3.1-1-star2lte.img) did not solve the issue, however I managed to install the dev build (not the stable one with the old twrp version).