Install /e/ on device currently running Android 10 (specifically samsung s9)

I can’t, i just can say that at least two users claim they have bought and received a Samsung S9 or S9+ running stock android 10 ( one said I do all the updates proposed by Samsung )

And then use successfully the easy installer,

Haven’t you try it @SuzieQ ?
I (@piero), don’t have device yet compatible with the easy installer (only Galaxy s4mini, s4, s5mini, s5, Tab2, … and … iPhone 5s)

Yes, that is what I feared.

Of course! I speak from practical experience. Grey theory is not my cup of tea.

These devices received a stock Android up to a maximum of Android 6.0 Marshmallow. This is another Android world with far fewer restrictions on the part of Google and Samsung. And the Galaxy S 9 / S9+ differs significantly from its predecessors S8 / S8+ and S7 / S7 Edge anyway.

For the user side the process is the same :

1/ Downloading the files
2/ Installing the tools on the computer
3/ Update the smartphone to the latest Samsung firmware
4/ Flashing a custom recovery
5/ Installing the /e/ build

@SuzieQ, Have you read @JeanGui ´s post ?

Model SM G965F
Version de base G965FXXUAETG3

Samfrew says that is a 7 june 2020 firmware

Since I don’t speak French, I used the translator DeepL and overlooked the firmware designation. All the more fortunate that you point it out.

The Android 10 ‘version G965FXXUAETG3’ cannot even be downgraded to the previous version G965FXXU9ETF5 according to Samsung statutes - to protect the user from conflicts with the previous version, according to Samsung. The Samsung bootloader roll-back lock already takes effect here.

The descriptions of ‘JeanGui’ are incomprehensible to me and cannot be verified. You were surprised, I find that suspicious.

It was me that flashed an Android 10 Samsung Galaxy 9 (starlte) with the easy installer back to Oreo. I believe I have that setup (files of installer and ROM) still on my computer. Will try to reproduce this and report back the exact details … it makes me curious also.

PS: @SuzieQ … really appreciate your participance on this forum. Always very clear explanations and polite. Also appreciate your critical view on several subjects. I have the feeling you are on the edge of leaving the forum, but hope you will stay. Keep it up!

Hello @pinibo, thank you for your feedback. I am also curious about the result of your investigation.

Technically, what you’ve described should not work. I’ve worked on two handfuls of S9 / S9+ and have been shown the limits that Google on the one hand with Stock Android and Samsung on the other hand with its security philosophy impose on users. See you soon.

So I’m really confused by reading all of this and other threads.
I started with a S9 with the latest software until January’s security updates, used the Easy installer to install /e/ and ended up with /e/ Android 8.1…
But what confuses me is that to upgrade to /e/'s Android 10 Q I first have to flash Samsung’s stock ROM to go back to where I was before and after that install the /e/ dev build that contains Android 10 manually??

Just flashed my starlte device again.

  • Was coming from Havoc OS this time (3.12 - Android 10)
  • Previous time I was coming from Samsung stock firmware (Android 10)
  • I have used EasyInstaller v0.11.2-beta (used that also back in October)
  • I did not have a choice on which version to install. It went back to version 0.14-0-2021012999012-stable-starlte (Android 8.1.0).

I have made some pictures during installation, but no strange messages during install at all. It went back smooth to Oreo.

Okay, I note: from Samsung stock firmware (Android 10) and Havoc OS 3.12 - Android 10 via /e/asy installer to /e/OS 'O’reo 8.1.2) 0.14-0-20210129 has worked for you. In this respect I can consider this as a successful installation process. However, in my eyes it is not progress to switch down from Android 10 to Android 8.1.2, even if the Oreo 8.1.2 version is /e/ OS. Progress and improvement to me means an OS change from stock Android 10 to /e/ OS ‘Q’ Android 10.

That an installation via /e/asy installer to the current /e/OS ‘Q’ e-0.13-q-202101 does not currently work is also confirmed by the official /e/Support:

So the only option left at the moment is to do this manually.

I have connected my S9 with /e/ OS ‘Q’ Android 10 to the /e/asy Installer v0.11.2-beta for testing. It detected the ‘starlte’ and downloaded the files and Then it did not go any further. The button “Continue” remained roughened and could not be used actively.The /e/asy installer does not cope with this constellation.

Furthermore I tried a Stock Android downgrade from Android 10 to 9.0:
from_ G960FXXSBETH2 = Android 10 2020-08-19 August 2020 Security Update
to___ G960FXXU7CSJ1 = Android 9-pie 2019-10-01 October 2019 Update

This process fails with the message on the S9 display:

@pinibo, are you still using your S9 with /e/ OS 'O’reo 8.1.2 or will upgrade to /e/ OS ‘Q’ Android 10?

I just upgraded now to Android 10 (0.13-2021012097133).
First I downloaded the latest firmware from Samsung ( G960FXXSEFUA1) and flashed it via Heimdall (I have a Linux machine).

Then I flashed the latest TWRP ( [twrp-3.5.0_9-1) also via Heimdall. From there I was able to flash the mentioned Android 10.

I can try later today to flash from the current configuration via EasyInstaller back to Oreo … but I guess I will get the same result as you have just described.

@pinibo :+1:

I was fully aware that my /e/asy installer attempt is not practical, because who would want to downgrade from the much anticipated /e/ OS ‘Q’ to 'O’reo.
I just wanted to learn how the /e/asy installer behaves. But why the /e/asy installer first downloads two files in the volume of about 700 MB and then stops silently instead of terminating the process with a hint, I will probably never know.

I might saiy that I have just downgrade in my S9+ from dev to stable 0.16 in easy installer without any problem from here.

I’m confused my phone installed .17-202110531117530 and it says Android 8.1.0

Well Hi Piero, I see that you’re french and really effective with Samsung and e/os. I’m french too, not really big boss with all of this but I try to install e/os on my S9, evrything goes well but when it reboot, it’s android 10 which start !! I’ve tried many times and it’s always the same…
My phone is a SM-G960F, Android 10, n°version QP1A…, install with the easy installer v0.17… I saw that you usually need precises informations to resolve problem so don’t hesitate to ask me what you need to help me if you can.
I really know nothong for the moment about manual install or other kind of pleasure but I can learn !

Good Days,

I haven’t been able to test the “easy-installer” yet because of the lack of a compatible device, @aibd is sharper than me on this subject.

It’s probably a timing problem with the fingers, try again.

Otherwise, take a picture of the download mode screen

Bons Jours,

Je n’ai encore pas pu tester l’“easy-installer” par manque d’appareil compatible, @aibd est plus affuté que moi sur ce sujet.

C’ est probablement un problème de “timing” avec les doigts, re-essayez.

Sinon, prenez une photo de l’écran du mode download

Linux, macOS, Windows ?


Have a read to

ok thanx a lot, I’m with windows 10.
I’ve tried but in vain, I’ve never seen the magic “blue line” :)), I gonna try again soon and I’ll tell you :wink:

verification :
when download mode, I unplug USB from my phone ?? then I force power off with vol- / power, and imediatly when black screen I hold vol+/bixby/power and stopped as soon as I see the blue line ?

but I’ve never seen this magic blue line yet ! :frowning:

another verif : at “unlock OEM” step, I have to active or desactive unlock OEM ?? if desactive phone restart to reinstall and if active nothing happening…

You have to allow “OEM unlock”, then continue the process

[HOWTO] an Unified Install Guide Project for /e/
Know your hardware - Samsung

My favorite hint in Odin is to unselect auto-reboot, and prepare the fingers…