Installation Failure i9300 - Help

I have a Samsung Galaxy SIII i9300, I followed the general advice, the great help from from Piero and the posted new anonymous advice about installin on a J5. All looked good till I wiped the original Rom and tried to install the /e/. I have got the message “failed to map file external SDcard (filename) error installing zip file”. In desperation, I tried to recover something with installing two other downloaded ROMs, an Official Nougat and a Hexagon Rom. On trying to reboot it says no OS installed.
I’m not bricked becauseTWRP is accessible but I cant load the software.
Am I buying a new phone or is there away out?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

You have TWRP installed, that’s a good start.

To really be sure to wipe correctly everything, in Wipe and Advanced Wipe, select Data, then click on “Repair or Change File System”, then on Change File System, click on “exFAT” then swipe to confirm.
Redo the same thing but select “ext4” instead of exFAT.

Now in Wipe > Advanced wipe, select "cache / ART Dalvik, Cache, Data, Internat Storage, System, and swipe to confirm.

Your phone is now perfectly wiped and ready to receive a custom ROM.

You can insert a SDcard with the zip file on it, or sideload the zip file, or plug the phone and copy/paste the zip file in the internal storage, and go in “Install”, select the zip file and swipe to flash.

It’s normal if TWRP says NO OS INSTALLED even if you just flashed an OS. Just reboot and it will work.

Thanks for the advice
On wiping data I get unable to decrypt FBEdevice on exfat and on wiping the rest I get unable to wipe data, Error changing file system and it reboots intothe opening screen but no more.
Can I do anything else?

Hello @lionel.smith, I’m not sure to understand: are you trying to install /e/ on a S3 or J5 ?

Sadly I don’t know more than I have already said… Wait for somebody else.

I am installing on a Samsung Galaxy SIII, Piero was helping me and copied a previous link from someone with a J5 saying it was an easier install than the official instructions. I have copied Piero’s instructions below from a previous post First timer - Checking requirements
"For my accompaniment during the install process, I am refering to the structure of the official documentation :

The links to the advice are “First timer - checking requirements
[HOWTO] Install /e/ on a Samsung smartphone with Windows easily
Thanks for your help

Ok nice.
One of mine is with the last Lineage official build (a year ago) the second one is with /e/ since a year or so and the last one (a SIII 4G - 9305) is with /e/ (since some weeks) also, so we can be confident.

First of all, you have TWRP installed right ? but which one ? official ? which version ?
What OS you are using Windoz ? Ubuntu linux ? Assuming you have a pc.
Have you an sd-card to work with ? 4G is enough.
Download last two or three /e/ builds for 9300 on your pc and and do a md5sum
(in french) or sha256sum check. If everything goes well transfer them to your sdcard.
Put sdcard in the phone and boot to TWRP: vol up, home and power.

Thank you Tintin
I am using Odin to install TWRP each time I try and fix it.I am using the latest TWRP-3.3.1-0-i9300.img.tar, official. I started loading with the official /e/ method in Ubuntu16.04 but could not manage the terminal emulator or adb shell, so I have reverted to a Windows PC. I have a twrp- img on the 56GB SD card along with three versions of of ROMs but want to install the latest for my phone e-0.9-n-2020051153544-dev-i9300. I found the MDS sums did not work for Linux but the sha256sums worked well. I fail to get an MD5sum done on Windows so I transfer the files.
I am trying to work out the windows MD5sum syntax and borrowing my wifes phone to copy accross the other two e dev files.

Sorry, so now you need to Wipe cache and Dalvik as usual.
In Advanced Wipe you really need to verify that or change to “aka format” all other in ext4 except Data in vfat.
And try to flash one of the zip even if you have an error in format Data step.
Good luck and let me know :crossed_fingers:

1 Like

I loaded twrp onto the phone through the SD card (Ihave to load that on my wife’s phone as Windows does not recognise the phone). I tried to clear data, it allowed me to clear data changing to exfat but if I then try and wipe davlik, cache, system and internal storage and try and change the format, it says “invalid system partition”. Last night I installed, it got to the e and bouncing ball, I was so excited, but halted and said something like “unencryption failure” and forces me back to factory settings.
I have trired twice since, once leaving it overnight, but it gets stuck half way through downloading.
I am not hopeful as i sit beside it stuck.
Should I go back to ubuntu and try through Heimdall? it did reboot when I did the Heimdall print-pit? I cant see how to use Terminal emulator or adb shell.

Thanks Tintin, Piero and everyone who helped I have finally loaded. I need to check the bugs

1 Like

Ok @lionel.smith nice to read that ! Congrats !
TWRP version I use is 3.0.2-0, works like a charm even with unknown command times to times.
Not a problem.
nb: if you talk about somebody add “@” before his name. It helps :wink:

Now that I am up and running I have registered a couple of bugs for an SIII, the apps crash whenever you open anything. Seconly, it show my files and pictures from my SD card behind a warning box saying “No Storage, No external storage available”. If I try and open the card the two options are “format and format as storage”. arghhh
Can anyone tell me where to find the “update on air” feature in settings, I cant, and I want to backup but under backup I can only find “factory data reset”. As I did not backup I have no factory settings.

If the launcher fails, go in /settings /apps to clear the cache.
there are many bugs with bliss, some of us have be able to found a stable position, if you don’t, you can add another,
a Bliss complete rewriting is awaiting for soon (maybe some months)
For now, to do backups you have to use TWRP.
Edit :
(backup system, settings, apps installed only, not personal documents)
First go to the developers options to enable advanced boot in this way you will able to reboot easily to recovery mode

@lionel.smith as it runs now, you should do a factory data reset (in /e/ not TWRP) and see if it helps or/and flash /e/ again.

I have tried clearing the Cache. I reported the problem and am seeing many others with this problem, many after the last update. Thanks for the advice on rebooting.
Incidentally, on the SIII the ONLY installation method that worked was sideswiping.

The factory reset says you will erase all data from your phone’s internal storage including
Your /e/ account
System & app data and settings
Download apps
Other user data
If I lose the /e/ account I will have nothing left! I will wait for the bug fixes when I learn how to update.
Thanks for your support

Hi @lionel.smith,
You will lose your connection to your /e/ account temporary only.
So you backup everything you need to your /e/ account, do a factory reset (and even a second flash) and connect your device back to your /e/ account.
And restore what is needed to.

@Anonyme @piero am i wrong ?

Yes for the account,
Also, MTP connexion to the PC may works better under TWRP than with system booted

@Tintin @piero I did a factory reset which took me to TWRP where I rebooted. Nothing has changed.
To reflash the ROM, do I have to go through the procedure of wiping the old ROM clearing Data in exFat wiping all but external card and USB OTG in ext4, then sideswiping the same file? For the SD card I will copy files off the card, re format, then copy back on. There are a growing number or people reporting the APP crash.