Installation problems on OnePlus Nord

Sure ! It’s here : OnePlus - Nord - avicci - Documentation Suggestions
Thank you for your help improving documentation :+1:

Hi sceriffo,

Can you put here the required instructions that are required to install /e/ os on a oneplus nord?


Yes, later today or tomorrow I will.

1 Like

I wrote the procedure but I can’t post it because new users can insert a maximum of two links per message.
I have to ask a moderator to unlock this limit otherwise I have to write more messages and it gets a bit confusing…

1 Like

Pl send me the post in a message and also the location where you want to post it and I can do the needful.

I wrote an email at because I can’t direct message you

The procedure is as follows:

  1. Back up your phone data if necessary.

  2. Charge the phone battery to at least 50%.

  3. Enable ADB and fastboot on your PC. Instructions here: Installing adb and fastboot on Linux PC

  4. Download the Q stable /e/OS ROM and the e-recovery from the official link: /e/ image ROM download

  5. Enable developer mode on your phone and then enable USB debugging from developer options. Instructions here: Enable USB Debugging and OEM Unlock

Unlocking the bootloader:

  1. Enable OEM unlock in the Developer options under device Settings, if present.

  2. Connect your device to your PC via USB.

  3. On the computer, open a command prompt (on Windows) or terminal (on Linux or macOS) window, and type: “adb reboot bootloader”

  4. Once the device is in fastboot mode, verify your PC finds it by typing: “fastboot devices”

Tip: If you see “no permissions fastboot” while on Linux or macOS, try running fastboot as root (typing the command “sudo” before the command “fastboot …”). I runned fastboot as root from here to the end of the procedure.

  1. Now type the following command to unlock the bootloader: “fastboot oem unlock”

  2. If the device doesn’t automatically reboot, reboot it. It should now be unlocked.

  3. Since the device resets completely, you will need to re-enable USB debugging to continue.

Booting a custom recovery:

  1. Connect your device to your PC via USB.

  2. On the computer, open a command prompt (on Windows) or terminal (on Linux or macOS) window, and type: “adb reboot bootloader”.

  3. Once the device is in fastboot mode, verify your PC finds it by typing: “fastboot devices”.

  4. Flash a recovery image onto your device by typing “fastboot flash recovery recoveryfilename.img”.

Replace the “recoveryfilename” with the name of the recovery image you downloaded in the previous section.

  1. Now reboot into recovery to verify the installation.

Pre-install instructions (copying the content of the slot A to the slot B):

  1. To do this, sideload the “” package by doing the following:

  2. Download the “” file from here: | by The Muppets for Generic Device/Other

  3. Sideload the “” package:

  4. On the device, select “Apply Update”, then “Apply from ADB” to begin sideload.

  5. On the host machine, sideload the package using: “adb sideload”.

Warning: The Recovery will present a screen that says “Signature verification failed”, this is expected, please click “Continue”.

So far was the official guide summarized, from here it’s chrisrg’s instructions.

Installing /e/ from recovery:

  1. When e-recovery home screen is up and running, select Factory reset. Next select Format Data/factory reset.

Screen will go white and output at bottom left (very small letters) when done.

  1. Return to e-recovery home screen (if not already there, can’t remember ) and select Apply update. Next select Apply from ADB.

  2. If device wasn’t plugged to pc, plug it in now and issue the command to sideload the OS zip: “adb sideload” changing the “filename” to the name of the file you downloaded (probably if you didn’t changed it.).

Terminal output should now show "serving"something or other as the zip is transferred across, with a percentage amount.

It will stop at 47% (all being well) and everything is being done on device. Watch the on screen output for Step 1 and then step 2. Its quite slow and you may think nothing is happening, but wait until the recovery screen changes and you then press the back arrow at top left. Output should show install status.

Press reboot system.

  1. Done.

Let me know if there is any problem, I checked very well but I could be wrong. I wrote this procedure a few days after doing it.


Hi @sceriffo , I have added the rest of the details to your post above. Also marked it as a wiki so that you or other users can make edits to it.


I can confirm this procedure is 100% correct, im now running /e/ on my OnePlus Nord AC2003 with no issues. The only thing i would add to this is a big bold header that says DO NOT UPDATE TO ANDROID 11 at the top :grin:

1 Like

Hi everyone, not sure this is the right thread for this question but it’s related at least.

I’m new to /e/ and am very interested in getting a phone with it. Thought of buying a second hand OnePlus Nord and installing it myself on it, since it would come out much cheaper than buying it with /e/ pre-installed from their store.

My question is : is /e/ compatible for the OnePlus Nord N10, N100 or CE or only for the original OnePlus Nord ? For those who don’t know, OnePlus have declined the Nord into a series of phones which remain essentially the same but with lesser components and are therefore cheaper and less performant. For more details see this article (in french).

Thanks in advance !

Sorry I don’t know it

I have follow the instructions, rolled back to Android 10, installed the ADB, installed the ADB driver, added the PATH for the ADB directory, but get stuck on step 9:

9. Once the device is in fastboot mode, verify your PC finds it by typing: “fastboot devices”

I can get my Nord into fastboot mode but I cannot complete step 10. I am using a Windows 10 OS. This is what my cmd says (you can see I’ve tried various prompts):

I suspect it is something specific to my laptop. Have tried multiple USB ports and cables. Any ideas would be amazing, please? Thank you.

Hi @escapeartist welcome to the /e/ forum. There is an odd thing which happens with Windows sometimes. Windows loads the drivers for the device, but not the full drivers which allow fastboot (even though adb devices produces a response !)

Leaving your install instructions on one side temporarily, the workaround is to open a Windows device manager alongside your terminal.

Check that the Device manager shows no :warning: Problem device.
At each stage check the Device manager again.
Make contact with the phone with adb devices.
Switch into Fastboot mode.
Try to make contact with fastboot devices.
At any point where a :warning: Problem device appears, in the first instance try to allow Windows update to fix it.

1 Like

Thanks @aibd your suggestion worked and I now have /e/OS installed on my Nord, very happy!

Now I am working out how to setup my phone! Am slowly figuring it out, is there a setup guide or suggestions in the community do you know?

Great news @escapeartist. For guidance there is

and to help you learn to navigate this forum and other resources

Good luck

1 Like

@sceriffo @Manoj am stuck on #16.
I get an error that says: “error: cannot load file ‘xxxxrecovery file.img’”
any ideas?

Sorry, I don’t have the knowledge to answer your question. You have to wait for someone experienced.

This was resolved by using the proper msm download version.
Issue resolved
Please see post: bricked one plus nord for more details

Have you try to install Nord OS on your N100 ?
I have also a N100…