Installation success ? But fastboot stuck

At any restart of an Android system, USB debugging, and your permission to use your PC will be lost. So yes, you need to re-ensble USB debugging at that point.

Wipe of data is also associated with Error 7, so I would definitely do it on change of Android version. And/ or a patch might be intended to include some prep of data partition, which is why I added a spoiler ! (Hope I am clear !)

HOW-TO: Going back to Stock ROM/Recovery on Zenfone 3 ZE552KL/ZE520KL | XDA Forums

It worth a try, as we don’t know how ASUS manage their firmware :wink:

Well, once you have the device reset from base stock firmware, you just flash versions after versions and if it’s not the correct version the device will tell you the proper version to install. Then you go to the Asus website, do a quicksearch (ctrl + F) with the number version paying attention that it starts with a WWsomethingsomething (not JP-) in my case.
With all the packages being around 2Gb, it’s a really long process and I hope that after all this, /e/OS will work.

It did not work.

First, I followed the instructions again and when I went for sideload; I got error 7. Then I chose to go with “install with SD card” and it installed successfully.

Time to reboot and…nope. Boot loop. I’m back to when/where I started this thread.

Is there is an older version of /e/OS I could use to make the step from android 8 to 9 ? If yes, where to find it ?
Is it the right way to go ? Which version of android this system had when the first /e/OS build appeared ? Maybe /e/OS nougat was the starter ? Should I try with updating android to nougat and then /e/OS ?

So what is the latest Asus android stock version have you managed to boot this time before trying the eOS install?

When in bootloop have you tried these steps?: Power off device> Manually boot into recovery> factory reset> reboot.

So what is the latest Asus android stock version have you managed to boot this time before trying the eOS install?

I managed to install up to android 8.

I just did that from twrp and it doesn’t change anything.

And then it bootlooped after eos install?

Yes, it bootlooped after I installed /e/OS through SD card because I couldn’t through sideload as I got error 7.
But the first time I did the manip’ I did through sideload and I had the same result.

That’s progress.

I guess the twrp version you are using is from the webpage linked from eOS instructions, so it’s from 2019.

If the phone still has Stock android 8 (WW15) on it , even if it won’t boot now, I would try to install something else on it to get started.

I found this page with a link to an unofficial lineage os rom - Lineage 16.1 (equivalent to pie,9). They also do 15.1 but the date is older than the twrp recovery so I wouldn’t try that. The downloads page has the rom and an md5 checksum file which is a good sign in my opinion.

Might be worth a try, don’t know,

Seeing your proposition gave me an idea; I went to look for a newer version of TWRP from their official website.

I dunno what I will start with.

Maybe I’ll try installing lineageOS to overwrite it with /e/OS, see if it changes anything.

This newer version of TWRP is a good idea or did /e/ devs especially pointed at this older package for a reason ?

EDIT : NEVERMIND, I WENT LOOKING FOR NEXUS 5X INSTEAD… so no, zenfone 3 has no twrp build on their website.

This build of lineageOS works without any hassle. I didn’t install microG because I don’t care about these for the test I ran.
Once installed, I went back to TWRP in order to install /e/OS through external SD card and it did the same fastboot loop as before.
So, my conclusion is that the dev build isn’t in a working state at the moment. I hope it’s not a forgotten project. If it is, I’ll just sell back this phone and find another one that supports /e/OS.

Thank’s @chrisrg for the new ideas and paths. I’m kinda losing hope right now.

My sense it that you need to attend to Recovery.

You mention using TWRP, but also not being able to find it ! Perhaps time for a break.

You made good progress !

There’s no TWRP build for the zenfone 3 on their website. There’s only the ones proposed by /e/ team. I was hoping for a newer version.

What do you mean ?

Yes, I need a break.

I cannot see the answer right now. The /e/ build might be broken, but it is here we would look for the evidence.

I think we need to solve some “correct recovey” issue. What branding is on the “Factory” recovery you used for the manufacturer upgrades ?

If you have the stamina…here’s an earlier e-0.17-p from the time of eOS test builds for pie.

There is also a newer Lineage recovery here that might be worth a shot!

Thanks @Yrdael

There’s only the ones proposed by /e/ team.

I had received an error accessing that page yesterday, so I was uncertain.

Back to the “Format data” issue (known to cause Error 7). It looks like your “Zenfone incremental ROMs” sorted the “Format data” issue there. I understand “Format data” was not required.

Were you sure to Format data when you changed to yesterday’s Unofficial TWRP + /e/ ?.

Oddly that method is not included in our instructions ! Only sideload is recommended.

The fact that the device has only unofficial TWRP might point to something irregular in the hardware.

Hello again,

Thank you @chrisrg for the ideas. I tried this early build but it ended up with the same result. Also, lineage recovery did install properly but I can’t sideload due to an error (can’t mount /cache no such directory and such…) and there’s no option to install via SDcard. So, following this way of thinking I went looking for another recovery, but alas no option available for this model on either of these groups :

And no wonder since they are derivatives of TWRP. I was still hoping they’d have it somehow.

No, I can’t be sure I did that since it was some time ago, but I made this step an automatism for me “always clean up before install”, so I assume I did.
So what you mean is that I shouldn’t have formatted the data in the first place ?

I know, it actually used to be on some devices, like the samsung S4 last year or something. Thing is, this is the only way I have to get to the installation process without any errors. I’m still trying sideload from time to time just because it’s supposed to be working from what’s said in the documentation.

Just to review my advice a bit; way back at Post #28 I said

Wipe of data is also associated with Error 7, so I would definitely do it on change of Android version.

I believe that to be correct. On regular updates wipe cache + ART is sufficient, when Android version change is involved Data should be wiped.

While you were doing incremental manufacturer’s updates, you were following their guidance, so I would expect their guidance to be sufficient. I think I understood you to report that under their guidance this data wipe was not specified. Fine by me so far :slight_smile:

That “tiresome night” I had a concern that you had got into the habit of omitting the data wipe from your workflow.

Then I asked “were you sure you did the data wipe”, the time that you went to /e/ install, following the long run of “manufacturer upgrades”.

I am just spelling that out, as I think that is the point you are asking me to clarify. :slight_smile:

I really don’t think you can do any harm (other than lose your data) if you wipe data on any occasion.

I did wipe in between each installation.