Installing /e/ on galaxy tab S2 Wifi

repo forall -c ‘git lfs pull’ did not work. I download the prebuilds app now manually and restarted build… finger crossed

1 Like


ERROR: Dex2oat failed to compile a boot image.It is likely that the boot classpath is inconsistent.Rebuild with ART_BOOT_IMAGE_EXTRA_ARGS=“–runtime-arg -verbose:verifier” to see verification errors.
23:32:14 ninja failed with: exit status 1

I suppose I ran out of memory?

The command runs with no trace to the terminal.

After completing a repo sync, you will have to run repo forall -c ‘git lfs pull’

Running the command directly after repo sync may help to ensure you have a connection to the server.

Re Dex2oat error … as I found by a search

export CPU_SSE42=false

Thanks guys for all your help. I commented out in /lineageOS/art/build

the two msse4.2 lines to
// “-msse4.2”,
but might also forget to write `export CPU_SSE42=false in the terminal.

And the good news is, build was now successful:

[100% 96027/96027] build bacon
Package Complete: out/target/product/gts210wifi/


I will test in the next days…

Here are the instructions again:

Congratulations ! @ronnz98

Is there a chance, that the version T813 of the S2-Tablet gets re-supported by /e/os? That would be really great since this Tablet is still in 2023 a powerful and very slim & light peace of Hardware…

There are probably no official maintainer

This rocks! Thank you ronnz98 for getting this started!!
I’m still using the very same tab (Exynos 5433) on my home network and could not agree more – it is very powerfull, slim and light.
This could be the to be announced /e supported tablet :star_struck: :wink: :+1:

I will report back, once I got it running – any issues so far?

This goes to:
Released 2016
SoC Qualcomm MSM8976 Snapdragon 652

It should be:
Info about gts210wifi | LineageOS Wiki
Samsung Galaxy Tab S2 9.7 (Wi-Fi) (gts210wifi)
Released September 2015
SoC Samsung Exynos 5433

Up to now I could not get the [UNOFFICIAL e-1.14-t] (gts210wifi) 3G/32G
to boot. I would even show up e logo.
Anyone able to help me with debugging?
The latest LOS20 version for this device from 13-AUG does work fine

Are you using TWRP?
It has a file manager, does logs during flashing… you can mount system read only and look for logs, from when it tried to boot, maybe!?

Or do you have adb working during the black screen?

yes I’m using TWRP. Unfortunately I cannot connect via USB (charging does work though).
I did install via SD card.
I will try again and search for log files. The logs during flash looked fine

Do you have version number and, or link, please?
(I only asked about TWRP, after someone here said he had never heard of it – only ever learned adb, I gues)
I am still working on several S7 and S7edge, so not tried flashing the tablet, yet.

here is the link:

On XDA forum its stated
A5. You MUST use TWRP 3.6.2_9.

There is however also a newer version which I tried and also could successfully install LOS20

1 Like

For old devices, i prefer old twrp, such as 3.3.x-x

Same here, also better luck with those.
I often also just look at the size and pick the last <10mb, if there is a long list of versions.

I tried some older version of TWRP but still not luck
I could also build now for SM-T710 a eOS version of 1.14-S. But in lack of owning this device I cannot test. I own only a SM-T713 which I’m looking to create a manifest file

Do anyone can support in debugging the SM-810 version I build?

Remember Dex2oat jumped in, but there should be alternative ways to check the reported

verification errors

I think, perhaps printed to a .txt file not shown in the quoted output.

during build to print a log file or during booting (is this possible tough?)