Installing /e/ on Poco 3

Hi All,

I’m installing /e/ on a Poco F3 Alioth.
I am following the guide until point 4, installing recovery using fastboot.
It goes without error, so I think that it went well.
After this, the screen still shows fastboot.
Point 5 assumes the phone is off, so I hold the power button until it reboots and I keep the volume up button in too.
But it boots the normal stock rom, I don’t get into recovery.
Tried it several times, but no avail.
Wat goes wrong here??

Thanks in advance

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @Gaea,
from your description I read that you have not verified your eRecovery installation, so you end up back in Stock Android. Please follow the steps below:

(4a) Flash a recovery image onto your device

fastboot flash boot recovery-e-1.5.1-s-20221102231515-dev-alioth.img

(4b) Now reboot into recovery to verify the installation with command:

fastboot reboot-recovery

(4c) Update - Supplement
Important: At the same moment, while the display of the device turns black and reboots - hold VOLUME UP + POWER. Keep holding both buttons until the ‘POCO’ logo appears on the screen, then release. The system should now boot into eRocovery mode.

(5a) Now install /e/OS from eRecovery

On /e/OS Recovery Main Screen:

  1. Select Factory reset
  2. … and so on and immediately …

Happy Flashing!

Ok, thanks!

This is what I did with the phone in fastboot mode;

 ~/platform-tools $ fastboot flash boot recovery-e-1.5.1-s-20221102231515-dev-alioth.img
Sending 'boot_a' (196608 KB)                       OKAY [  6.584s]
Writing 'boot_a'                                   OKAY [  0.320s]
Finished. Total time: 6.931s


~/platform-tools $ fastboot reboot-recovery
Rebooting into recovery                            OKAY [  0.003s]
Finished. Total time: 0.204s

Then it boots into normal stock rom…
Aperently it writes nothing, so it appears to me?
I used the package

I tried a new installation on a Pocco F1 with /e/OS ‘S’ V1.5 - and it only worked if the point (4c) is taken into account. @Gaea,excuse me for having missed out this passage before.

Ok, thanks @anon29344687 ,

I will give it a go again tonight.
But is it normal that writing only takes 0.32 seconds?

Edit: It still boots into stock rom after applying point 4c

@Gaea, although I do not have the Poco F3 in my hands myself, I suspect that especially the installation of /e/OS ‘S’ is the same as on a OnePlus 8T (see here).

If I were to install /e/OS ‘S’ (Android 12) on a Xiaomi POCO F3 (alioth), I would proceed as follows:

Before following these instructions please ensure that the device is currently using the Oneplus Oxygen firmware version mentioned below.

POCO F3 EEA (Euorpe) V13.0.6.0.SKHEUXM
POCO F3 Global V13.0.3.0.SKHMIXM

Unlock Pocco F3 bootloader (if not already done)

Flashing the vendor boot partition

Download this vendor_boot.img file

Power off your device, and boot it into bootloader mode:

With the device powered off, hold VOL(-) and POWER. Keep holding both buttons until the word “FASTBOOT” appears on the screen, then release.

Flash the downloaded vendor_boot.img to your device by typing

fastboot flash vendor_boot vendor_boot.img

Booting the eRecovery using fastboot

Flash the downloaded eRecovery to your device by typing

fastboot flash boot recovery-e-1.5.1-s-20221102231515-dev-alioth.img

Now reboot into eRecovery to verify the eRecovery installation.

fastboot reboot-recovery

Now iInstalling /e/OS ‘S’ from eRecovery
. . .
adb sideload

Good luck and happy flashing!

Ok Thanks!
The vendor_boot img did the trick.
Now I sideloaded the file:

~/platform-tools $ adb sideload
Total xfer: 1.00x           

See the picture for error messages
When I tried to reboot, I get a warning it might fail to boot.
So I left it as it is for now, it is still in recovery.
What now?

Error message:

Update package is older then the current build, …

Remember what I wrote in #6:

Please ensure that the device is currently using the firmware version mentioned above. If your current installation is newer or older than the required version, please upgrade or downgrade to the required version before proceeding.

By the way: The yellowish overlays in your image are not helpful, because they mask error messages.

Hi, Thanks again,

That yellowish is the foil, it is still brandnew and it is a x-mas present for my son.

I don’t know how to determine wich version EU or Global I have without rebooting.
Product code is mzb08rjeu.
On a Xiaomi website I could find it is the International version.
Can I use either version?

Hi, use ‘Global’ if you are not in Europe.

Redmi K40/POCO F3/Mi 11X (alioth) Firmware Downloads

Good morning,
I’m in the Netherlands, I bought it off and the seller is aparently from Tallin…
But does it matter as it is going to be overwritten?
Do I flash it the same way, or with a special flash tool like here:

They have a recovery and a fastboot rom?
Bit confused…

Hey @Gaea, that’s Android basics! If you aren’t known, you’re quickly mistaken.

The RECOVERY file is used for system update.
The FASTBOOT file is used for repair and reinstallation (clean flash, all data is irretrievably deleted because the system is reformatted).

Do I flash/sideload the file thru ADB just like the /e/ rom, or should I use a xiaomi flash tool?
From tommorow I’m away for 2 weeks, after that I will have another attempt.


With a lot of effort I manage to install stock Rom fw_alioth_miui_ALIOTHGlobal_V13.0.3.0.SKHMIXM_07afcb74cd_12.0 succesfully.

After that I flashed /e/ the same way
as discribed above, but I get the same error as shown in the picture.
I flashed also the newer one 1.6.
And I used vendor_image from 2022-12-17

What has gone wrong?

I finally manage to install /e/ using this topic:

Hello everyone! I wrote the guide that Gaea used to finally successfully install eOS 1.6 S. The issue is that all ALIOTH documentation provided by eFoundation is not just outdated but also instructs the user to install incompatible MIUI versions, making installing eOS impossible or resulting in malfunctioning upgrades. I try for over a month to get Manoj to either publish my updated guide or at the very least place a warning on the outdated guides telling them to wait for an update or consult the alioth documentation thread where I volunteered to assist people with both installs and upgrades, should my upgrade guide not suffice.

I know the team is very busy and alioth not being a Murena device having very low priority. But if any of you by chance are able to edit the documentation, I would be delighted if you could make any of this happen.

Everyone else: If you need help with installing or upgrading to eOS Version S, head on over to the forum thread I linked above. I will help you, if you bring some patience. I check the thread at least once a week.