Is /e/OS Q installed on Samsung S9 with current v0.11.2-beta?

The two .ZIP-files only have something to do with TWRP insofar as they can be installed with TWRP.

As I wrote above:
I did not use these two files because they were not necessary for the /e/OS ‘Q’ to work. A clean Stock Android 10 as a base and the /e/OS ROM ‘Q’ are a good team to use the S9 99.99% deGoogled.

Hi @Manoj.

Due to the extraordinary detective work of @SuzieQ above, the /e/asy installer developer should be made aware that the installer is not using the most current /e/ Q OS build for nor is using the most recent version of TWRP (3.5.0_9-0).

Just wanted to let you know as currently this situation results in “Error 7” installation failures, as she has shown in detail above.

Best regards, Marc

@mcmd, the /e/ communication leader has long since registered our lines. He is a careful observer. And don’t wait to change your OS. In stock Android 10, first enable ‘OEM unlock’, then install TWRP 3.5.0_9-0 or eRecovery recovery-e-0.13-q-2021012097133-dev-starlte.img, and so then install the /e/ OS ll My recommendation: Use this guide. Flashing the eOS is not witchcraft.


I understand. My intent was to have a leave a simple summary comment on this so that if someone wanted to understand what the status of the installer was with the S9 it would be there- they could also see that I notified the communications leader so there was no need to do it again.

I won’t. I expect to have some time this weekend to install TWRP 3.5.0_9-0 and then the /e/ OS as you outlined above.

For some of us it certainly seems that way! :rofl:

Thank you again for your help- even as a “troublemaker” you are an invaluable asset to the /e/ team! :star_struck:


@mcmd, once you’ve TWRP or e-Recovery installed on your S9, the next step is a breeze.

1 Like

Please apologize my ignorance. How do I install/update TWRP?
I am aiming to move from /e/ o (8.1.) to /e/ Q (10) on an S9+. I also saw “Error 7”.

Edit: I just found this Galaxy S9 'starlte' + /e/OS 'Q' dev AOSP Android 10

The most common methods are flashing the TWRP files via Odin v3.14.4 (Windows host machine) or Heimdall suite (Linux PC’s). Instructions are a dime a dozen, especially for Odin3 - which is also available here.

1 Like

@SuzieQ Is it possible to save a Nandroid backup of the Samsung ROM for archival purposes once TWRP is installed but before flashing /e/OS?

Yes @mcmd, this is possible. But I have also found that restoring with TWRP Restore has not always worked one hundred percent. In theory, the Nandroid backup is easy and safe to handle, but practice always teaches me otherwise.

So I do separate backups of important data and files before the ‘Nandroid backup’, then the actual Nandroid backup. Besides, I hope that I don’t have to restore because … well, you know …

A sync to Nextcloud (e.g. /e/cloud) or with other CustomROM via SeedVault backup to Nextcloud can be very helpful.

I appreciate the insight. In this case, I am not concerned about preserving data, but rather in preserving the ability to go back to the stock ROM if I decide to sell the device at some time in the future.

To do this, should I backup all the partitions in TWRP (except Recovery of course) to be sure everything’s “there” or are only specific ones needed to accomplish this?

I know that there are Samsung “stock” ROMs available on certain websites (Sammobile, etc), but I do not know which S9 ROM is correct as they are carrier-specific. For example I am in the US, but purchased a device that shows “Samsung, Yateley UK” on the back. How would I know which U.K. ROM is correct (BTU, EE, H3G, O2, etc.)?

The cleanest way back to factory stock Android is via Odin3 or Heimdall. This will not only erase all partitions but reformat them from scratch. The real factory state is restored, so to speak.

U.K. ROM 'BTU’ is a good choice because it’s a provider-free firmware version. But the other versions are also fully suitable. They don’t differ in the basic functions (LTE frequencies) but rather in the bloatware included.


@SuzieQ Once again, many many thanks for your help! I’ll download the BTU version now for future needs and update this post with my /e/OS install experience so that others may be informed.

It’s look like TWRP 3.5 as TWRP 3.4 don’t match for installing Nougat, Oreo, or Pie,
But only Q and R.

The easy installer install the stables /e/ builds and it don’t yet exists Q stable /e/,
the dev build has just been released yesterday !

Hi SusieQ, right now I have the latest TWRP (twrp-3.5.0_9-1-starlte.img) version on the G960F, OpenSUSE Leap 15.2 KDE Dolphin has a pretty robust ability to connect to these devices, S8 /e/, and motorola for LineageOS all went well. This is my 4th phone in a few years and Samsung S9 is the most challenging, it gets to the mtp:/starlte/Internal Storage/ and then I can’t get any farther in.

adb CLI does not find the device at all, so two things, as you wrote somewhere no VENDOR file, no patch file used. The phone came with android 10 and 1 Feb 2021 update, running filemanger as root made no difference doesn’t get anywhere either and also it seems you prefer the e recovery tool instead, can I install the recovery tool instead? or am I overlooking something else?

Hi @luka,
your S9 comes the brand new stock Android 10 ‘1 Feb 2021’. There’re the best conditions to switch to /e/ OS ‘Q’ because the S9 firmware is fully tuned to Android 10 - including VENDOR, MODEM, etc… Therefore, we do not need any additional tools, except for a custom recovery.

TWRP Recovery offers me numerous tools such as the file manager. I appreciate TWRP very much. Nevertheless, eRecovery is a useful installation aid for the /e/ OS ‘Q’.

Yes, that is exactly why you should try eRecovery version recovery-e-0.13-q-2021012097133-dev-starlte.img, if TWRP is bitching° around, and and then use it to flash the /e/ OS via abd sideload It works flawlessly.

_ _
°Do you’ve an S9 DUOS or an S9 single SIM?

1 Like


Single Sim


So I have the SM-G960F Single SIM, I just re ran the heimdale command to flash eRecovery img instead,

there is that white progess line that shows up when does it actaully move. last night I went to bed and nothing had happend for TWRP nopw that I flashed eRecovery it’s also sitting here for like 40 minutes.

As far as the docs go I feel as part of the SDLC, being Software Engineer and Cyber security guy myself.

I am of the opinion that as part of change management and version control. All supported models represent a branch and that includes the level 1 support docs. Writing technical documentation is a thankless job…but when it’s correct it saves so much time on support calls, emails confusion and frustration and the ultimate decision of people to stick with the project and load the phone… Thereby using the phone so others will see and know… And it saves my sanity by not having to use one of my search engines to scour the giant dumpster fire known as the internet.

Also all these nougat and pie and oreo and Q are just nebulous marketing names and are usless we need version numbers like Q 10, pie 9 or oreo 8…I feel like the software that is ready and tested and official need to include the doc ( level 1 support ) as part of change management and version control…

The internet dumpster fire is full of bad technical writing…

1 Like

The flash procedure of TWRP or eRecovery is experienced in three minutes under normal circumstances. 40 minutes and more indicate technical faults in the hardware.

To isolate the error, here is a suggestion, a first step: Replace the USB 2.0 cable. Make sure that the USB 2.0 Type-A connector on the PC is plugged into a real USB 2.0 slot in the PC.

W’re probaly miscommunicating, :wink:

the documentation does not say what is supposed to happen. It does not reboot obvious because of the switch so what is supposed to happen,

heimdall flash --RECOVERY recovery-e-0.13-q-2021012097133-dev-starlte.img --no-reboot

``The doc say

  • A blue transfer bar will appear on the device showing the recovery being transferred. the transfer happens so fast the bar never turns blue.

  • Unplug the USB cable from your device.

  • Manually reboot into recovery:

I guessed and got into the sideload options ran the adb sideload command and now it mounted /system and is sideloading.

43.2 seconds

installed update

detected ext4

patchig system image unconditionally

script succedded result was[1.0000000]

Clear as mud but it works.

it Encrypted

and I’m at 10 at last

Wow the work interpreting the documentation was more work than the actual technical act of doing the mod.

Still man, cool project if your a masochist. LOL Kidding… I can start testing. Now where is my LAN line! and dial telephone!

Yes, I didn’t interpret your descriptions in your sense. That is one of the main problems of us speaking people, to express ourselves in such a way that the other person also understands exactly as intended by the author of the word. Such misunderstandings often result in great conflicts.

I understood that the flashing of TWRP was still not finished after 40 minutes. On the other hand, 43.2 seconds for data transfer of the /e/ OS ‘Q’ ROM via adb sideload is completely normal.

Let’s make a point at this point. You are on ‘10’.

1 Like