Is the bootloader locked? How to unlock/access on pre-installed phones?

No worries. Just make sure that when you are in the “Install” mode of TWRP, choose “Install Images” and not “Install ZIP”. There is a button in the bottom right corner which lets you switch between those two methods. Default is “Install ZIP” if I remeber correctly and this will lead to your image file not being shown.

I’m a little confused. We are talking about flashing eOS, or not. The eOS which you have downloaded is a zip, or not. If it is an img, pls show me where you downloaded it. So I know better for future issues. Thx

Sorry, Harvey186, no. I’m updating my TWRP.

In another thread, I mentioned that I would (also) be flashing eOS onto an old OnePlus One that I have … you commented there, as well … perhaps you’ve mixed up the threads?

In TWRP, /storage is empty. No “emulated” dir, no nothing.

This is in the “Install” section of TWRP, and it is regardless of whether it is set to install .zip or .img files.

Additionally, there is a ‘File Manager’ section of TWRP. In there, the /storage folder also appears empty.

Finally, TWRP has a terminal available. In the terminal, I ran ‘ls -a /storage’ command, which also showed nothing there.

ETA: While booted into TWRP, I just (re-)tried a variety of mount/unmount/remount/USB/MTP connection adjustments. Same as before, my laptop ‘sees’ the attached device. I can open a file manager window to it, but it is read-only. Cannot copy anything to the phone … additionally, it shows nothing on the phone.

Oh, ok, than there is an img file. That’s right.

But if you want update twrp, why don’t use the normal flashing way:
Boot into bootloader
From pc use command ‘fastboot flash recovery twrpXYZ.img’

harvey186, I know you’re trying to help, and I apologize if this is rude, but I covered all of this in my very first post in this thread. bootloader/fastboot doesn’t work on this phone. Apparently, this is a Samsung thing.

TeamWin’s - TWRP for Samsung Galaxy S7 Edge - “hero2lte” (Exynos) (SM-G935F) offers two hero2lte files:


Image supplement to “There is a button in the bottom right corner which lets you switch between those two methods.

If you really have a twrp*.zip file, try the following:

  1. Boot your device into recovery mode on device with key combination VOL(+) - HOME - POWER directly in TWRP.
  2. Then connect your Samsung Galaxy S7 Edge via USB to your desktop computer and open “Advanced → ADB Sideload → Swipe”.
  3. From the Desktop Computer, transfer the *.zip image to the hero2lte device with this command:
    adb sideload /

This allows you to update devices where TWRP has problems with encryption.

FUCK!!! Fucking Android piece of shit.

Something, somewhere in the process of trying to fix the “TWRP can’t find my internal storage” … fucking phone reset to original settings. All of my installed apps and personal data is gone.

TeamWin - TWRP What should I back up in TWRP?

All this time, the whole point of trying to update to a new version of TWRP was specifically and explicitly to fix that. Using a TiPatched version of TWRP, that does in fact include internal storage in the backup …

Except Fucking Android goes ahead and wipes my internal data, literally as I’m in the process of figuring out how to back this up properly.

… words cannot express …

Sorry to here that, that’s indeed very frustrating but I guess everybody can tell you a similar story about their trial and errors at the beginning.

Just don’t give up yet - if you want, I can assist you in a phone/video call.

1 Like

Weird silver linings … first, the full reset of /e/ has fixed the TWRP issue. Something was screwed up on the partition, somehow, that was preventing TWRP from interacting with it correctly.

Second, I swear my phone is working better now, than it ever has before. The camera performance, in particular, is night and day … it has flat-out sucked since the day I got the phone, and now it’s pretty good, 5 or 6 out of 10.

Other improvements, too … I think … subtle enough that I might be imagining/projecting …

I will start a new thread shortly, specifically to document this unexpected improvement in my instance of /e/.

Good to hear :+1:t4: