Issue with echo heard by call receivers on some Galaxy S7 devices

Issue details: Some Galaxy S7 users have complained of an echo at the call receiver’s end. The caller would not be aware of the issue unless the person on the other side of the call complains.

Some of these devices were purchased from the Murena Store.

Investigation: The development team did a detailed analysis of the issue and has arrived at the following conclusions.

  • The issue is due to incompatibility between the hardware and the software which assists in the noise cancellation.
  • This problem does not impact all users of this phone.
  • The Galaxy S7 devices in question are from 2016 and have stopped receiving firmware updates by the vendor since 2019… This effectively means there will be no vendor patches for the device any longer.

Solutions tried:

  • Debugging: No positive results to report despite exhaustive efforts.
  • OS upgrade: The S7 was released with Android 7 (also called Nougat) and thanks to the /e/OS developers was upgraded to /e/OS based on Android 10 (also called Q). Unfortunately, this has not resolved the echo issue.
  • Use different firmware version: no result
  • Play with audio configuration: no result

Action to be taken :

  • Based on these findings, the development team has concluded that it would not be possible to resolve the echo related issue in the affected Galaxy S7 devices.
  • The echo issue related bugs in GitLab raised for this hardware will be closed with these findings.

Learning from this exercise:

  • The Murena store has stopped sourcing and selling this model
  • Testing of builds and newer devices includes test cases to check for echo on receiver side.
  • Testing teams to include volunteers spread across different regions and service providers

Remedial Step(s):

  • Use of headphone has been reported by some users as a possible solution to this problem

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Thank you @Manoj for this conclusion,
I have this problem and for me, using headphones actually allows me to solve the problem. It’s a phone bought reconditioned 4 years ago, the problem will be solved at the end of its life.

Merci pour cette conclusion,
J’ai ce problème et pour moi, utiliser des écouteurs me permets effectivement de régler le problème. C’est un téléphone acheté reconditionné il y a 4 ans, le problème sera réglé définitivement à la fin de sa vie donc.

That is a very good idea. Could you please also include testing on a video call using any kind of messenger. Thanks very much!

Please don’t “close” the bug , because people will not find it directly from the device page , or change the filter to include " won’t fix" status ( is this the case already ? )

We can add links to this page from the issue on Gitlab and the device page.

1 Like

Thank you @Manoj for the wrapup!

Thank you @Manoj for your efforts here.
I will retire my old S7 and replace it with a more up to date phone that is currently receiving firmware updates.

1 Like

With my GS290 I also experience such problems. Based on the technical explanation given, is it likely that this phone also have this problem?

1 Like

Hi Tore,
I’m not aware of such an issue with GS290.
I suggest you perform a factory reset of your phone, and if the issue persists, please contact helpdesk with as many details as possible.

Factory reset doesn’t help.
I have also this problem on my GS290 since eOS 0.9.
after the update, the problem is still exist.

Hi @MichielP80 pl send the details of the issue to
As @Shenol mentioned we have not received reports of echo on the GS290. @Tore 's post above also mentioned this.

Regarding the echo problem with the S7:
I haven’t been able to test it extensively yet, but I just tested one of the suggested solutions from this video “How to fix echo problem on your Samsung Galaxy S8,S7,S6”.

At least with one device with which the echo problem occurred so far, I then tested it and the echo then no longer occurred.
I activated the option “Mono audio” in the settings, as suggested there.
The other advice suggested there is to boot into safe mode once and then boot normally again.
I can’t say yet whether this helps permanently, but have these methods also been tested or has anyone tried them?

1 Like