Issue with MMS + Internet APN

Hello !

I have seen that I am not the only one with this kind of issue, but I was not able to reply to an existing post to ask a question so I create this new topic.

I am using the NRJ virtual provider (the selected network is Orange). I can either connect to Internet when selecting the NRJWEB APN, or send MMS when selecting NRJMMS. To be able to select the NRJMMS, I have added “default” in the APN Type field. If I do not do this, I cannot select NRJMMS and I am not able to receive or send MMS (but then, of course, I cannot access to the Internet anymore).

I have read that this issue was solved for some users at Free Telecom and Sosh by adding “mms” in the APN Type field of the Web APN.
This is something I tried but it did not work. I even tried to add the MMS parameters into the Web APN settings but it did not worked neither.

Because Sosh is Orange, could someone for whom it works give me his or her Web APN settings ?

…Or if someone has another solution to propose, I am open to test anything ! :slight_smile:

FYI, my /e/ OS version is 0.7-o-2019082020897-stable-star2lte.

Many thanks by advanced.

B.R.

Eric

Hi Eric,

Does it have worked on other custom rom ? Or only on stock rom ?
I would prefer to flash a custom rom or stock rom where it was working, writing down the APN setting, flashing e new and setup your APN with the settings you have from working rom.

I know it’s a worst to do, but so you can find (I hope) a solution

Hello @harvey186,

No, /e/ OS is my first lineageOS. I owned a Samsung S9+ with the OS pre-installed, received it a few days ago, and have never upgraded it.

The workaround I found for the moment is to select the MMS APN as the default one, so I can receive and send MMS, and I use the WiFi to access to Internet (either at home or sharing the data connection from another phone).

I believe I will be patient and try the next release. If it does not work, then I will start to cry and find an early ROM that works :slight_smile:

I have seen that some APN can work for both Internet and MMS, this could be another (and better) workaround to configure it for my phone, but I do not know how to find it.

Many thanks for your time, @harvey186, you are too kind !

B.R.

Eric

Your are always wekcome and I hope your workaround will work for you.

One yhing you can try. Ask a friend who is using yhe same network for his APN setup. So you can create your own APN with that setup to test if it will work better.

Good luck

Hi, this is working for me with Sosh

teste cela,
pour free avec /e/ en plus de paramétré les apn il faut aussi corriger un petite bug de /e/
29j

alors j’ai trouve une solution qui fonctionne.
ici Mise à jours des apps
je vous mets le tuto de la solution :

il faut avoir “adb” d’installé sur son PC ou sur Ubuntu. pour “windobe” le Minimal ADB and Fastboot sufit.
pour ubuntu c’est pus simple, il faut juste installé le paquet “abd”. avec un sudo apt-get install adb
pour savoir comment utiliser abb, ici un petit tutot.

mais en résumer :

l’appareil Android pour ADB

Pour utiliser ADB, il est nécessaire d’activer le débogage USB dans les options de développement sur l’appareil Android. Pour cela, rendez-vous dans la section « À propos du téléphone » dans les paramètres de l’appareil, puis touchez sept fois la zone Numéro de build . Au terme des sept appuis, un message vous indique que vous êtes développeur ! L’option Options de développement apparaît de nouveau dans les paramétrages Android. Vous pourrez alors activer ou non le Débogage USB .


en suite sur l’ordinateur dans une invite de commande taper dans l’ordre les commande suivante :
pour windows si vous avez le message abd commande inconue, il faut d’abbord vous placer la ligne de commande dans le répertoire ou vous avez télécharger abd minimal.

adb root 
adb remount
adb shell
echo "ro.telephony.mms_data_profile=5" >> /system/build.prop
exit
adb reboot

une fois le téléphone redémarrer vous devriez pouvoir envoyer des mms en data.
enfin pour moi cela a marché.

Hi guys,

The solution could be interrested for other people. You are here in english group, so pls answer in english. Thanks

sorry my english is too bad to write a translation of my answer.:woozy_face:

Yes, this was the purpose of my ticket : to find someone with a single Orange or Sosh APN that works with both Internet and MMS :blush:

Provenance :
Courrier
pour Windows 10

And is solved now ?? If Yes, could you please edit your headline to “[SOLVED] Issue with MMS + Internet APN” ?

I am moving at that time, I will be able to test the configuration provided by @alezan this Saturday in the afternoon (CET).

I will tell you, @harvey186 ! :slight_smile:

B.R.

Eric

Hello @alezan,

I have tested your configuration for “Orange World” APN. This issue is that I cannot save any API with MNC at “01” : It deletes the entry !

I tried 20+ times to see if it should come from a random bug, but

  • either I create the APN with the default MNC, save it, then change the MNC to 01 and save again the APN, the APN disappears
  • or I create the APN with the MNC at 01 from the beginning and nothing is saved

It is really disturbing !

@harvey186, I believe there is a bug INSIDE the bug :smiley:

Eric

I don’t understand why this APN must be 01. On German.and Austria networks I can create 10 or more APN which I can select and use manually.

Hello!

MNC at 01 is for Orange network, regarding the documentation.

B.R.

Éric

Télécharger Outlook pour Android

Hi @edejaeger ,
Did you tried to re-initialize default network’s parameters ?

Hello Torn,

Yes, I did it.

… And I am still looking for some help to make it work :slightly_smiling_face:

I will open an issue on the Git Lab…

Télécharger Outlook pour Android

Salut @alezan,
J’ai le meme problème de MMS avec un Samsung J5 depuis la MàJ e-0.7-o-2019101026628-dev-j5lte.zip
J’ai essayé de faire la modification du fichier /system/build.prop
Le problème chez moi est que ce fichier est en readonly. Je n’arrive donc pas à le modifier.
Je suis bien en adb root et je peux voir le contenu de build.prop mais je ne peux pas le modifier.
Quelle manip puis-je faire à ce niveau là ?
En tous cas, merci pour le boulot que vous faites :slight_smile:

@alezan
Re
J’avais oublié la commande remount !!!
J’ai bien modifié le fichier build.prop mais cela ne résout pas mon problème d’envoi de MMS :frowning:

Est ce que tu as bien redémarrer ton téléphone ?

Les commande a passer son
adb root
adb remount
adb shell
echo “ro.telephony.mms_data_profile=5” >> /system/build.prop
exit
adb reboot

Puis redémarrer le tel

Salut Alezan,
Merci de ta réponse.
Oui j’ai bien redémarré le tel mais je crois que le problème vient de la nouvelle mise à jour (celle du 09/10/2019)
Encore merci