Issue with no connectivity for users still on old builds post release of v2.0


I tried to updgrade but the upgrader does not show any recent update.
I tried to follow the following recommandations poster ealier here

“since version 1.14, a few users have reported a crash with the system Updater whenever they try to open it. In that case, they won’t get notified of the next OTA system update. To solve this problem users need to: go to Settings > Apps > See all apps > 3 dot menu > Show system > Updater > Storage & cache Tap on Clear storage and validate Go to Settings > Updater Tap on the refresh arrow And voila! 1.15 should appear among the available updates!”

It did not help and the last version I see is from 2020

Is there another way to get the updates ? If not, is there a tuto to back up and flash in order to updgrade a fix this internet issue ?

A search in the documentation finds several pages about backups, this here among them …

Installing manually can be done with the Easy Installer or via command line … … both methods will wipe user data.

But since you are on Android 10 (Q) and stable, I would perhaps wait if something comes up to either solve this failure to upgrade or at least explain it.

At least the OTA server still knows about those old versions, so it should be able to offer something to the updater.

Are you on a Wi-Fi internet connection when you try to find updates?
Do you use any Antivirus or Firewall App you could deactivate to see whether they were blocking the updater?

@Manoj: 0.12-q-2020111084009-stable-FP3 should still be OTA upgradable in theory, right?

If nothing helpful comes up otherwise … There is a method to update in recovery mode to a newer version within the same underlying Android version without wiping data, in effect emulating what the updater should do, but this isn’t officially recommended or documented, and backing up everything important from the phone to somewhere safe beforehand should be done before trying this, too.
I don’t know whether everything was in place for this already with the 0.12 recovery, but if you want to try and find out and have no fear of the command line, perhaps open a new topic to be walked through this.
The idea would be to get to 1.4-q-20220920220045-stable-FP3 this way and see whether the updater can upgrade by itself from there.


Hi @aidb
Thank you for the help ! I will try to answer you questions :

  • My phone is a fairphone 3
  • the cloud is working well (even if I am at 95% full)
  • My phone is indeed locked…
  • my computer is a mac, but it more or less the same as the linux command, so I am not lost.

I also find this tuto :
would you recommand “OTA Sideload” of “Flashing with fastboot” ?

Last question : which OS do you recommand ? Should I go directly from android 9 to 11 or to 13 ?

Thank you very much for all the help :slight_smile:

If you follow that tutorial you will install FaiphoneOS not /e/OS.

The way to install /e/OS is by means of a script delivered with the ROM. The script uses a fastboot method. The tutorial at the end of my last post describes how it works.

The /e/OS device page is, the Command line install page is linked from it. You will see that Easy Installer is an option too,.

I think you would need a good reason of your own not to choose the latest build; so Android 13 (T).

The main thing to fix in your mind is if you plan to install Official / stable, with OTA Android version upgrade to look forward to or the Community / dev build. The different build types are described

1 Like

so my phone still transfers data normally but it always shows the “x” for both wifi and mobile data and says “no internet”. I wouldn’t care but this sadly affects the functionality, some apps don’t even try to run and tell me to get internet connection (e.g. spotify), same thing for synchronization of e-account data (e.g. calendar)

You will notice @sex that this thread has a “get you home” solution from … and Post #69
You will also notice that affected users seem to have an older build and an Upgrade to latest for your phone is the likely best long term fix.

See also Week 22 2024: Development and Testing Updates

1 Like

Whoa !!! I didn’t even realised FaiphoneOS was a thing !!! I was convinced that I was installing e/OS ! Thank you very much for the clarification !

I tried the easy installer, but it doesn’t detect my phone, whereas adb does detect it :-/ not sure what happened there.

I will procede to in install tomorrow, hopefully with th right OS :-p I will let you know how it went !

I would guess most Fairphone OS users don’t even realise /e/OS is a thing :slight_smile: .

@AnotherElk, Fairphone OS former users are fossils like me, that lived in the times of Fairphone 1, then 2, then… (we are at model 6 now IIRC) : please don’t talk badly of fossils :sweat_smile:

thanks @aibd ! I made it to the step “choose custom servers in captiveportalcontroller”. what exactly do I do here?

For me the easiest solution was to tap on each field and then select the default option that the app suggests. This got things working, but i do not know how good - or private - these settings are.
In one of the other threads on this topic @tcecyk suggested 3 murena servers. I got those working by trial and error, but do not really know if what i did was in any way sensible either.
I think we, the users with problems, need to be better at not starting new threads, rather first checking thoroughly to see if anyone else has already asked a similar problem. Then people do not need to repeat the answers again and again and there will be a complete, definitive thread with all the info in one place.
Here are the settings i guessed at with the murena servers:

Fallback 1:
Fallback 2:
User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.32 Safari/537.36

If anyone can tell me if these are right or wrong i am sure the info might be useful to others too.

1 Like

@4nthony looks good. Order of servers doesn’t matter as they’re supposed to behave the same way - and all hosts can do both protocols. just that you use https where it is a https variable.


I use eos based on android 8.1.0.
recently i got the info from my browser, that i have no internet connection. however i can surf.
app store: no connection possible at all. wifi connected: also no internet connection, but i have internet connection.

i think i know the reason: the server where eos is asking if there is internet connection was shut down or changed the ip or something.

where can i change the server that is asked if i have an internet connection or not?

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

Hi @Sanni it seems you ran into a “new” (negative) issue with older builds :slight_smile:

Allow me to point you to Issue with no connectivity for users still on old builds post release of v2.0 where many such issues have been “amalgamated” :slightly_frowning_face:

Best fix “Upgrade to latest”. especially

i do not wan to be forced to update. how long the update will work? until someone wants me to update again? somewhere must be written the server that is contacted to check the internet connection. this server ip i must change and thats iti would say. in the links they dont say how to, but they also want to avoid updating…

Another edit Thanks to @piero there is now a full guide to the solution you want here: May 2024, Solution to connectivity issue on old builds and a copy on this thread Post #115.

The above replaces

Edit There seem two “marked solution” on this thread Post #69 and Post #79

At present another thread with the solution you want still exists OS think's I'm offline even though i'm not - captive portal server?

See also on this thread Post #107

Also Week 21 2024:Development and Testing Updates - #15 by tcecyk


Nobody forces you to have a smartphone with the accompanying software-sanitary responsibilities.

/e/OS gets updates including further security patches on supported devices roughly every month.

thanks to @tcecyk @aibd @poiuzzz @4nthony for the solution


First of all thank you very much for this detailled solution.
I planned to do it these days. To check an usb-c ethernet adapter (completely a different topic) i plugged it into my eos phone. I saw it is working. By chance and i am still not sure if this is related to the adapter, i saw that the message “no internet” was gone. Maybe already before, i am not sure. I checked the app store which was always complaining and yes also this worked! So i made no upgrade and no change as proposed here and nevertheless it works now. Crazy.

Your help here in the forum is awesome. I take this opportunity to say this to all of you. Thanks!!

1 Like

divine intervention, not the adapter. Someone finally made the sensible call and re-enabled - the source of all the hubbub