Issue with no connectivity for users still on old builds post release of v2.0

so my phone still transfers data normally but it always shows the “x” for both wifi and mobile data and says “no internet”. I wouldn’t care but this sadly affects the functionality, some apps don’t even try to run and tell me to get internet connection (e.g. spotify), same thing for synchronization of e-account data (e.g. calendar)

You will notice @sex that this thread has a “get you home” solution from https://gitlab.e.foundation/e/backlog/-/issues/7975 … and Post #69
You will also notice that affected users seem to have an older build and an Upgrade to latest for your phone is the likely best long term fix.

See also Week 22 2024: Development and Testing Updates

1 Like

Whoa !!! I didn’t even realised FaiphoneOS was a thing !!! I was convinced that I was installing e/OS ! Thank you very much for the clarification !

I tried the easy installer, but it doesn’t detect my phone, whereas adb does detect it :-/ not sure what happened there.

I will procede to in install tomorrow, hopefully with th right OS :-p I will let you know how it went !

I would guess most Fairphone OS users don’t even realise /e/OS is a thing :slight_smile: .

@AnotherElk, Fairphone OS former users are fossils like me, that lived in the times of Fairphone 1, then 2, then… (we are at model 6 now IIRC) : please don’t talk badly of fossils :sweat_smile:

thanks @aibd ! I made it to the step “choose custom servers in captiveportalcontroller”. what exactly do I do here?

For me the easiest solution was to tap on each field and then select the default option that the app suggests. This got things working, but i do not know how good - or private - these settings are.
In one of the other threads on this topic @tcecyk suggested 3 murena servers. I got those working by trial and error, but do not really know if what i did was in any way sensible either.
I think we, the users with problems, need to be better at not starting new threads, rather first checking thoroughly to see if anyone else has already asked a similar problem. Then people do not need to repeat the answers again and again and there will be a complete, definitive thread with all the info in one place.
Here are the settings i guessed at with the murena servers:

HTTPS: https://connectivity.murena.io
HTTP: http://connectivity.murena.io
Fallback 1: http://204.murena.io
Fallback 2: https://murena.io/generate_204
User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.32 Safari/537.36

If anyone can tell me if these are right or wrong i am sure the info might be useful to others too.

1 Like

@4nthony looks good. Order of servers doesn’t matter as they’re supposed to behave the same way - and all hosts can do both protocols. just that you use https where it is a https variable.

2 Likes

Hello,
I use eos based on android 8.1.0.
recently i got the info from my browser, that i have no internet connection. however i can surf.
app store: no connection possible at all. wifi connected: also no internet connection, but i have internet connection.

i think i know the reason: the server where eos is asking if there is internet connection was shut down or changed the ip or something.

where can i change the server that is asked if i have an internet connection or not?

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

Hi @Sanni it seems you ran into a “new” (negative) issue with older builds :slight_smile:

Allow me to point you to Issue with no connectivity for users still on old builds post release of v2.0 where many such issues have been “amalgamated” :slightly_frowning_face:

Best fix “Upgrade to latest”.

https://gitlab.e.foundation/e/backlog/-/issues/7975 especially https://gitlab.e.foundation/e/backlog/-/issues/7975#note_544102

i do not wan to be forced to update. how long the update will work? until someone wants me to update again? somewhere must be written the server that is contacted to check the internet connection. this server ip i must change and thats iti would say. in the links they dont say how to, but they also want to avoid updating…

Another edit Thanks to @piero there is now a full guide to the solution you want here: May 2024, Solution to connectivity issue on old builds and a copy on this thread Post #115.

The above replaces

Edit There seem two “marked solution” on this thread Post #69 and Post #79

At present another thread with the solution you want still exists OS think's I'm offline even though i'm not - captive portal server?

See also on this thread Post #107

Also Week 21 2024:Development and Testing Updates - #15 by tcecyk

2 Likes

Nobody forces you to have a smartphone with the accompanying software-sanitary responsibilities.

/e/OS gets updates including further security patches on supported devices roughly every month.

thanks to @tcecyk @aibd @poiuzzz @4nthony for the solution

Résumé
3 Likes

First of all thank you very much for this detailled solution.
I planned to do it these days. To check an usb-c ethernet adapter (completely a different topic) i plugged it into my eos phone. I saw it is working. By chance and i am still not sure if this is related to the adapter, i saw that the message “no internet” was gone. Maybe already before, i am not sure. I checked the app store which was always complaining and yes also this worked! So i made no upgrade and no change as proposed here and nevertheless it works now. Crazy.

Your help here in the forum is awesome. I take this opportunity to say this to all of you. Thanks!!

1 Like

divine intervention, not the adapter. Someone finally made the sensible call and re-enabled connectivity.ecloud.global - the source of all the hubbub

4 Likes

I also didn’t believe that the adapter had something to do with it, but that someone reactivate something on Eos site was even more incredible for me, so i stayed with my adapter-theory😅

1 Like

It is a bit late, but I wanted to say thank you @aibd for the support !

Everything is now working well. I ended up using the easyinstall for mac, on the 28th, and it took about half an hour to have un updated phone :slight_smile:
I recommand it for everyone ! I had to change the cable for a better one, and restart my computer.

2 Likes