Issue with no connectivity for users still on old builds post release of v2.0


I’m using Fairphone 3 and haven’t made any changes in a long time. Suddenly since yesterday Wifi shows as “No Internet” below the icon and a cross is visible on the icon. Wifi is connected however, and internet is working fine in the web browser. So far, the only place I notice internet isn’t working is in the app store where it says “Can’t connect! Please check your internet”, which is kind of a problem since then I can’t update Aurora Store, and with the version of Aurora I have I can’t login. So I’m stuck without the ability to update any apps. Using mobile data, internet works fine too, except in the app store and Aurora store, which shows same inability to connect or login with mobile data too.

Any ideas are greatly appreciated,

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

1 Like

Hi mate,
just a heads up that I’ve got the same issue since today: OS think's I'm offline even though i'm not - captive portal server?

Same problem;

I’ll report an issue.

Sorry, can’t register at gitlab-server, Tried several E-Mail addresses.

If you tell me how to report a problem, I can do it :slight_smile: I have the exact same issue since yesterday.

1 Like

had already finished this text (and can provide logcat.txt but don’t know how):


Without changing anything, I have a “x” in the wifi symbol.
I have access to internet using Firefox.
But some applications seem to use this status.

I restarted the phone, disconnect battery and tried four different routers.
An identical device with Android works.

I don’t use Advanced Privacy. The settings under “Securitly&Privacy” all seem unchanged.
Connection via mobile data works.
Other than updates, I didn’t change anything on the device at the time of the error.

However, I had an Amazon Fire stick that I wanted to root connected to the WiFi. Maybe e/OS/ is offended :wink:
(I sent a few commands to the stick via ADB. But that can’t be it?)

Seems I’m not alone:

Xiaomi Redmi Note 4
eMido-userdebug 9 PQ3A. 190801.002 eng.root.

If it helps finding a solution:
Besides several network settings with DNS, Roaming etc. I also tried to change the captive portal to my own host (a simple oneliner to return a 204 status code). Unfortunatly that hasn’t fixed it.

Sacer, can you tell me how I can get and change the captive portal ?

Got my info from here:

Thank you for the link !
From the following link it seems there are 4 different captive portal parameters:

  • captive_portal_server (<= Android 6.0.1)
  • captive_portal_use_https (>= Android 7.0)
  • captive_portal_http_url (>= Android 7.0)
  • captive_portal_https_url (>= Android 7.0)
1 Like

report an issue here:

1 Like

I’ve checked the network traffic and it seems some HTTPS requests are failed.
Could our issue be due to an expirated certificate ?

Interesting. However, I cannot confirm that only http sites work.

You could try to set captive_portal_use_https to 0

As for the general issue, I “fixed” it by simply updating /e/OS
For more details see here: OS think's I'm offline even though i'm not - captive portal server? - #3 by Sacer

Unfortunately there is no update for my device:

Xiaomi Redmi Note 4
eMido-userdebug 9 PQ3A. 190801.002 eng.root.

I have the same problem since yesterday on my Fairphone 3. The data and wifi work despite the phone thinking there is no connection/saying I’m offline. The only thing that doesn’t work is spotify, the app thinks I’m offline and so I’, not able to play any music and I can’t connect to the sonos player.

Issue is reported:

1 Like

what to do in such a case?

I don’t know. Waiting for solution.