Issues Installing /e/ q on Essential ph1 with Android 10 q

@marcdw @Quaternium Hi! You two seem to have experience with /e/ in the Essential ph1. Perhaps you could help me finish installing it.

I first followed the official instructions.

I hit a roadblock when flashing recovery:
fastboot flash recovery recovery twrp-3.2.3-0-mata.img
Sending 'recovery' (48712 KB) OKAY [ 1.663s] Writing 'recovery' FAILED (remote: 'No such partition.') fastboot: error: Command failed
I tried with fastboot boot, fastboot flash boot as well, and got basically the same error.

I then found the forum post: Error in installation instructions, unable to make backup
Which shows the trick of doing:
sudo fastboot getvar current-slot
sudo fastboot set_active a
sudo fastboot flash boot_a twrp-3.2.3-0-mata.img
I was then able to boot into TWRP recover, but touchscreen didn’t work.

I then found the other informative post: Updating to /e/OS Pie using fastboot, adb, and TWRP from where I learned the issue is with the official TWRP image. However, these posts are focused on upgrading /e/ pie. I’m simply interested in installing whatever is the latest functioning version of /e/ into my Essential, which has never had /e/ before. At the time of this writing, /e/ q is the latest version available.

  • Does all that mean that it’s still not possible to install /e/ in Essential ph1, due to the TWRP issue?
  • In that case, why are the official instruction still misguiding new users into using the malfunctioning TWRP? (Like me)


  • Is it advisable to stay away from the latest /e/ q on Essential ph1? I was hoping to install /e/ q, but I would still consider installing pie, or whatever else works.

The article referenced, “Installing LineageOS and Magisk on Essential Phone PH-1 using Windows” uses a different version of TWRP, but I need some clarifications before I can put this procedure into practice.

  • Will I have to install /e/ Pie? Or will I be able to install whatever version of /e/, once I get past the TWRP issue? (Like /e/ q)
  • Would this procedure also work from Linux (The writer specifically uses Windows)?
  • Is it necessary that my current Android version be the same as the version of /e/ I’m trying to install? In this case, I have Android 10. Does that mean I can intall /e/ q?

I actually managed to install /e/ q and have it working with touch enabled. Everything else looks good so far. Here’s how I did it.

In my experience, the only factor that diverged from the official instructions was the specific img file used as recovery, and the specific procedure to install the recovery. The official instructions say you should use the official TWRP file in: “The version of TWRP we used to test the ROM was 3.2.3-0”. Well, that produced the no touch issue. Instead I used the file @marcdw provided from his Google Drive:

September 2018 pre-patched TWRP image with touch ( Google Drive ).

The specific way to install the recovery should be as demonstrated in this article:

  • Get the current slot:
    fastboot getvar current-slot
    This will return either “a” or “b”
  • Flash TWRP to opposite slot. (If “a”, then do “b” in <slot> below, etc.)
    fastboot flash boot_<slot> twrp-mata.img
  • Set slot where we flashed TWRP as active.
    fastboot --set-active=<slot>
    So, if your current slot was a, you will use --set-active=b above. If current slot was b, you will use --set-active=a above.

I will add that if for any reason, the TWRP recovery doesn’t load at all, then just install it in the other slot, set it as the new active slot, and try again to boot into recovery. (Either with the physical buttons, or with adb reboot recovery.

Enjoy /e/!

This worked for installing /e/ q in Essential ph1, which previously had an up-to-date version of Android q as well.

Those instructions should definitely be updated. Other people don’t have 4 hours to spare researching through forums like I did today.

I tried creating an issue in the board for “mata”, but it asks for “Select a project”. I’m not sure what I should choose there. Anybody can point me in the right direction here?

If you want to suggest updates to the documentation then you can add it here
If you are reporting a bug in the ROM you can raise the issue on gitlab

Cool deal. Glad you got all that sorted out.
Excuse the late response. I haven’t yet made the move to Q and I’m not sure if I will. Yet. Each new Android version introduces new restrictions (read security enhancements) that don’t sit well with the way I do things. Only one of my devices runs Android 9 (/e/OS Pi/e/) because i was reluctant to even move up to that at first.

Kudos for your perseverance and apologies for not responding earlier.

I thought I had submitted info for updating the documentation awhile back. Let’s see what we can do to fix that situation.

Been spending too much time fighting with Pinephones. :grin:

im not sure if this is where id want to post this or make a new thread. im having a difficult time finding something that answers this-

i flashed the essential with twrp as guided, everything went smoothly all the way through to installing e. as soon as e booted up i lost all touchscreen. anything i can do to easy fix? thanks

its in the e setup menu where you would hit ‘next’ or ‘emergency call’

Check this thread from last month. It might be helpful.


If you flashed twrp as a temporary recovery with the fastboot flash boot command, and because you have installed e (even though it’s not booting properly) you may now have eRecovery on your phone as part of the install. So you could power off and manually reboot to recovery. If it’s eRecovery, sideload e again.

On my PH-1 installation with eRecovery was a doddle. Only when later on I tried flashing something else with twrp did I discover the trouble that this phone can get into!

Also, I followed the Lineage install instructions to get e up and running.

@chrisrg i did everything per supported /e/ device page

@marcdw thank you- thats what i was looking for. there are lots of forums to sift through to find exactly what i need. do i have to go back to stock before going forward with the patched twrp or would installing new twrp.img overwrite old?

ok i get what you are saying now (took a minute to sink in) yes, it is eRecovery. are you saying sideloading e again would work without updating twrp?

Ok I got it working- process of elimination and a bunch of dead ends.

My conclusion is an issue of going from the nougat. After I did the flashallwipe.bat from the Back-To-Stock Pie build following marcdw’s post, I could install the December TWRP update (until then the touchscreen didnt function on anything other than the TWRP from the website) After that everything went smoothly following the Essential Install guide.

Thanks again - Cheers