Jack headphones (3.5) not working on a Pixel5 with usb-c adapter


I have a Pixel 5 with the e/OS v1.17-t. I want to use my jack headphones but the phone only has a usb-c socket. I’ve tried connecting them to the phone with a usb-c to jack (3.5mm) adapter but they don’t seem to be recognised. The sound is still coming out of the phone’s speakers. The “Disable USB audio routing” option is not activated. I tried using 2 different headphones and 2 different adapters, including the one sold by Google for the Pixel.

Does somebody have the same issue?

Kind regards

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi Pierre

There are different types of USB-C to AUX adapters. Some have a built in DAC (digital audio converter) and some don’t. The Pixel phones need an adapter with DAC.
I had the same problem with my Google Pixel until I purchased an adapter with DAC (e.g. https://amzn.eu/d/3uUQSho or https://store.google.com/de/product/usb_c_headphone_adapter)
My first guess is that your adapter lacks a DAC and therefore your headphones are not recognized.


Works also fine: Google Pixel USB-C™ earbuds


Thanks for your help @Ulf. I bought 2 adapters, including the one from Google because it contains a DAC according to the information I found on the internet. But it still doesn’t work :slightly_frowning_face:

Can you please tell me what system settings are you using (“Disable USB audio routing” and “Transcoding of multimedia content” in the Developer options?

I will consider your option @Xxpsilon if this doesn’t work but I hope I will be able to use my headphones.

Hi Pierre

I didn’t do anything to the Konfiguration settings. I just plugged the adapter with the headphones to my Pixel phone(s) (4a, 4a5G, 6, 6a, 7a) and it worked (also with /e/ OS).

Did you tested it also in other phones to validate there’s no problem maybe with the headphones now? :wink:



Problem is solved :smile:

@Ulf My headphones work correctly with other devices. So the issue seems to be related to my phone.

I try with an other Pixel 5 whixch is also with /e/OS and it works with my headphones and my adapter.
So I check the usb configuration between the 2 phones and found 1 difference. My phone is in French so here is the option (in the “Confidentialité > Trust” menu):

Restreindre l’USB
Contrôler la prise en charge des connexions USB telles que les écouteurs, les périphériques de stockage, etc.

On my phone this was set to:

Autoriser les connexions USB lorsque l’appareil est déverrouillé

On the other it was:

Toujours autoriser les connexions USB

I change the setting on my phone and now it works!

Thank you for your help

Hi @PierreT

I checked the settings in my Phone(s) with /e/ OS and there the USB restriction is also set to “always allow USB connections”. This seems to be the default setting so it was working right out of the box on my phone(s).
Glad to hear it is working now as expected also on your side. :tada: