Joplin keeps crashing at launch

After reading some posts on this forum, I’ve decided to install Joplin to manage notes. But once installed, this app keeps crashing (I’ve managed to launch once and then it crashes when I’ve tried to open a note).
The Joplin version is 1.0.312.
The phone is a Samsung Galaxy S7 Edge with /e/ pre-installed
The version of /e/ is lineage_hero2lte-userdebug 7.1.2 NJH47F20191008.

I don’t know whether it’s an issue of Joplin or of /e/? Thanks.

My Galaxy S6 Edge works like the S7 Edge with /e/ OS e-0.7-n-20191225 and Joplin notes v1.0.312 is also installed.

It starts and does not crash. I am welcomed …

Unfortunately I cann’t tell you more monentanously.

Also have a look at “Simplenote” available in the App Store> 9.0 Privacy rating.

Simplenote is also available for iOS, Android, Mac, Windows, Linux and the Web and can be downloaded from the manufacturer’s website. I like that. But he synchronization function has its price: In order to use Simplenote, an account must first be created.

Is the “Joplin” problem on your S7 edge solved?

Joplin runs on all of my ROMs including /e/ although oddly, yesterday, on three ROMs on three devices (/e/ being one of them) Joplin would crash whenever I tried to access its Configuration. That was odd. I was going to blame it on Substratum as those ROMs were themed but another that was not didn’t have the crash. But I don’t think that was it after booting to another ROM with SubS theme and no Configuration crash.

But anyway, Joplin runs fine on /e/.

It still doesn’t work: it just crashes when it opens. No time to access the configuration.
I would prefer to use Joplin instead of the Simplenote because you can synchronize with the /e/ cloud and don’t need to create another account.

@ctranxuan, a suggestion: do an OTA update of your /e/ OS ROM to the current Dec’20190 build. This includes also a updated microG release e-v0.2.10.19420

See also → OTA Update Changes

Try updating Joplin app, although ive not had any crashes personally, ive noticed the app in f-droid has been updated 3x times in the past 3 days… maybe has something to do with it.

Thanks for the hint. I’ve updated to /e/ 2019110830013 but I’ve got the same issue.
May be it’s related with the Bliss Launcher: every time I uninstall Joplin, Bliss Launcher crashes.

I’ve the latest version available v1.0.312 (on /e/ Apps and on Joplin website). I haven’t found it on F-Droid. I’ve seen newest versions on Joplin’s gitub but nothing packaged.

As of writing this message v1.0.315 is latest on f-droid (IzzyOnDroid Repo) Which is latest on github.

For IzzyOnDroid repo add:

Isn’t there a more recent version (“stable¹”) of the refurbished Galaxy S7 Edge with /e/ OS ROM pre-installed from 12/2019? “The source code repository is the same.²” as e-0.7-n-20191225-(“dev³”)-hero2lte?

¹the stable version code base is the same as the dev release only with a further layer of testing to ensure all the apps on it are working.

²The source code repository is the same. Only difference is that the level of testing is more on the release builds. One level more than the dev builds.

³/e/ ROM latest dev build downloads

Thanks! The phone was only proposing 2019110830013 as the most recent update.
I guess I need to wait a bit for new ones.

Thanks! I’ve installed it. It crashes but after restarting the phone it was little better: I’ve managed to open the app and display the welcome notes. But it still keeps crashing often and randomly when going through the menus.

Weird. I just downloaded Joplin from Apps Installer and installed and it is working normally on my device (not a samsung). Could be an OS / Device issue. Please add it as an issue here with logs generated after the crash.

Screenshot_20200102-061523_Joplin Screenshot_20200102-061542_Joplin Screenshot_20200102-061552_Joplin

My devices (Samsung Galaxy S6 Edge und LG G3) behave identically and work normally with Joblin v1.0312 from /e/ APPS Shop.

Since @Manoj’s Xiaomi Mi A1 works just as well, it will be a device-specific /e/ OS ROM issue. The Galaxy S7 / S7 Edge has, according to the experiences of users from this forum, often bugs that other devices do not have.

Hi all,
Well, I was looking for some entry on the forum for this specific problem with Joplin. There it is…

So this is a +1 for Joplin crashing at startup (in my case after 1 or 2 seconds during which things seem to be working). I do have a Samsung s7, with a recent (ota) update of the system running…

Sad to read this is not a first with this very model.


I’m still using Joplin from IzzyOnDroid Repo on F-droid and gets updates and still yet to experience any crash. My advice would be to install from f-droid repo ive mentioned above/previous not /e/appstore

As I am experiencing the same problem, have opened an issue on gitlab for this.

I had thé same problèmes, so i installéd it from upkpure : it works but there is a problème about sync ( sée jp ).
I sync with dropbox: nom problèmes on desktop, only with m’y /e/ phone.