Linux+ADB: error: no devices/emulators found

Hi, Linux Mint 20.1 to Moto G7 Plus (Bootloader unblocked) and using abd trying to install Recovery before /e/

fastboot finds the device and displays it OK
[c]adb reboot bootloader[/c] shows “starting now at tcp:xxxx”
then “error: no devices/emulators found” and adding “sudo” to the start makes no difference.

How can I get past this?

We have no windows PCs.

Thanks, looking forward to getting /e/ installed as not impressed with LOS on it.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

In that case you don’t need adb reboot bootloader.

If the phone is already in fastboot mode and fastboot devices sees the phone you can continue with whatever is the next step.
As you said the bootloader is already unlocked (i.e. you successfully did the fastboot oem get_unlock_data step), I guess the next thing is to temporarily boot recovery, so it would be step 4 of the “Temporarily Booting a custom recovery using fastboot” on

1 Like

ADB doesn’t work in Fastboot Mode, only the fastboot command does.
Every time a guide wants you to execute an adb command, the guide assumes that Android is booted (with enabled debugging, ADB = Android Debug Bridge), or a recovery with ADB support.

Edit: adb sideload is an exception to this, and adb devices works with the phone recovery in ADB Sideload mode, too.

Thanks, but the Mandatory “copy slots” requires an ADB command.

How do I do that with only TWRP installed?

TWRP is a recovery with limited ADB support.
But the command in the guide is adb sideload, which is special in the sense that almost every recovery can do that much (I edited my earlier post accordingly), it just differs how to enable the ADB Sideload mode. In TWRP it’s done with Advanced - ADB Sideload.

If this doesn’t work for some reason, you could also transfer the ZIP file to the phone and install it from TWRP’s main menu with Install.

Thanks again, I was just about to use the recovery I downloaded from the /e/ Download page. I also downloaded TWRP v3.4, bth zip and img files, but I think the TWRP installation is different.

Is the /e/ download recovery a modified TWRP?

I am used to TWRP 3.2 on my old phone so would like to stay with that format and am OK with the /e/ version if it is based on TWRP.

It’s not a modified TWRP.
I think it’s a modified LineageOS recovery, since /e/ is based on LineageOS.

Which reminds me …

Whether /e/ would make a difference heavily depends on which aspect(s) of LineageOS you were not impressed with :wink: .

:slight_smile: Got it on the LOS. Mostly the support. This forum seems more active so thought I’d give /e/ a try.

Anyway, I installed the download version and then rebooted to it. Clicked down to the “Advanced” then “Start ADB” and got this.

adb: sideload connection failed: closed

Hmmm … I don’t use the /e/ recovery, and I don’t have your device.

ADB Sideload needs to be started in the recovery first. I guess there should be some message on the phone that Sideload was started or that the phone would wait for file transfer now or something like this.

Then adb devices on the computer should report the serial number along with “sideload” to confirm the recovery really is in ADB Sideload mode.

Then execute the adb sideload command.

As said … TWRP’s Install does the same job, but it needs the ZIP file somewhere on the phone, either in Internal Storage or on an external SD card.

Thank you, I installed TWRP and used the Sideload within Advanced. So far so good. :slight_smile:

More ina few minutes I guess.

10% and counting up about every 2-seconds.
p.s. I had bricked the G7 a few days back then spent another day and half un-bricking. Now that I know how to do that I can be reckless. :wink:

Wooohooo /e/ is running fine.

Gotta hit the wiki to get rid of stuff on the Lock Screen. I seem to have pushed 2-icons on to the one button and can’t get them to split again.

Not quite as intuitive as I expected, but will read up on it.

Thanks for the help and guidance getting installed.

1 Like

I had the same error message with a Samsung S8, solved with

adb kill-server
adb start-server

Your device should then appear when running

adb devices -l

Hope that helps

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.