[LIST] Banking Apps on /e/OS

Hello,
I am successfully using the following banking apps on my Fairphone 4 with /e/OS:

  • App: SEB (se.seb.privatkund); Country: Sweden; Bank: SEB; Comment: requires BankID for login
  • App: meineSmartId (at.hypovbg.smartid); Country: Austria; Bank: Hypobank Vorarlberg; Comment: used to login into online banking. Had to be installed via Aurora Store as it was not available.

Currently using the following finance apps in India with no issues.

  • Paytm
  • Cred
  • IDFC First Bank
  • PayZapp
  • HDFC Bank

I am on Redmi Note 5 Pro

I went to LOS+microG because I was experiencing installation problems with a new phone (Sake)
At that time, the app Payconique (Bancontact) and also Itsme (Belgium EID) worked surprisingly.

Since yesterday I am back on /e/ today v1.1 but Payconique refuses to start due to USB debugging or rooted phone :frowning_face:
App Itsme works
App Argenta works

I have an FP4 with /e/os 1.1 (same thing previously with 1.0) with unlocked bootloader and magisk installed (zygisk and the whole shebang).

This has worked nicely for my regular don’t-like-root apps (Vipps, NFC Nice Ticket, other banking apps), but has failed with BankID (no.vipps.bankid). I’ve tried with enforcing DenyList in Magisk and with Shamiko (or whatever it’s called), but a recent search led me to try IceBox, where I freeze Magisk (it’s also hidden, so running under another name), and now BankID actually works too!

It’s obviously far more hoops than I’d like to jump through (also means I have to fix magisk every upgrade, since the patched boot thing is overwritten), but at least it works.

Tried to remove Shamiko from the equation, and that works as well. Most my apps work with just the magisk DenyList, but BankID also requires the IceBox trick.

The bastard also requires me to change to a recognized keyboard! I use anysoftkeyboard, and I’m happy there. Think I need to talk to the app maintainers.

I found a solution on XDA (phone must be rooted)

I think this projekt has potential

Paypal works
Itsme works
Bank app Arganta works

:slight_smile:

1 Like

Annoyingly, Vipps has stopped working for me. After a recent update, they now discover both Magisk, Zygisk, Shamiko and all the other various root-hide methods I have. Magisk Delta didn’t fix it either.

Hello! I’m interested in reporting which banking apps work fine with /e/ OS.

However, I’d like to know if this has to strictly include banking apps or if apps for prepaid accounts can also be included. Here in Chile, there’s a great lot of apps that are for signing up with and managing prepaid accounts with virtual (and sometimes physical) prepaid cards, too.

1 Like

As it have been said, you have to reflash the “patched-boot.img” after every /e/update…

1 Like

Update: still Swish app, and /e/OS 1.1, Swish displays but do not read the QR.
I found a workaround: In the scanning interface there is a button to use a picture instead.
So you can take a picture of the swish QR code using a camera app, then in Swish select that picture, and it works.

I contacted Swish and first they say they do not support altered Andrioids, but after i told them other banking apps and nation supported ID apps works flawlessly they said they should convey it higher internally.

2 Likes

For the many apps of similar use in Chile, I suggest creating a separate thread for that, with a table, and then one entry in the table above in this thread to point at it :slight_smile:

2 Likes

Alright! I’ll keep it in mind!

Although I believe I probably need to have stayed some further time here in this forum to do that, since my trust level is still low.

For the Netherlands, the SNSbank and ABNamro banking apps work as well.

Yeah, have done that. Magisk does not complain, and other apps work, but Vipps has upped their game.

Monzo works well too.

Germany, ING DiBa, ING Banking

On a FP3 running v1.2 q stable installed this morning, the Payconiq app is now properly starting, without any help of Magisk or rooting. I added this info in the wiki.

In Sweden, these apps work great on my /e/ devices:
App: Länsförsäkringar
Bank: Länsförsäkringar Bank

App: Sparbanken (in english: Savings Bank Private)
Bank: Sparbanken

These also need BankID for login.

Edit: Clarification

1 Like

Banking apps from UK’s Co-operative Bank are working fine in /e/OS R build 1.2 on Sony Xperia Z3 Compact. They do not work in /e/OS Q or earlier builds. They include Co-operative Bank Personal and Business apps, and Smile banking app.

Table in first post updated (and put into alphabetical order by country, just because… :slight_smile: )

Goodmorning,
I’m in France and i’m using ‘‘MACIF’’ app for my assurance and my bank account. It works fine. :slight_smile:

1 Like