Location doesn't work at all, help

Hi, I just flashed my Fairphone 4 with /e/ today and the location isn’t working on any app or website.

When I use the default map app (magic earth) no location marker appears and when I try to share my location I get an error message: “No GPS position”.

Advanced privacy is disabled, and just in case, I modified its location setting to “Use my real location” and network settings to “Use my real IP address”.

All the apps and web browsers that I have tried location on had location permission.

I searched all settings and tinkered a bit with everything, rebooted my phone many times and still don’t find a solution, does someone know how I can fix this ?

EDIT: If I activate advanced privacy and use the “Use a random plausible location” setting it actually finds the generated location…

1 Like

No idea from what causes this issue.

How did you flash your device? Stable or dev version?

Did you “adb sideload” the whole .zip file from recovery (dev version only) or did you unzip and flash all the .zip content (line by line?)

Maybe a missing line that could miss the GPS firmware?

I flashed the stable version (/e/ image ROM download => MG-e-1.0-r-20220526188860-stable-FP4.zip) and did flash each image line by line, these are all the commands I used (retrieved from zsh command history) :

sudo fastboot flash bluetooth_a bluetooth.img
sudo fastboot flash bluetooth_b bluetooth.img
sudo fastboot flash devcfg_a devcfg.img
sudo fastboot flash devcfg_b devcfg.img
sudo fastboot flash dsp_a dsp.img
sudo fastboot flash dsp_b dsp.img
sudo fastboot flash modem_a modem.img
sudo fastboot flash modem_b modem.img
sudo fastboot flash xbl_a xbl.img
sudo fastboot flash xbl_b xbl.img
sudo fastboot flash tz_a tz.img
sudo fastboot flash tz_b tz.img
sudo fastboot flash hyp_a hyp.img
sudo fastboot flash hyp_b hyp.img
sudo fastboot flash keymaster_a keymaster.img
sudo fastboot flash keymaster_b keymaster.img
sudo fastboot flash abl_a abl.img
sudo fastboot flash abl_b abl.img
sudo fastboot flash boot_a boot.img
sudo fastboot flash boot_b boot.img
sudo fastboot flash recovery_a recovery.img
sudo fastboot flash recovery_b recovery.img
sudo fastboot flash dtbo_a dtbo.img
sudo fastboot flash dtbo_b dtbo.img
sudo fastboot flash vbmeta_system_a vbmeta_system.img
sudo fastboot flash vbmeta_system_b vbmeta_system.img
sudo fastboot flash vbmeta_a vbmeta.img
sudo fastboot flash vbmeta_b vbmeta.img
sudo fastboot flash super super.img
sudo fastboot flash aop_a aop.img
sudo fastboot flash aop_b aop.img
sudo fastboot flash featenabler_a featenabler.img
sudo fastboot flash featenabler_b featenabler.img
sudo fastboot flash imagefv_a imagefv.img
sudo fastboot flash imagefv_b imagefv.img
sudo fastboot flash multiimgoem_a multiimgoem.img
sudo fastboot flash multiimgoem_b multiimgoem.img
sudo fastboot flash qupfw_a qupfw.img
sudo fastboot flash qupfw_b qupfw.img
sudo fastboot flash uefisecapp_a uefisecapp.img
sudo fastboot flash uefisecapp_b uefisecapp.img
sudo fastboot flash xbl_config_a xbl_config.img
sudo fastboot flash xbl_config_b xbl_config.img
sudo fastboot flash core_nhlos_a core_nhlos.img
sudo fastboot flash core_nhlos_b core_nhlos.img
sudo fastboot erase userdata
sudo fastboot erase metadata
sudo fastboot --set-active=a

I don’t think I’m missing any & bootloader has been relocked…

Sequence looks fine… (Are you sure sudo was required?)
Did you well unzip the folder before flashing your device?

However, this guide is from an old version, did you check that all those img in command lines are exactly the same in the zip folder?

Did you activate “location” in the settings?

Did you check if GPS worked in Fairphone OS before flashing /e/OS? (could be a hardware issue?)

Sometimes, first GPS fix might take up to 15 min in an outdoor postition (keep screen on)

Did you update fairphone OS before flasing /e/? Could it be an outdated firmware?

These are just some of the avenues to be explored to solve this problem.

Did you well unzip the folder before flashing your device?

Yes.

However, this guide is from an old version, did you check that all those img in command lines are exactly the same in the zip folder?

I didn’t before but I did now and they are the same.

Did you check if GPS worked in Fairphone OS before flashing /e/OS? (could be a hardware issue?)

No, it could be possible this is a hardware issue.

Did you update fairphone OS before flasing /e/? Could it be an outdated firmware?

I had pending updates that I did not do because I was going to flash it and thought it wouldn’t matter, however I did activate wifi and I think they might have completed automatically.

Another possible reason is that I just activated my SIM card today, maybe it needs a little more time to have GPS (I have 4G already though…) ?

I don’t think GPS issue can be related to Sim card. But you can try to remove your sim card and try again (if you have WiFi).

For example, Xiami Redmi devices firmware are not released by custom ROMs like /e/OS, so flashing new MI firmware (or update stock system before flashing a custom ROM) are very usefull. I don’t know if it could be the same on Fairphones…

Try also to completely remove the battery for 20 minutes, reboot your device and try again.

You can download those 2 apps:

“GPSTest” and “GPS Status”.

Both will monitor your GPS connection and give you logs and stuffs like that, So maybe then other people more skilled than me can help you.

I still suggest to turn magic earth on and leave it 15 minutes outdoor to see if it can fix the position.

I just flashed Calyx OS and the location works on it.

Weird indeed… Would you try to re-flash /e/ and test again?

I tried and broke my phone, locked bootloader unable to boot :frowning:

Before locking and breaking my phone (fastboot flashing lock) I did test it and I had still no location though.
Don’t know why the phone broke, I had OEM unlocked…

Is OEM still unlocked? Resp. which output gives fastboot flashing get_unlock_ability? Is it “1”? If yes, you should be able to unlock the device again.

2 Likes

Indeed, you normally should be able to:

fastboot flashing unlock

Before to flashing anything.

Note that V1.0 seems to generate issues with GPS on some devices. Maybe wait for 1.1 (28/06/22)

I have the same issue since the latest upgrade. Didn’t have this problem before upgrading, was on previous /e/ version before and used in-OS automatic update.

Location fixed at Trinity College in Oxford, no way to change it. Tried restart, turn on off, pop sim cards, always same location - also in maps.

On OnePlus 5

Thanks!


Update:

And now I changed the fake location setting… ignore the above :slight_smile:

For me this issue was simply related to the new Advanced Privacy settings in /e/ 1.0

It seems by default location settings are set to use a fixed “random plausible place” which breaks apps that use GPS and this has caused people no end of headaches.

I stumbled across the fix as documented here:

TLDR: in Settings → Advanced Privacy → Manage my location: Change those settings to “Use my real location”

Sometimes one needs to clear the cache of applications that use GPS after having turned off advanced privacy / set to real location.