Lost my OS during factory reset

How do I re-install the OS? I did a factory reset, all was well, but I did it again and now have no OS

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

what is your device ?

1 Like

Samsung Galaxy S9 Duo

So you have TWRP installed, no problem
Boot on it, recovery mode (volume up + home/bixby + power)
From the PC :
paste latest /e/.ZIP /e/ image ROM download in the phone memory (internal or SD)
On the phone
Tap install and navigate to the zip

Thanks, I only get as far as the re-boot keys and it won’t list the storage or anything. I can see them, click them and then they don’t open on the main menu. I screwed something up somewhere. So pissed. I actually had my phone making calls for the first time in over a month, and I promptly screwed it up.

If you have recovery-e instead if TWRP,
You can choose “apply update from SDcard”

My phone was only working for texts, still had service and a signal, but no calls in or out. So I did factory reset after backing up the photos etc…and then re booted or recovered (I don’t remember) , tried calling and it was working! So I did another reset to get back to the setup menu (stupid I know), and now my phone won’t come back or let me choose anything. It wants a password after doing the bixby restart. There is nothing in the menu to click on. I can see a list I see folders but it doesn’t move to the selection mode. Can’t open anything up on the PC either. It’s a little complicated for me. No easy way to plug into PC and just say “make it so”? I can’t get past the PASSWORD stage. I don’t know the password. I think that’s the secret.

Please share a photo…

Please can we rule in or rule out one possibility?

Was this an e.solutions shop device, where you eventually waited for the OTA Upgrade and you are now in the same position as these posts #ota-upgrade ? In which case you are just facing an “unexpected to you” encryption issue.

Edit, re reading, if your OS is “gone” this is not possible ! Perhaps you could also try to give us

Settings > About phone > Android version > /e/ version

In certain devices/versions long click on /e/ version will copy to clipboard.

In this case when you meet Enter Password (as in your final image) please press cancel to pass “default password”. This action will cause you lose your data. A backup may still be possible before Decrypt Data, but maybe not trivial.

Edit, just to get the terminology right; all your images are of the phone in Recovery mode, that is TWRP aka Team Win. TWRP has significant limitations with encryption on Android 10.

/sdcard is internal storage
/external_sd is external storage

Yes, it is an e.foundation phone that stopped working with calls, texting still worked and I could still use the internet without wifi, just my phone service. But my service said they upgraded to VoLTE and that’s why it didn’t work. That didn’t make sense since everything else still worked right.

I did the factory reset, and it was working but the second time it went back to not taking or making calls so I did it again and that’s when everything went to crap. I bypass the pass code but seems like it is read only then because nothing will happen no matter what I click on.

It is a Samsung S9 Duo. That short time it was working gave me hope I could keep it instead of return it and ordering a new one. What would you do? Order a new model and move on? I was ready to order the Murena Teracube.

As you are speaking about VoLTE, i presume you are in USA, Terracube is a good choice, because s9 will not fully working in USA

Okay, thank you for your help. I’m moving on :smiley:

So that is of course about right, because it is encrypted ! (TWRP is also not quite competent for the situation, but it will work in the correct sequence ! )

Should you wish to recover the phone

  • (and I quite understand how infuriating the Samsung / USA situation is)
  • you have backed up, so you are not worried about loosing data,
  • so (even if the tutorial at first sight, seems not exactly your subject)

this is a well illustrated tutorial on how to “fresh start” and hopefully resolve the encryption issue.