Magic earth maps broken

I just received my galaxy S7, but the pre-installed Maps app is not working. I get the error message :

“This app version is not compatible with the new maps available. Install the latest app version to use the new online and offline maps.”

But it seems to me that the version is the latest. What should I do?



I have the same issue here on my S7 I got refurbished from /e/.
Didn’t find yet how to solve that.

Unable to replicate this behavior on a test build of Pie. Please can you raise this issue on Gitlab with logs generated after your click on Maps. Please share details regarding OS and build.

1 Like

Same issue with my S7 from /e/.

I receive a samsung s7 with maps not working with no error message. I solve the problem by installing Aurora market and making an update with aurora. Since, maps is working.

I hope this solve your issue.

@GrappinBrutal : Great! This solved my problem. Thanks!


Hi Manoj,

Thank you for the details, issue reported here :

1 Like

Same problem here on Galaxy S7+ from /e/ store.

I got this error message about installed maps and cannot update them. The message appeared only twice: one week after I installed the local maps, and just after my system update.

I also have this issue, on a custom eOS pie build.

Installed Magic earth is version Magic earth details in Apps store application show me that latest version is but only suggest me to open currently installed Magic earth, as if latest version was installed on my system. I have no apps listed in Apps “updates” tab.

I rebuilt my custom eOS today and re-installed it. My phone is now running /e/ 0.11-p instead of 0.10-p. Interestingly, Magic Earth is no more pre-installed, so Apps suggest me to install the up-to-date version, and it works.

Maybe you build with this bug:

Hi everybody,

I read various posts on my issue, but could not really find a satisfying solution, so I open a new thread and hope someone can help:

I purchased a FP 3 with /e/ preinstalled a couple of weeks ago, but I realized I can’t use Magic Earth maps app. I always receive this notification:

“This app version is not compatible with the latest maps. Please install the latest app version to make sure that you can use the latest maps.”

I tried to update Magic Earth via Aurora store, but nothing happened when I clicked on the “Aktulisieren” button.

Than I tried another recommendation: updating /e/OS, but there are different updates offered to download, and I did not know whether I have to download only the most recent one or both or none? So far I opted for “none” since I did not want to mess anything up…

Actually, I am not used to update the OS manually, With my former FP 2 and the regular Android, I would receive a notification by Fairphone updater whenever I was supposed to install an update. How does this work with /e/?

Can anybody help me with my questions?

Thanks in advance and have a nice day!


It’s the same with /e/, you should get a notification when to update. You could search for “system update” in the settings and trigger a manual search for updates. But IIRC the next update will come in one or two weeks.


Hi Ingo_FP_Angel,

thanks for you reply.
Do you think a manual system update would help to solve Magic Earth issue?

And if I try the system update do I have to install all updates available vor just the most recent one?

Best regards,


Actually I don’t know. Seems like this happened earlier, too: Magic earth maps broken

Installing the most recent one is sufficient

1 Like

I read this thread but I can’t understand what the conclusion is.

When I bought my Fairphone 3 I installed /e/ and everything seemed to work just fine… but gradually things started failing and I doubt it’s the hardware.

Now I go to app store and try to reinstall the Magic Earth app but the only option it gives is “Open”. Opening it gives me this.


Also I notice the GPS icon has gone missing from settings.
Does anyone know what I need to do to use “the new maps”?


Magic earth is a system app. So you can’t update it through an app store.
It’s updated through system (OS) updates.

You can download the newest version of Magic Earth application from i.e.

And then install downloaded APK file (if needed allow unknown source to be able to install it) and then it should update the current version of Magic Earth application.
I checked it on Nougat, Pie and Q version of /e/OS (the latest releases) and works fine for me.


I don’t understand the concepts, however I followed the instructions by cooky below and it seemsto have worked this time. I gather the GPS icon is a red herring as it simply doesn’t display it but turns it on when it needs it.

Thank you cooky… I tried it and magically it all started working. I have no idea what I did wrong before, but I’m happy now :smiley: