Mi 10T Pro Issues /e/ 0.18 R (dev)

Hello Community,

I´m using this device for about a week now with /e/ version 0.18-r-20210901133005-dev-apollon.
Overall it seems to work stable, but actually there are two issues.

First one affects the Home Screen on the far left side (where Widgets are placed, f.e.). This Screen is completely blank and i have no possibility to edit its settings. There are no error messages at all.

Second one affects notifications of some messenger apps (Threema, Telegram, Signal). Although all notification settings are set active i only sometimes get an optical and acoustical information when receiving a message. Most of the time i have to open the apps manually to see new messages.

After each reboot both issues are not present for a while (i cannot determinate how long it takes or what action causes these issues to show up).

Is there anything i can do to help to investigate? Tried to sign up in /e/ Gitlab, but cannot: “Email domain is not authorized for sign-up.”

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello,

Did you upgrade to the latest stable firmware before installing /e/ R ?

As for /e/ Gitlab, registration may be restricted, did you try with a @e.email address ?

1 Like

Recently we had an issue with dummy accounts being created on /e/ Gitlab to prevent this only select domains are whitelisted. You can send a mail to support@e.email if you want to get your domain recognized / ID created Sorry for the inconvenience .

1 Like

Hello smu44,

i did so…but tbh i updateted Android at 09/03/21 as i received the device. At this point i started the bootloader unlocking procedure and had to wait for about 7 days → 09/10/21. I haven´t checked for MIUI updates then and installed /e/ right after this 7 days were over, so it seems i had NOT the latest MIUI firmware installed. That means i had MIUI from 08/25/21 and /e/ from 09/01/21.

Could this explain the issues? Are there recommendations for this specific case?

Thanks for the tip with Gitlab, i´ll send an mail as recommended by @Manoj.

It’s not only about date, but also about Android version of MIUI (which bring appropriate firmware).
I can’t guarantee that the latest firmware will solve your problem, but it definitively worth a try.

Please take care to download firmware only, european or global depending of your country.
Flashing is simple : once the file on your phone, you can use the Install function within TWRP (you will find your Downloads folder at /sdcard/Downloads or /data/user/0/Downloads).

1 Like

Now things are getting a little bit clearer. The xiaomi-link you posted shows that the firmware i lastly installed actually is the latest version for europe. The newer entry has the same version number except the country code (V12.5.5.0.RJD**XM). Sry for the confusion, shouldn´t write here while at work. ^^

So at first (based upon those new informations) i prefer to not reinstall/flash the phone. I recently use it on a daily basis as a replacement for the Redmi 8T and would like to save the extra work if it is unlikely that it´ll solve the issues.

Maybe there are apollon users who can confirm or falsify the issues i got.

I agree, this would be useless.

Unfortunately, I have no other clue about your issues :frowning:

Hi @El-Barto I think that this may be to do with some “unresolved magic” in flashing Android 11, R, custom ROMs. I do not know this phone, but to help compare your experience with other devices it might be good to know if you have a Super partition and/or if this is a “two slot” device.

If this is unknown, might you consider installing Treble Info by Hackintosh Five

Absolutely no problem @smu44 , thank you very much for your assistance.

Hello @aibd, i installed Treble Info as recommended by you and it shows that this device uses dynamic partitions (Super-partition). I don´t know what ´two slot´ device regarding the topic exactly means, but if we´re talking about SIM-slots - it has two (but unfortunately no sd-slot).

Only unsupported feature regarding Treble Info is ´seamless updates´ and in relation to the description i understand it that way, that (all) non-GSI installed firmware doesn´t support seamless updates and it isn´t a device based missing feature (but surely i could be wrong).

I am sorry I used the expression “twin slot” so loosely. I was referring to the idea of A/B Partitions

So a device that does not support seamless updates does not have an A and a B partition.

This rules out the possibility that there was some “unresolved magic” (during installation) on the “other slot”. :slight_smile:

1 Like

This is a known issue on some devices and maybe you can add to the bug report when you get access to gitlab.

Something you could try is to check this setting:

Go to Settings and enter in search box: “Notification access”. Select Notification access from search result and see the status for Bliss Launcher. Is it set to “Allowed” or “Not allowed”?

Mainly it is for allowing notifications dots and on a couple of devices it has been delivered set to Not Allowed on first installing. It would be useful to see if you have this also although it actually might not help your problem much. Worth a try though.

2 Likes

Okay, got it. :grinning_face_with_smiling_eyes: Thanks for the link, now i understand that a little better and it´s a pity this feature is missing on this device.

@chrisrg Good to know, i´ll post that on gitlab.

The notification issu is solved, you were absolutely right. Bliss launcher was set (per default) to ´not allowed´ and after i changed that setting the messenger notifications are working as expected. Thanks a lot for your support.

2 Likes

It will be interesting to see if the notification issue is solved in the longer term for those apps you are using.

I’ve noticed another problem with this Notification access setting whereby it is not now possible to toggle off notification dots on app icons! Very confusing. I have created an issue report.

Indeed it is not solved overall. After a reboot to check for the widget screen issue i cleared storage of Bliss launcher - > widget screen works fine. As i started sorting my apps again i noticed that the widget screen was first ´half´ empty (only the upper half was visible) and after another swipe full empty again…and app notification wasn´t working again. That means, after reboot the permission for Bliss Launcher notification setting was set to “not allowed” again.

But the confusing thing is: I tried to reproduce this behaviour with more reboots…but it´s not reproducible.

I can confirm your additional issue regarding the notification dots too.I´ll add that to your report.

So after all it is not solved yet, but at least there are workarounds available.

Some apps need you to alter the Battery Optimisation setting so that they can run in the background for push notifications. Looks like Threema is one of these. Did it ask you to do this on installation?

Other apps may need google services via microg. I don’t know about Signal though.

Other apps use a notification to enable push, like Telegram Foss, and sort themselves out of the box. Which Telegram client do you have?

1 Like

Threema was set correct (no Optimisation) while Telegram FOSS and Signal wasn´t. I can´t remember i had set those options intentionally. I changed it no to ´no optimisation´ and are observing the behaviour now.

Telegram on my other device Redmi 8T is using some kind of background service (symbol in upper Tray-bar), on 10T Pro there is no such symbol - maybe this is the notification you mentioned above. Need to investigate, but this could unfortunately take some time. I am using Telegram FOSS v8.0.0.

Yes, it’s best to take your time! That’s the latest TelegramFoss you have and usually it sets up right first time with the “push” notification in the status bar.

Check TGFoss app info in the device settings: Settings>Apps and notifications>Telegram Foss>Notifications to see what’s toggled on or off there. Although I have to say on my device I currently have the Push Notification Service toggled off and I still get instant notifications!

Also in app info check Permissions. My set up has contacts and location denied, everything else allowed.

In the Telegram app settings > Notifications and sounds > scroll down to “Other” I have the Background Connection on as default.

If nothing helps, delete and install the app again to see if you get the status bar notification this time.

In Telegram every setting and permission you mentioned is active. I haven´t tried reinstallation yet but will try that this weekend.

Reinstallation seems to solve the problem with Telegram notification. Even the notification LED flashes now. :slight_smile:

Hey, good result!

Did you get any improvement with your other apps, by the way?

1 Like