Mi 10T Pro Issues /e/ 0.18 R (dev)

Yes absolutely, thanks to your help.

Signal and Threema also seem to work now. I think the battery optimisation settings were responsible in that case.

Interesting. Would you say the Mi 10T Pro is stable enough to be viable as a daily driver? As the Poco F3 has some serious problems which holds it back from supporting /e/OS atm. I am looking at similar alternatives.

Currently i am using it daily as my main smartphone and beside the issues posted here/on GitLab there are not much more noteworthy problems. From time to time it reboots itself sporadically, but this is very rare. In my opinion it´s a very good phone and /e/ works stable enough at this time.

1 Like

@El-Barto just a quick one is your phone the 5G version? I am about to buy one for /e/ but I am not able to find the models (from the /e. Device list corresponding to the model name) but I don’t want to make a mistake… Thanks

I buy there is one month - MI 10T 5G - Model M2007J3SY .

Yes, like @esiger said, but in my case it has the model code M2007J3SG (difference maybe the country code).

Thank you both ! So apart the small glitches (the ones from your post) globally you are satisfied and you have everything working great with /e/ ?

I am currently running /e/ on MI 8 which is all fine but better to cross check with your experience :slight_smile:

I´m totally happy with this device, it has much more power and resources than my recently used 8T Pro and i´m missing nothing. Ok, to be honest i would like to have a microsd-slot, but with 128 GB onboard it´s not that big thing at all.

But, after all, this is just my subjective opinion and your user experience may vary. :slight_smile:

Thanks @El-Barto !
Maybe 'y last question is about how /e/ Camera (OpemCamera) is managing the 4x cameras MI 10T Pro got ? Do you see it take full advantages from that or it does failback to “normal/classic” 1 camera used ?

I made screenshots for you from information site of the default camera app. As you can see in picture 1, the app recognizes 2 cameras, so i guess it cannot use its full resources. I don´t mind at all, because i´m using smartphone cameras generally only for quick snapshots.

Hint: “verfügbar” means available

Hi! I have the Mi 10T now (uses the same files for installation as the Pro) and have followed the instructions. The phone does not show up in the Unlock Tool and I have tried every tip on the Xiaomi Community forums and XDA Dev forums that I could find.

Any suggestions? :slight_smile: I am getting a bit desperate as my iPhone now only charges wirelessly and has several issues.


i´m guessing you are using the official Unlock Tool from Xiaomi.
At this point i do not know what kind of help or hints from Xiaomi forum or XDA devs you got and tried. So it´s a bit difficult to give you assistance.
My first thought was, if your device doesn´t show up in that tool - is your device recognized in your OS via USB?

1 Like

… and, did you have a dedicated SIM for your Xiaomi account and are you proficient at logging in and out of that account? As a double check for myself I added an avatar to my Xiamoi account (just as a personal double check against any chance of silly mistake).


Could you try with another computer and/or another USB cable ?
If you have the choice, prefer a USB2 port.

Thank you for all the replies!

The unit does not show up in the Unlock Tool, nor does it show up as an Android phone in Device Manager, but did show up when I used CMD and typed ADB units - but suddenly stopped showing up there too. I have tried on my desktop and laptop.

One question I have, which is not covered anywhere: do I have to log in with a Google account for the Xiaomi process to take effect, or can I just use F-Droid and Aurora?

Do I have to use the phone actively with a SIM while I wait, or can I simply plug it in when I want to install eOS? I have added info etc., so I can verify it is the right account :slight_smile:

I used this workflow:

  • Login in Xiaomi ID on your phone
  • Download the Mi Unlock app
  • Connect your device to PC

So you do need the Xiaomi account, but google are not involvrd.
The download is from “source” so F-Droid and Aurora not involved.
They expect you to use the phone “normally”. From what I read I felt it necessary to get a new SIM card and dedicate it to the job (possibly over the top?). Assuming they want to harvest a certain amount of info in that time (and no one will have the full time job of monitoring your behaviour) perhaps they would aim to search for you a certain number of times and expect more hits than fails? Also specified that you should be online on mobile data, rather than just internet.

I think that they will want to eliminate the possibility that you have a sales operation of some sort, buying in their phones, adjusting them in some way and reselling them.

When the time was up I had a positive and definite message that the phone was “available to unlock” (not sure the exact wording, but explicit) - so that would be a guide to whether you passed that stage.

That is the exact flow I used, but my phone was not detected. I have since followed some advices and ran a fabric reset and logged in with the account again, but still the same issue of my unit not being recognised </3

I really don’t know what to do now.

Tell me where your phone was not detected? Did you get the “success” message from Xiaomi?

It was not detected in the Mi Unlock Tool or Device Manager.

I did get the success message at first, but no overview of time etc. remaining, and it suddenly did not show up. Then after a few days, I got a message that it failed for some reason. That is when I ran a factory reset and tried again, but the unit still did not show up. I did use the phone, just not with a SIM until I was going to install etc.

This is where we see “Use your phone actively during the waiting period.” https://c.mi.com/thread-2262302-1-0.html, anecdotally the SIM is required. When I search I see conflicting views, but it is older posts that indicate Xiaomi is relaxed about it.