microSD formatting fails & LiveDisplay

I received my 2e preinstalled with /e/ 0.22 yesterday. Although it works mostly fine, i encountered two glitches:

  1. microSD card won’t work
    I tried two different microSD cards, but both fail to be formatted. After inserting the microSD the system tells me that it needs to format the card (which is fine for me). After selecting the option to expand the phone storage the formating starts but fails every time at 40% with the following toast appearing:

  2. LiveDisplay won’t work at all
    In Settings → Display → LiveDisplay i’m presented 4 options on how it should behave (automatic, off, day, night). But whatever i choose, after leaving the “LiveDisplay” section and re-entering it, the setting is back to off.

Anyone having similar issues or ideas what can be done? Especially the sdcard thing is important for me.

I wanted to report this issue at https://gitlab.e.foundation, but the gitlab instance won’t accept my mail adress for whatever reason. :frowning:


the microSD partitions look like this afterwards:

Sometimes the first 16 MiB partition is formatted as exfat, sometimes not. The main partition is always unformatted.

A simple technical parameter re sd card: the max size of an sd card for the Teracube2e is 128GB. I got this from their support after asking about it (also suggested putting this on their tech specs page which they did not do it seems). What is the size of the sd card you are trying to format?

Thanks for your hint.

I tried with 16 GB (Transcend) and 64 GB (Kingston) cards - both work fine in other devices.

Atleast my sdcard issue has found a workaround: Sdcard issue - internal storage errors - external storage always on notifications - #3 by marcdw

After some more search in the forums it seems that the LiveDisplay issue is a long standing one (atleast for Fairphone users).

Ok. I have a Teracube2e from 2021 originally from the company and put /e/ on it myself manually
(not a trivial pursuit - the “easyinstaller” does does not work (as of January this year) and there is a “bug” in the sequence of commands in the manual installation instructions (documented here on this forum)).
I was able to format a 128GB sd card with no problems either as a portable storage or as an extension of the internal storage. I have 0.22 /e/ on it, the card was formatted with 0.21. It works fine.
Ok, I see you found a workaround - good luck.

Thats why i opted for the 2e with /e/ preinstalled. I didn’t want to mess around with a manual installation. Installing Android on a device seems overly complicated to me - maybe it is by intent to make people stick with the Stock ROMs. :wink:

LOL, it seems that way. During my flash-a-holic days I’d flash ROMs constantly. With newer devices we got system-as-root, A/B slots, and what not making things not so straightforward. And with TWRP falling out of favor…

There’s a LineageOS for the 2e 2022 batch but I don’t feel like messing with it so it goes unused until /e/ is ready for it.