Murena Teracube 2e -- microSD card not formatting

I cannot get microSD cards to format. I have tried two new microSD cards. For both cards, when I am presented with “How will you use this SD card?”, I select “Phone storage” and not “Portable storage”. After I select phone storage, the progress bar gets to 40% and then I get the following error message:

Attempt to invoke virtual method ‘java.lang.String’ on a null object reference

The first card I tried was:
SanDisk 128GB Extreme microSDXC UHS-I Memory Card with Adapter - Up to 160MB/s, C10, U3, V30, 4K, A2, Micro SD - SDSQXA1-128G-GN6MA

The second card I tried was:
SanDisk 128GB Ultra microSDXC UHS-I Memory Card with Adapter - 120MB/s, C10, U1, Full HD, A1, Micro SD Card - SDSQUA4-128G-GN6MA

I found a similar post here (microSD formatting fails & LiveDisplay), but I cannot tell if there is a real fix. If using the card only as “Portable storage” is the only option, it seems the message screen offering “Phone storage” is misleading/confusing.

I hope I’m making a simple mistake someone could point out and/or point to a model number of a card people know works. I am using emerald build 20220406.134740, FWIW. Thanks!

I’ve experienced the same ‘Phone Storage’ error messages with a new Teracube 2e when attempting to format a fresh SDmicro card.

Should I stumble across a solution, will post it here.

This does not sound like correct behavoiur but it is only portable storage which should be available now.

Internal storage used to be possible on /e/ but was problematic.

As I understood it the option was completely removed.

If you are seeing a choice which does not exist it sounds like a problem somewhere. It seems to be reported and in progress here: