Mipad 4 building

“propretary” -> “proprietary” in xml manifest :wink:

1 Like

I have read often this asking for user name and password. But I can’t remember if there was a solution. I have had it also sometimes and I have added my personal github account creditentials. But I think it was also working if you only hit ‘enter’,

EDIT: As I have written some post above, I don’t think that the sources will work. They are not as lineage needed. No
‘lineage_clover.mk’ NO ‘lineage_dependencies’ and so on.

In mk_clover.mk it’s the wrong PRODUCT_NAME.

The complete source must overwork. Otherwise the build will fail

I just launched a test build in my VM, I’ll post the result tomorrow …

1 Like

Android vm ? …

Thank you very much!

Nope, but I’d love to !
Ubuntu in VMware Workstation VM, on a middle-class blade server : Retour d'expérience : mon premier build UNOFFICIAL pour Xiaomi MiMix2 (Oreo et Pie)
Ok, that’s off-topic :wink:

BTW there was another typo in roomservice.xml : relaunched with
instead of
LineageOS/android_packages_devicesettings …


>> [Tue Jan 28 20:52:59 CET 2020] Starting build for clover, v1-pie branch
including vendor/lineage/vendorsetup.sh
device/xiaomi/clover/device.mk:417: error: _nic.PRODUCTS.[[device/xiaomi/clover/lineage_clover.mk]]: "vendor/xiaomi/clover/clover-vendor.mk" does not exist.
20:53:03 dumpvars failed with: exit status 1
Device clover not found. Attempting to retrieve device repository from LineageOS Github (http://github.com/LineageOS).
Repository for clover not found in the LineageOS Github repository list. If this is in error, you may need to manually add it to your local_manifests/roomservice.xml.
device/xiaomi/clover/device.mk:417: error: _nic.PRODUCTS.[[device/xiaomi/clover/lineage_clover.mk]]: "vendor/xiaomi/clover/clover-vendor.mk" does not exist.
20:53:04 dumpvars failed with: exit status 1
device/xiaomi/clover/device.mk:417: error: _nic.PRODUCTS.[[device/xiaomi/clover/lineage_clover.mk]]: "vendor/xiaomi/clover/clover-vendor.mk" does not exist.
20:53:04 dumpvars failed with: exit status 1

** Don't have a product spec for: 'lineage_clover'
** Do you have the right repo manifest?

No such item in brunch menu. Try 'breakfast'
>> [Tue Jan 28 20:53:04 CET 2020] Failed build for clover
>> [Tue Jan 28 20:53:04 CET 2020] Finishing build for clover
>> [Tue Jan 28 20:53:04 CET 2020] Cleaning source dir for device clover
20:53:05 Entire build directory removed.

ESC[0;32m#### build completed successfully (1 seconds) ####ESC[00m


<?xml version="1.0" encoding="UTF-8"?>
        <project name="crites3/android_device_xiaomi_clover-oss" path="device/xiaomi/clover" remote="github"/>
        <project name="crites3/android_kernel_xiaomi_clover" path="kernel/xiaomi/clover" remote="github"/>
        <project name="crites3/proprietary_vendor_xiaomi_clover" path="vendor/xiaomi/clover" remote="github"/>
        <project name="LineageOS/android_packages_resources_devicesettings" path="packages/resources/devicesettings" remote="github"/>

Seems something is still missing !
Once again you were right harvey186.

1 Like

Yes, I’m sorry for you guys :cry:

Short update/Inforamtion:
I have just build a new rom (magma) which is also based on lineage. I have working LOS17 sources for my device. But still I have needed around 40 Hours and around 60 tries to get a build finished.

Hi @eggzenbeanz and @donut3 pls have a look here: [UNOFFICIAL BUILD] Pie test ROM for Mi Pad4 /Pad4 Plus (clover)
a little eastern egg for you

WOW!! Thanks @harvey186. Downloading now

Hope that it will work. Pls let me know

I get treble error when installing. Format data, wiped system and cache. Latest official twrp

Oh, shit, have seen something about treble in the kernel sources.
Tja, was a try which fails :cry: so I remove the post.

Is the clover device a treble device ? Which OS are you running on it ?

Thanks for trying @harvey186

It’s a Clover device with LTE

Originally running Los 17.1 beta from xda device forum

I have tried to build without treble in 2 different ways. coud try if one of it is booting ? If not. pls share error.

version 1 https://ecloud.global/s/8bYBAedZdJoPFBa

version 2 https://ecloud.global/s/zsHGxL5JZ9jQj7X

Both versions install with success in twrp. Both versions boot fine, but seemingly after the e logo they reboot to recovery

Ok, have you format data ? Not only wipe

and could you try flashing this AFTER flashuing eOS ? https://ecloud.global/s/MQpQtP2yCftLowD

Yes format data.

Tried as policy as permissive and it boots, but back to twrp on v1 and v2 zips

Enforcing doesn’t boot at all

Thanks for trying man!!