Mipad 4 building

Is the clover device a treble device ? Which OS are you running on it ?

Thanks for trying @harvey186

It’s a Clover device with LTE

Originally running Los 17.1 beta from xda device forum

I have tried to build without treble in 2 different ways. coud try if one of it is booting ? If not. pls share error.

version 1 https://ecloud.global/s/8bYBAedZdJoPFBa

version 2 https://ecloud.global/s/zsHGxL5JZ9jQj7X

Both versions install with success in twrp. Both versions boot fine, but seemingly after the e logo they reboot to recovery

Ok, have you format data ? Not only wipe

and could you try flashing this AFTER flashuing eOS ? https://ecloud.global/s/MQpQtP2yCftLowD

Yes format data.

Tried as policy as permissive and it boots, but back to twrp on v1 and v2 zips

Enforcing doesn’t boot at all

Thanks for trying man!!

Ok, but bad :woozy_face:
Hope I will find a solution

OK, next try :slight_smile:

Back to treble errors when flashing

WTF. let me check …

EDIT: OK, treble was activated in new sources. will run new build later today

1 Like

Just coming back after the weekend
Thank you soooo much for this @harvey186… Really appreciate it
I’ll install the latest build today.
I’ve been using Bootleggers ROM but will gladly swap it for /e/!
I’ll wait till the evening, then.

Build fails at 77%
Will check tommorrow

Thank you :+1: I appreciate it so much :grin:

I think I have tried now all available sources. Here my (very) last result. I hope it will work, because there will be no other try. sorry.

And pls don’t forget to FORMAT data. A wipe is not enough.

EDIT: If it isn’t booting you can try 2 ways

  1. flash first oiginal LOS16 and the eOS
  2. flash first orignal MiUI stock rom, update til andoid 9 (if availabe) and than flash eOS

Thank you so much!
Am downloading now, will test later today

Thanks for trying man. I get the treble error again on the 14 04 build

coukd you try installing los16 from xda ??

Tried restoring to miui factory then format data and install. Same treble zip compatibility error. Tried los16 flash then format data and wipe, same error.

Thanks for the effort man. If you’re in a position to share steps how you built it I would love to tinker a bit more

Very bad :woozy_face:
I can share you the needed roomservice.xml and which changes I have done in device tree and my build script

1 Like