Mms not working

Hi.
Ok, I will try it at the first chance I get and report back.

Ok, so I have now tried a friend’s sim (from a different carrier) in my phone and still cannot send or receive mms photos.
My sim in their phone could, so we can rule out the sim.

I had the exact same problem, just got a new phone (Fairphone 3), installed latest /e/ and found MMS not working. SMS works, but not MMS. Attempts to send a photo via MMS results in “failed to send”. I have T-mobile service.

The solution, which I found in another forum, is to edit the T-mobile APN, and change the value for “APN Protocol” from the default “IPv6” to “IPv4/IPv6” instead. After making this one change, MMS is working for me. Hope this helps.

Doesn’t work for me. I ended up having to have 2 apn setups which I switch between as needed. One works for mms and the other for internet. Unfortunately neither works for both, hence the need to switch :frowning:

I face 1:1 the same Problem like above and troubleshhoted it down even with the Telco-Provider.
Everithing works fine exept recieving and sending MMS.

Its definitely not the SIM because any SIM does not send and recieve MMS and its not a wrong APN or Network Setting. And its not an issue of the MMS app which I tried a few with different SIM’s.

It must be a setting that is not available or changable somewhere in the Setting-Menu like it would be in other Android configurations.

One strange phanomena is also that any SIM (different Providers) does not get recognized everytime after a boot and on top of that the Internet-Connection does not work from time to time after booting even the LTE Symbol apears active.
Unselect and reselect the MobileData Icon (LTE) does the trick and it works from then.

It’s also questionable why the SIM tray does not allow to physically place the 2nd SIM. One SIM and one SD Card fits fine but the tray is something like 0.5mm to narrow that the 2nd SIM would fit in the space wehre the SD Card used to be.
The Samsung S9 manual shows clearly that and where it should fit in neatly.

Im using Samsung Galaxy palttforms ever since and usually i hat never HW or Firmeware issues or alike.

Does anyone have a clou, please?

I have the same problem (mms not sending nor receiving).
I have activated the developer option and have created an error report.
In this, I found the following error messages that may be related:

##-## ##:21:47.337 radio  4796 23069 D MmsService: [SendRequest@165d539] APN name is mms.eplus.de
##-## ##:21:47.338 radio  4796 23069 I MmsService: [SendRequest@165d539] Loading APN using name mms.eplus.de
##-## ##:21:47.350 radio  4796 23069 I MmsService: [SendRequest@165d539] Using APN [type=mms mmsc=http://mms/eplus/ mmsproxy=212.23.97.153 mmsport=5080 name=E-Plus MMS apn=mms.eplus.de bearer_bitmask=0 protocol=IP roaming_protocol=IP authtype=1 user=mms password=eplus
##-## ##:21:47.353 radio  4796 23069 D MmsService: [SendRequest@165d539] HTTP: POST http://mms[17], proxy=212.23.97.153:5080, PDU size=########
##-## ##:21:47.354 radio  4796 23069 I MmsService: [SendRequest@165d539] HTTP: User-Agent=LineageOS
##-## ##:21:47.354 radio  4796 23069 I MmsService: [SendRequest@165d539] HTTP: UaProfUrl=http://www.google.com/oha/rdf/ua-profile-kila.xml
##-## ##:21:47.359 radio  4796 23069 E MmsService: [SendRequest@165d539] HTTP: IO failure
##-## ##:21:47.359 radio  4796 23069 E MmsService: java.net.ConnectException: Failed to connect to /212.23.97.153:5080
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.io.RealConnection.connectSocket(RealConnection.java:143)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.io.RealConnection.connect(RealConnection.java:112)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.StreamAllocation.findConnection(StreamAllocation.java:184)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.StreamAllocation.findHealthyConnection(StreamAllocation.java:126)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.StreamAllocation.newStream(StreamAllocation.java:95)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.HttpEngine.connect(HttpEngine.java:281)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.HttpEngine.sendRequest(HttpEngine.java:224)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.huc.HttpURLConnectionImpl.execute(HttpURLConnectionImpl.java:461)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.huc.HttpURLConnectionImpl.connect(HttpURLConnectionImpl.java:127)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.huc.HttpURLConnectionImpl.getOutputStream(HttpURLConnectionImpl.java:258)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.MmsHttpClient.execute(MmsHttpClient.java:183)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.SendRequest.doHttp(SendRequest.java:83)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.MmsRequest.execute(MmsRequest.java:171)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.MmsService$2.run(MmsService.java:414)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1162)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:636)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at java.lang.Thread.run(Thread.java:764)
##-## ##:21:47.359 radio  4796 23069 D MmsService: [SendRequest@165d539] MmsNetworkManager: release, count=0
##-## ##:21:47.359 radio  4796 23069 E MmsService: [SendRequest@165d539] HTTP or network I/O failure
##-## ##:21:47.359 radio  4796 23069 E MmsService: com.android.mms.service.exception.MmsHttpException: java.net.ConnectException: Failed to connect to /212.23.97.153:5080
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.MmsHttpClient.execute(MmsHttpClient.java:225)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.SendRequest.doHttp(SendRequest.java:83)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.MmsRequest.execute(MmsRequest.java:171)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.MmsService$2.run(MmsService.java:414)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1162)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:636)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at java.lang.Thread.run(Thread.java:764)
##-## ##:21:47.359 radio  4796 23069 E MmsService: Caused by: java.net.ConnectException: Failed to connect to /212.23.97.153:5080
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.io.RealConnection.connectSocket(RealConnection.java:143)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.io.RealConnection.connect(RealConnection.java:112)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.StreamAllocation.findConnection(StreamAllocation.java:184)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.StreamAllocation.findHealthyConnection(StreamAllocation.java:126)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.StreamAllocation.newStream(StreamAllocation.java:95)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.HttpEngine.connect(HttpEngine.java:281)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.http.HttpEngine.sendRequest(HttpEngine.java:224)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.huc.HttpURLConnectionImpl.execute(HttpURLConnectionImpl.java:461)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.huc.HttpURLConnectionImpl.connect(HttpURLConnectionImpl.java:127)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.okhttp.internal.huc.HttpURLConnectionImpl.getOutputStream(HttpURLConnectionImpl.java:258)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	at com.android.mms.service.MmsHttpClient.execute(MmsHttpClient.java:183)
##-## ##:21:47.359 radio  4796 23069 E MmsService: 	... 6 more

There are some things that are strange:

  1. There is an ip address with a leading slash: /212.23.97.153:5080. That does not seems to be a valid representation.
  2. The address http://www.google.com/oha/rdf/ua-profile-kila.xml is not resolvable (404).
  3. There is a google address. /e/OS should be a Google-free OS, but I know that sometimes this cannot be completely prevented.

The points 2. and 3. doesn’t seem to be related to connectivity problems (look here).

Maybe related, maybe not:

##-## ##:21:25.717  1000  4334  4497 E ConnectivityService: Exception adding interface: java.lang.IllegalStateException: command '710 network interface add 113 rmnet0' failed with '400 710 addInterfaceToNetwork() failed (Device or resource busy)'
##-## ##:21:25.717  1000  4334  4497 E ConnectivityService: Exception in addRoute for non-gateway: java.lang.IllegalStateException: command '712 network route add 113 rmnet0 ###.###.###.###/32' failed with '400 712 addRoute() failed (No such file or directory)'
##-## ##:21:25.718  1000  4334  4497 E ConnectivityService: Exception in addRoute for gateway: java.lang.IllegalStateException: command '713 network route add 113 rmnet0 0.0.0.0/0 ###.###.###.###' failed with '400 713 addRoute() failed (No such file or directory)'

PS: I have replaced some information with # for more privacy.

Hej all !

I have the same issue, can’t send neither receive any MMS while Internet and SMS work fine.
I’ve a Murena Gigaset GS290 purchased from esolutions.shop…
Do anyone have a solution please ?

Thanks

I am not offering a solution, but I would be very interested to know if you are confident that you can have say 85% plus WiFi and mobile data at the same time when you try to send MMS - just a theory, perhaps some carriers need them synchronous.
This was a red herring. More to the point, a carrier service that provides MMS seems to be on different APN settings from the carrier’s standard service.

What seems to fix it for me (no guarantees) is to change to “Network” DNS and restart.

I prefer to use Quad9, so this “solution” is less than ideal. I stay on Quad9 until I see that I have some MMS that won’t download, then I do a temporary switch.

See: Problems Sending/Receiving MMS and Group Messages

Thanks all for your answers.
What worked for me is instead of having 2 APNs : one for internet and one for MMS as suggested by the operator (SFR), I made only one APN that groups the 2 configurations.

2 Likes

“I” solved the problem by contacting my operator. They said that I should send “mms” to a specific phone number so the current MMS settings are send to my phone. After that alone didn’t work, they said that there is an error that will last for one day and will disappear.
The next day, it starts working :partying_face:

2 Likes

You operator has an excellent customer service ! :smiley_cat:

My late research on the linked thread suggests that the “APN +MMS” setting is indeed the “combined” setting. Quite why it is not the default I do not know, but is seems the way things have gone.

… and carrier’s customer support love to give excellent service :slight_smile: one just has to ask them the correct question!

Maybe that enquiry to customer support should be:

My device works fine except MMS. Can you check for me if your default APN settings include MMS. {If no or uncertain…} Please can you send me the “other” APN settings which include MMS. {If no …} Why? Are they not available in my deal?

Thanks both for success reports! :slight_smile:

FINALLY! after the last system update, it seems to be working that I can both send/receive MMS messages and connect to internet via the browser, without having to change APN profile settings. Better late than never ?! Took just over a year as far as I can see, but we got there :wink:

Had to try myself! Yeah, it is working!! Step by step, nice work /e/team!!!

Bonjour,

Désolée mon niveau d’anglais est trop limité (pour les questions techniques encore plus …), je tente en français…

De mon coté non plus les mms ne fonctionnent pas, j’ai fait une re install de 0.19 avec easy installer suivi d’une maj aujourd’hui vers 0.22 après un plantage total hier de mon système sans que je sache pourquoi :(.
Mais tout est rentré dans l’ordre aujourd’hui :slight_smile: grace à l’aide bienveillante du desk support de /e/ à la newbie que je suis.

J’ai des problèmes avec les mms depuis le début de mon aventure avec /e/ (commencée avec l’achat d’un Murena gs290 prêt à l’emploi vendu sur esolution.shop), qui ont pourtant parfois fonctionné sans que je comprenne pourquoi, parfois en changeant d’appli de messagerie ça a été un temps puis de nouveau HS.

Aujourd’hui avec un système tout frais ça ne marche pas mieux.

Supprimer les APN n’est pas possible pour un certain nombre, les désactiver ne fonctionne pas (pas moyen de faire glisser le bouton), et ils sont très très nombreux : 18 !!.. et ceux indiqués par mon fai, sfr, sont bien présents.

J’ai aussi tenté un paramétrage différent des DNS comme indiqué ici, Problems Sending/Receiving MMS and Group Messages - #37 by marcdw , j’ai pu envoyer 1 mms puis après un nouvel essai ça bloque à nouveau sur “envoi” et pas moyen d’en recevoir non plus…

Pour ce qui est de combiner les 2 APN en 1, je ne comprends pas bien l’opération à réaliser, ajouter mms dans type d’APN des data, par exemple ??? Je veux bien quelques explications en plus sur la manip … (désolée suis pas douée … encore moins quand c’est en anglais … very sorry)

Voilà, je ne sais pas si le problème vient de /e/ ou d’ailleurs (fai, config…?), le télephone, les sms et internet fonctionnent et c’est l’essentiel. Je ne sais pas si je suis passée à coté de la réponse en anglais plus haut si c’est le cas désolée, c’est que je n’ai pas compris.

Hello,
Sorry my level of English is too limited (for technical questions even more…), this is machine translation…
On my side either the mms do not work, I made a reinstall of 0.19 with easy installer followed by a shift today to 0.22 after a total crash yesterday of my system without me knowing why :(. But everything is back in order today:) thanks to the benevolent help of the support desk of /e/ to the newbie that I am.
I have had problems with mms since the beginning of my adventure with /e/ (started with the purchase of a ready-to-use murena gs290 sold by esolution.shop), which have sometimes worked without me understanding why, sometimes by changing messaging app it was a time and then again not work.
Today with a fresh system it does not work better.
Deleting the APNs is not possible for a certain number, disabling them does not work (no way to drag the button), and they are very very numerous: 18 !!.. and those indicated by my ISP, sfr, are present. I also tried a different setting of dns as indicated here, Problems Sending/Receiving MMS and Group Messages - #37 by marcdw, I was able to send 1 mms then after a new try it blocks again on “send” and no way to receive either… As for combining the 2 cameras into 1, I do not understand the operation to perform, add mms in data APN type, for example??? I want some more explanations on the manip… (sorry I’m not good at it… even less so when it’s in English… very sorry)
I don’t know if the problem comes from /e/ or elsewhere (FAI, config…?), the phone, sms and internet work and that’s the main thing. I do not know if I missed the answer in English above if it is the case sorry, it is that I did not understand.

For me, absolutely the only thing that finally made MMS work was to enable Network DNS (i.e. the network provider’s default DNS service). I have Private DNS set to automatic, but I don’t think that has any effect on Network DNS.

Et en français:
Pour moi, la seule chose qui a permis aux MMS de fonctionner a été d’activer le Network DNS (c’est-à-dire le service DNS par défaut du fournisseur de réseau). J’ai réglé le DNS privé sur automatique, mais je ne pense pas que cela ait un quelconque effet sur le DNS réseau.

J’ai testé cette solution, ça a marché une fois et puis deuxième test, bah non …

I tested this solution, it worked once and then second test,… no…

1 Like

C’était bien un problème d’APN mal configuré, pour les frenchy, et SFR voir là :
It was indeed a problem of misconfigured APN, for the Frenchy, and SFR see there:

1 Like