Motorola - edge 30 - dubai - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

In the documentation asks you to download the latest /e/ ROM for example from one month ago.

But when flashing partitions you have to get the latest dtbo.img and vendor_boot.img from lineage which is usually newer than /e/ and the flashing will fail because it will detect it as a downgrade.

You should choose the one before the rom you downloaxed’

Thank you, Guillermo! In addition to your hint, I have two more troubleshooting tips to share with future readers…

Guillermo’s Hint: SPL Downgrade Workaround
As of 2023-07-09 there are four sub-folders in the flashing_additional_partitions section.

Initially I used these files, but encountered the SPL downgrade message (and failure):

  • 20230706/dtbo.img
  • 20230706/vendor_boot.img

I tried again with these files and was succesful:

  • 20230615/dtbo.img
  • 20230615/vendor_boot.img

I suspect this worked because the recovery image and installation files are dated eight days later.

  • recovery-e-1.12.3-s-20230616300623-dev-dubai.img

Therefore, if someone is reading this in the future, perhaps you can use a similar strategy in case the documentation has not been updated.

Signature Validation Error
It’s also worth noting that I received a signature validation error, for which I needed to acknowledge to bypass. Coincidentally, this appeared around 47%.

ERROR:    recovery: failed to verify whole-file signature
Update package verification took 100.6 s (result1).
ERROR:   recovery: Siganture verification failed
ERROR:   recovery: error: 21
Installing update...
Step 1/2

Based on this signature validation prompt, I’m not sure if I’ve done this correctly. This is the first time that I’ve ever successfully unlocked an Android phone and installed a ROM. I could never get my old Xiaomi phone to successfully unlock.

Try Unlocking from Motorola UK Site instead of US site
After purchasing the device, I needed to wait just three days for the OEM unlocking to become available, but Motorola’s US unlock site kept giving me a “Your device does not qualify for bootloader unlocking.” message. I had to join Lenovo’s forum, and they suggested using Motorola’s UK support site to unlock the device instead of the US one.
This worked!

Final Words
To any developers reading this, I want to say thank you for your efforts on adding support for the Motorola Edge 30 As a long-time Apple user, I recently learned about the e OS and wanted to give it a try. I chose this device because it was the newest ones on the supported device list available in my region. It was also surprising that it was 40% cheaper than the cheapest iPhone.

This process was relatively painless and it’s nice to have a modern device which I hope to get many years of use out of.

You may add in the documentation that you have to wait a few days before the “Unlock” option is available on brand new device.

For the workaround, it’s not always possible. For example today:
the last recovery image is recovery-e-1.14-s-20230818321663-dev-dubai.img => 2023/08/18
but the oldest image is from 2023/08/24

In the installation documentation, instead of downloading the dtbo.img and vendor_boot.img images from LineageOS, it will be more consistent to extract these item from the full image. In some case the version of these files corresponding to the /e/-os one may not be available.

The procedure is described in : OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #7 by bofh666

1. download [latest release of payload-dumper-go ]( to the same directory (*) where /e/OS build ZIP file is
2. open terminal an `cd` to (*) directory
3. extract payload: `unzip e-*-s-* payload.bin`
4. extract payload-dumper-go: `tar xzvf payload-dumper-go_1.2.2_linux_amd64.tar.gz payload-dumper-go`
5. run `./payload-dumper-go -partitions dtbo,vendor_boot -o . payload.bin` command — needed files will appear in (*) directory.
1 Like


In the upgrade documentation:

It will be nice to add one step in “Manually upgrading your dubai to T”:

  • Set you device in recovery mode

It is not possible to unpack/mount the img, the image is damaged, it says.

mount recovery-e-1.14-s-20230818321663-dev-dubai.img /mnt/eos/

mount: /mnt/eos: wrong fs type, bad option, bad superblock on /dev/loop2, missing codepage or helper program, or other error.

This is the best way how to do it in my view. It keeps things consistent.

Is there a way how to suggest or contribute the doc update? I am happy to make some PR or something to update the doc based on my latest experience.

Documentation instructions to extract dtbo.img and vendor_boot.img from e-recovery.img – #7386.