Motorola Moto G7 Plus Model: XT1965-T in USA, Bootloader Unlock?

@aibd @SuzieQ Any ideas? Motorola Moto G7 Plus Model: XT1965-T.

I hope this is a noob mistake. I can’t get the actual bootloader to unlock. In developer options it shows unlocked but in download mode it still shows locked. I am simply trying to get the data to provide to Motorola to unlock the bootloader as outlined HERE, but I can’t event get the key to provide to Motorola.

~$ adb reboot bootloader (boots to download mode)
~$ fastboot devices
Zxxxxxxxx6 fastboot
~$ fastboot oem get_unlock_data
(bootloader) slot-co: not found
(bootloader) slot-suffi: not found

(bootloader) ‘get_unlock_datas’ is not a supported oem command
(bootloader) See ‘fastboot oem help’
FAILED (remote failure)
finished. total time: 0.000s

  1. Yes, I have enabled OEM unlocking, developer settings as well as USB debugging.
  2. Yes, I have tried rebooting the phone, turning those developer settings on/off multiple times.
  3. Yes, “Fastboot Devices” does register my phone as actively connected.

What gives?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @egx470 first guess, Motorola drivers installed ?
Second guess, latest platform-tools.

I couldn’t find any (edit: Motorola drivers) for Linux. I did install them on a Windows machine but the command prompts are not giving me any info either.

I think it’s more complicated than that. With mine I had to get an unlock code from Motorola.
Have a look here

@vernr I have followed the directions but the device won’t communicate back the numbers/code needed to put into Motorola’s website for the unlocking process as seen in the picture below.

$ fastboot oem get_unlock_data


(bootloader) ‘get_unlock_datas’ is not a supported oem command
(bootloader) See ‘fastboot oem help’
FAILED (remote failure)

@vernr what Android version are you on? Are you running 9(Pie) or 10(Q)?

@aibd gave me some help, THANK YOU! I am getting schooled on Linux. Apple and Microsoft have made me lazy…gonna change that. Here is what I am getting now, very odd.

mintymac@mintymac:~$ adb reboot bootloader
mintymac@mintymac:~$ fastboot devices
Zxxxxxxxx6 fastboot
mintymac@mintymac:~/Desktop/platform-tools$ ./fastboot oem get_unlock_data
(my mistake was I wasn’t executing directly from the “platform-tools” directory location by not using the complete chain “/Desktop/platform-tools$ ./fastboot oem get_unlock_data”)

I press enter in the terminal and the cursor goes to the next line and just sits there like it is thinking/trying to communicate with the phone… so I still am not getting the decryption code I need to provide to Motorola but we are getting closer. Here is what shows on the bootloader logs on the G7:

It just sits like this and does not return any decryption/unlock codes like it is suppose to.

I’m gonna factory reset the phone and try again. Any other ideas on next steps?

It’s been a while since I unlocked my phone but do you need ./ in front of
fastboot oem get_unlock_data. Try without it.

1 Like

@vernr thanks for the reply. I have factory reset the phone and tried what you said, here is what it returns including the “BOOTLOADER LOGS” picture:

mintymac@mintymac:~$ cd /home/mintymac/Desktop/platform-tools
mintymac@mintymac:~/Desktop/platform-tools$ fastboot oem get_unlock_data
(bootloader) slot-co: not found
(bootloader) slot-suffi: not found

(bootloader) ‘get_unlock_datas’ is not a supported oem command
(bootloader) See ‘fastboot oem help’
FAILED (remote failure)
finished. total time: 0.000s

From what @aibd relayed to me, yes the “./” (reinforces to use the instruction “use from here”) tells the host device to look directly in the /Desktop/platform-tools portion of the directory (where I have Andriod SDK tools located) for the “fastboot” file. I am a Linux noob but determined to get good using it so I can get off the Apple/Microsoft crack.

EDIT: but to your point @vernr the Bootloader Log on the phone still shows “oem get_unlock_data” but… it returns the garbage above to the terminal. Clearly there is code we can’t see interfering with the unlock keys being returned to the terminal.

@vernr from @aibd 's directions given directly above I can tell the Linux box is communicating to the G7+ because of what shows up on the “BOOTLOADER LOGS” picture (on phone), in red white we see “cmd: oem get_unlock_data” show up after executing the Linux terminal command above. What appears to be happening is something is blocking the G7+ from communicating back the unlock code to the Linux terminal (or an update from Motorola removed the information needed for the unlock key).

Does anyone see something different?

I bought 3 of these phones at only USD$120 each to test and they were suppose to ship “Unlocked” with Android 9 (Pie) but they arrived with Android 10 (Q) and had to update OTA connect to the internet briefly to get the OEM Unlock un-greyed out. They were new phones, never used. Starting to look like I will need to request a return… its appearing they aren’t “Unlocked” just “Carrier Unlocked”.

@SuzieQ I wanted to be sure you saw this :point_up_2:t3: more bootloader locking garbage, this time from Motorola! :weary:

You are in the position of trying to deal with the supplier, to release the code. You are not hacking the phone, you are following their instructions! What do they say (come Monday morning)?

While you were there is would be good to check out your assertion that Android 10 is in some way more permanently locked than 9.

1 Like

@aibd I got to their (Motorola) tier 2 support today. They told me in no way will I be able to speak to anyone about unlocking the bootloader and that the only resource was the URL already posted in this thread with directions on how to unlock the bootloader as well as their online forms. I wouldn’t let them hang up on me and that is how I finally got to tier 2. We live behind the iron curtain of tech here in the USA. Looks like I will initiate a return on these. Before I do what should I do to have a look at your thought regarding Andriod 9 vs 10 regarding more permanently locked?

I just ordered 2 more direct from Motorola (these 3 were sold and shipped direct from Amazon). Once they arrive I will pick up here. @aibd let me know if there are any additional commands you want me to throw at this phone before I ship it back (Amazon has accepted my return already).

My “idea” came too late! You did well to get to tier 2, I also read that there was no talk
to a human! Sounds like a blocker.

1 Like

:rofl::rofl::rofl:, nice link.

I did get through to a human but they @aibd wouldn’t do anything to help. (April 17, I just called Motorola support again and got back to level 2. This time, after explaining what I am seeing in the terminal vs bootloader logs on the phone, they listened and scheduled a level 3 call back for Monday. I will report back) Thank you for your continued help! @aibd

1 Like

@aibd @vernr

Level 3 support linked me to a developer forum but I figured it out before they could respond.

I believe it was a driver issue as first asked by @aibd. If you look HERE Motorola doesn’t list drivers for a Linux box. I booted into MacOS and the terminal did return the key for Motorola’s website. I submitted the key and received an email back with the OEM unlock code. Hope this helps someone else out there. Thanks to you both.

platform-tools % ./fastboot devices
Zxxxxxx6 fastboot
platform-tools % ./fastboot oem unlock 2xxxxxxxxxxxxxxxx5
(bootloader) Bootloader is unlocked!
OKAY [ 0.879s]
Finished. Total time: 0.879s

1 Like